aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-06-19 06:27:36 +0800
committerjgh <jgh@FreeBSD.org>2012-06-19 06:27:36 +0800
commit72d6d8e51ca8304cd27bbec7f485939f45879720 (patch)
tree40d5a977a9ef8c0a0dc06884110200ee1fb6ca2a /net
parenteb322bb45df516848beaeef6f0325c3dc9590207 (diff)
downloadfreebsd-ports-gnome-72d6d8e51ca8304cd27bbec7f485939f45879720.tar.gz
freebsd-ports-gnome-72d6d8e51ca8304cd27bbec7f485939f45879720.tar.zst
freebsd-ports-gnome-72d6d8e51ca8304cd27bbec7f485939f45879720.zip
- Update to 1.0
- Use ports framework for build: - Bonus: Now honours CC/CFLAGS/LDFLAGS - Remove DISTNAME override - Update LICENSE (GPLv2 not GPLv1) - Mark MAKE_JOBS_SAFE - Patch Makefile to see $(CC) not "CC" when not verbose - Pet portlint (LICENSE order) - while here shift where arch is tested, and use MAN{1,8}PREFIX PR: ports/169154 (based on) Submitted by: koobs.freebsd@gmail.com Approved by: maintainer, leres@ee.lbl.gov
Diffstat (limited to 'net')
-rw-r--r--net/hostapd/Makefile39
-rw-r--r--net/hostapd/distinfo4
2 files changed, 21 insertions, 22 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index a3c46954a196..99a342c2d6f2 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -6,44 +6,43 @@
#
PORTNAME= hostapd
-PORTVERSION= 0.7.3
+PORTVERSION= 1.0
CATEGORIES= net
MASTER_SITES= http://hostap.epitest.fi/releases/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= leres@ee.lbl.gov
COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+LICENSE= GPLv2 BSD
+LICENSE_COMB= dual
+
USE_GMAKE= yes
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MAKE_JOBS_SAFE= yes
MAN1= hostapd_cli.1
MAN8= hostapd.8
-do-configure:
- ${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
-
-do-build:
- (cd ${WRKSRC}/hostapd && ${GMAKE})
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN1} ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN8} ${PREFIX}/man/man8
-
PLIST_FILES= sbin/hostapd \
sbin/hostapd_cli
-#MAKE_JOBS_SAFE= yes
-#MANCOMPRESSED= yes
-
-LICENSE= GPLv1 BSD
-LICENSE_COMB= dual
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|@$$(E) " CC " $$<|@$$(E) " $$(CC) " $$<|' \
+ ${BUILD_WRKSRC}/Makefile
+
+do-configure:
+ ${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN8} ${MAN8PREFIX}/man/man8
+
.include <bsd.port.post.mk>
diff --git a/net/hostapd/distinfo b/net/hostapd/distinfo
index 3a5799214c63..8029e5a9562f 100644
--- a/net/hostapd/distinfo
+++ b/net/hostapd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hostapd-0.7.3.tar.gz) = 31eb2781f37e1a4c27969d1594f8019c0ca87779349c099ab812833289961567
-SIZE (hostapd-0.7.3.tar.gz) = 1138869
+SHA256 (hostapd-1.0.tar.gz) = 002e9dcb7e46cf82b5900a2fcf92b30fc8cdfd32a72d7fd4488588f1c013dfcc
+SIZE (hostapd-1.0.tar.gz) = 1327943