aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-06-23 18:15:55 +0800
committerbarner <barner@FreeBSD.org>2005-06-23 18:15:55 +0800
commit7f05da468ba2a5521410bbec7e4771bdfd2850e1 (patch)
tree88cd7a64247e97db1434e5339b6e7d655d14b736 /net
parentabeb8264a5bccd76667cb2cff60d9cf715ad3911 (diff)
downloadfreebsd-ports-gnome-7f05da468ba2a5521410bbec7e4771bdfd2850e1.tar.gz
freebsd-ports-gnome-7f05da468ba2a5521410bbec7e4771bdfd2850e1.tar.zst
freebsd-ports-gnome-7f05da468ba2a5521410bbec7e4771bdfd2850e1.zip
Add gaim-latex 0.3, a gaim plugin to display LaTeX output in your IMs.
PR: 82542 Submitted by: Geoffrey Mainland <mainland@apeiron.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/gaim-latex/Makefile34
-rw-r--r--net/gaim-latex/distinfo2
-rw-r--r--net/gaim-latex/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9ea72dc2cabe..b67f011f6406 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -153,6 +153,7 @@
SUBDIR += fugu
SUBDIR += gacxtool
SUBDIR += gaim
+ SUBDIR += gaim-latex
SUBDIR += gaim-openq
SUBDIR += gaim-rss-reader
SUBDIR += gajim
diff --git a/net/gaim-latex/Makefile b/net/gaim-latex/Makefile
new file mode 100644
index 000000000000..cb82d54ff714
--- /dev/null
+++ b/net/gaim-latex/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Gaim-LaTeX
+# Date created: 2005-06-22
+# Whom: Geoffrey Mainland <mainland@apeiron.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latex
+PORTVERSION= 0.3
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+PKGNAMEPREFIX= gaim-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mainland@apeiron.net
+COMMENT= Display LaTeX output in your IMs
+
+BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim
+RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim \
+ latex:${PORTSDIR}/print/teTeX \
+ convert:${PORTSDIR}/graphics/ImageMagick
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+USE_BZIP2= yes
+
+PLIST_FILES= lib/gaim/LaTeX.so
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/LaTeX.so ${PREFIX}/lib/gaim
+
+.include <bsd.port.mk>
diff --git a/net/gaim-latex/distinfo b/net/gaim-latex/distinfo
new file mode 100644
index 000000000000..5ae7a50f84b5
--- /dev/null
+++ b/net/gaim-latex/distinfo
@@ -0,0 +1,2 @@
+MD5 (gaim-latex-0.3.tar.bz2) = e0ff7686b3e40a8f2e456785b0557a29
+SIZE (gaim-latex-0.3.tar.bz2) = 12903
diff --git a/net/gaim-latex/pkg-descr b/net/gaim-latex/pkg-descr
new file mode 100644
index 000000000000..46c46e0e7ddb
--- /dev/null
+++ b/net/gaim-latex/pkg-descr
@@ -0,0 +1,4 @@
+This is a plugin for Gaim that allows you to display LaTeX output in
+your IMs.
+
+WWW: http://sourceforge.net/projects/gaim-latex