aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-07-18 00:28:21 +0800
committerrafan <rafan@FreeBSD.org>2006-07-18 00:28:21 +0800
commit7ffb077518cfa092c5af310606a334e1d9337ac6 (patch)
tree50148daae00bdedb1e7cf2f9f7e2b4d714a932b3 /net
parent297734f517319039fdb9d93c938738c0264c2412 (diff)
downloadfreebsd-ports-gnome-7ffb077518cfa092c5af310606a334e1d9337ac6.tar.gz
freebsd-ports-gnome-7ffb077518cfa092c5af310606a334e1d9337ac6.tar.zst
freebsd-ports-gnome-7ffb077518cfa092c5af310606a334e1d9337ac6.zip
- Enhancement rc scripts, bump PORTREVISION
PR: ports/100421 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/quagga.sh.in18
-rw-r--r--net/quagga/files/watchquagga.sh.in9
3 files changed, 16 insertions, 13 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 5461edc9bf33..599986eb53a2 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/
diff --git a/net/quagga/files/quagga.sh.in b/net/quagga/files/quagga.sh.in
index 868b00db1d69..9a28950558b3 100644
--- a/net/quagga/files/quagga.sh.in
+++ b/net/quagga/files/quagga.sh.in
@@ -2,9 +2,7 @@
#
# PROVIDE: quagga
-# REQUIRE: netif routing mountcritlocal
-# BEFORE: NETWORKING
-# KEYWORD: shutdown
+# REQUIRE: NETWORKING
#
# Add the following line to /etc/rc.conf to enable quagga:
@@ -13,6 +11,10 @@
# You may also wish to use the following variables to fine-tune startup:
#quagga_flags="-d"
#quagga_daemons="zebra ripd ripngd ospfd ospf6d bgpd isisd"
+# Per daemon tuning may be done with daemon_name_flags
+#zebra_flags="-dP 0"
+#bgpd_flags="-dnrP 0" and so on
+#
#
# If the quagga daemons require additional shared libraries to start,
# use the following variable to run ldconfig(8) in advance:
@@ -34,12 +36,13 @@ stop_postcmd()
# set defaults
-quagga_enable=${quagga_enable:-"NO"}
-quagga_flags=${quagga_flags:-"-d"}
-quagga_daemons=${quagga_daemons:-"zebra ripd ripngd ospfd ospf6d bgpd isisd"}
-quagga_extralibs_path=${quagga_extralibs_path:-""}
load_rc_config $name
+: ${quagga_enable="NO"}
+: ${quagga_flags="-d"}
+: ${quagga_daemons="zebra ripd ripngd ospfd ospf6d bgpd isisd"}
+: ${quagga_extralibs_path=""}
+
quagga_cmd=$1
case "$1" in
@@ -72,5 +75,6 @@ for daemon in ${quagga_daemons}; do
if [ ${quagga_cmd} = "stop" -a -z $(check_process ${command}) ]; then
continue
fi
+ eval flags=\$\{${daemon}_flags:-\"${quagga_flags}\"\}
run_rc_command "$1"
done
diff --git a/net/quagga/files/watchquagga.sh.in b/net/quagga/files/watchquagga.sh.in
index d9af072e47f6..be31f48c1f70 100644
--- a/net/quagga/files/watchquagga.sh.in
+++ b/net/quagga/files/watchquagga.sh.in
@@ -2,9 +2,7 @@
#
# PROVIDE: watchquagga
-# REQUIRE: netif routing mountcritlocal quagga
-# BEFORE: NETWORKING
-# KEYWORD: shutdown
+# REQUIRE: NETWORKING quagga
#
# Add the following line to /etc/rc.conf to enable quagga:
@@ -30,10 +28,11 @@ stop_postcmd()
# set defaults
-watchquagga_enable=${watchquagga_enable:-"NO"}
-watchquagga_flags=${watchquagga_flags:-""}
load_rc_config $name
+: ${watchquagga_enable="NO"}
+: ${watchquagga_flags=""}
+
command=%%PREFIX%%/sbin/watchquagga
pidfile=%%LOCALSTATE_DIR%%/watchquagga.pid
run_rc_command "$1"