aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2017-10-10 01:25:02 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:42:06 +0800
commit80aa7ea35c091aab2d5a705b20eaa5b5be28aed2 (patch)
tree05ec012cdc950efc3eb78fe614b1ead59e64a5f8 /net
parent63961241f159e657129659536154c110f62c757d (diff)
downloadfreebsd-ports-gnome-80aa7ea35c091aab2d5a705b20eaa5b5be28aed2.tar.gz
freebsd-ports-gnome-80aa7ea35c091aab2d5a705b20eaa5b5be28aed2.tar.zst
freebsd-ports-gnome-80aa7ea35c091aab2d5a705b20eaa5b5be28aed2.zip
follow raw socket behaviour change on 11 and later.
Submitted by: guido
Diffstat (limited to 'net')
-rw-r--r--net/u6rd/Makefile2
-rw-r--r--net/u6rd/files/patch-main.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/net/u6rd/Makefile b/net/u6rd/Makefile
index 203e24e500b4..c94f580033e9 100644
--- a/net/u6rd/Makefile
+++ b/net/u6rd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= u6rd
PORTVERSION= 1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://ftp.scythe.jp/pub/u6rd/release/
diff --git a/net/u6rd/files/patch-main.c b/net/u6rd/files/patch-main.c
new file mode 100644
index 000000000000..c46e92bb392e
--- /dev/null
+++ b/net/u6rd/files/patch-main.c
@@ -0,0 +1,12 @@
+--- main.c.orig 2013-06-19 11:23:58 UTC
++++ main.c
+@@ -608,7 +608,8 @@ tun2raw(struct connection *c)
+ ip4 = (struct ipv4_header *)(buf - sizeof(*ip4));
+ ip4->ver_hlen = 4 << 4 | sizeof(*ip4) >> 2;
+ ip4->tos = ntohl(ip6->ver_class_label) >> 20 & 0xff;
+-#if defined(__OpenBSD__) || defined(__linux__)
++#if defined(__OpenBSD__) || defined(__linux__) || \
++ (defined(__FreeBSD__) && __FreeBSD_version >= 1100030)
+ ip4->len = htons(len + sizeof(*ip4));
+ #else
+ ip4->len = len + sizeof(*ip4);