aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-04-19 07:40:38 +0800
committerjgh <jgh@FreeBSD.org>2013-04-19 07:40:38 +0800
commit8275128dc9849b4a7deb47d54b4699befeddfbca (patch)
treec137baf819e86d3153a7d1f46aed2b56bed29ff2 /net
parent4876c9816e74ce4c0f7b0643ccd0f5e3fd155bf0 (diff)
downloadfreebsd-ports-gnome-8275128dc9849b4a7deb47d54b4699befeddfbca.tar.gz
freebsd-ports-gnome-8275128dc9849b4a7deb47d54b4699befeddfbca.tar.zst
freebsd-ports-gnome-8275128dc9849b4a7deb47d54b4699befeddfbca.zip
- update to 1.0.5 [1]
- adjust MASTER_SITES and project site (pkg-descr) [1] - while here add documentation support and rc service script - take maintainership Suggested by: eddy.vervest@xs4all.nl, software author [1] Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/htpdate/Makefile23
-rw-r--r--net/htpdate/distinfo4
-rw-r--r--net/htpdate/files/htpdate.in43
-rw-r--r--net/htpdate/pkg-descr2
4 files changed, 60 insertions, 12 deletions
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index b04048a8b881..40395a1573b1 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -1,18 +1,13 @@
-# New ports collection makefile for: htpdate
-# Date created: 9 Jun 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
-#
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
-#
PORTNAME= htpdate
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTVERSION= 1.0.5
CATEGORIES= net ipv6
-MASTER_SITES= http://www.clevervest.com/htp/archive/c/ \
+MASTER_SITES= http://www.vervest.org/htp/archive/c/ \
http://twekkel.home.xs4all.nl/htp/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jgh@FreeBSD.org
COMMENT= Time synchronization over http utility
LICENSE= GPLv2 # (or later)
@@ -23,9 +18,19 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
MANCOMPRESSED= yes
MAN8= ${PORTNAME}.8
PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= Changelog README
+USE_RC_SUBR= ${PORTNAME}
+
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8.gz ${MAN8PREFIX}/man/man8
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/net/htpdate/distinfo b/net/htpdate/distinfo
index 7b1ff07e6fc3..c1ae48564bb7 100644
--- a/net/htpdate/distinfo
+++ b/net/htpdate/distinfo
@@ -1,2 +1,2 @@
-SHA256 (htpdate-1.0.4.tar.bz2) = 2e1a4c0cc3a2f489b73b2f15f009067eb41af5a865e3d5701ba00f5cfb70ab57
-SIZE (htpdate-1.0.4.tar.bz2) = 16214
+SHA256 (htpdate-1.0.5.tar.bz2) = 80a714bf5222e05d88c673099ce3b1207d88db105a5ae6c761de0b2439528d73
+SIZE (htpdate-1.0.5.tar.bz2) = 16377
diff --git a/net/htpdate/files/htpdate.in b/net/htpdate/files/htpdate.in
new file mode 100644
index 000000000000..0a2e54476722
--- /dev/null
+++ b/net/htpdate/files/htpdate.in
@@ -0,0 +1,43 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+# PROVIDE: htpdate
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable htpdate:
+#
+# htpdate_enable="YES"
+
+
+. /etc/rc.subr
+
+load_rc_config htpdate
+
+htpdate_enable="${htpdate_enable:-"NO"}"
+htpdate_servers="${htpdate_servers:-"www.freebsd.org www.linux.com"}"
+
+name=htpdate
+rcvar=htpdate_enable
+servers=${htpdate_servers}
+pidfile=/var/run/htpdate.pid
+
+command="/usr/local/bin/htpdate"
+command_args="-l -s -D $servers"
+stop_cmd=htpdate_stop
+
+htpdate_stop ()
+{
+ if [ -f ${pidfile} ]; then
+ echo "Stopping htpdate."
+ kill `cat ${pidfile}`
+ else
+ echo "htpdate is not running."
+ fi
+
+ rm -f ${pidfile}
+}
+
+run_rc_command "$1"
diff --git a/net/htpdate/pkg-descr b/net/htpdate/pkg-descr
index 3f8c4339c00b..f64020004c07 100644
--- a/net/htpdate/pkg-descr
+++ b/net/htpdate/pkg-descr
@@ -6,4 +6,4 @@ computer synchronized.
Accuracy of htpdate is usually better than 0.5 seconds (even better with
multiple servers). Htpdate can also work through http proxy.
-WWW: http://www.clevervest.com/htp/
+WWW: http://www.vervest.org/htp/
td>pav2012-06-271-0/+2 * - Convert to new options frameworksunpoet2012-06-271-2/+3 * - Update E17 ports:makc2012-06-27105-158/+840 * - Update to 1.0.6madpilot2012-06-265-47/+17 * - Unbreak with LLVM 3.1fluffy2012-06-261-3/+1 * - reset MAINTAINERdinoex2012-06-261-1/+1 * - reset MAINTAINERdinoex2012-06-2613-13/+13 * - Update to 0.7-12tota2012-06-262-4/+3 * update WWWbf2012-06-261-1/+1 * - Update to 1.8.0wen2012-06-253-820/+995 * update cegui to 0.7.7oliver2012-06-253-26/+26 * Fix build on powerpc and sparc64.linimon2012-06-252-7/+15 * - Fix plist entrymva2012-06-251-1/+0 * - Update graphics/blender to version 2.63amva2012-06-253-128/+134 * - use OPTIONS_DEFINEdinoex2012-06-241-19/+15 * - fix dependecy for option GVEDITdinoex2012-06-242-70/+76 * - Add py-django-easy-thumbnails 1.0.3sunpoet2012-06-246-0/+194 * Remove non-existing WWW.kwm2012-06-241-2/+0 * fix build if tinyxml is installedoliver2012-06-241-1/+5 * update cegui to 0.7.6oliver2012-06-243-28/+28 * - update to 10.35.85dinoex2012-06-233-11/+10 * - update to 4.0.2dinoex2012-06-234-81/+5 * - Update to 2.83sunpoet2012-06-222-3/+3 * - remove extra dirdinoex2012-06-221-0/+1 * - Update to 2.82sunpoet2012-06-212-5/+3 * - strict python version to 2.x only (doesn't work with python3)rm2012-06-213-8/+9 * - update to 1.5.11dinoex2012-06-213-17/+11 * Remove BROKEN now that imlib is fixed.kwm2012-06-203-6/+0 * Fix unresolved symbol in library after giflib update.kwm2012-06-202-1/+22 * Update to 5.3.14flo2012-06-201-2/+0 * Only try to delete the module directories (they may not get created).mm2012-06-192-6/+6 * Disable HDRI by default. It fails the analyze.sh test on some systems.mm2012-06-191-1/+2 * - Mark BROKEN: does not configurepav2012-06-191-0/+2 * - bugfix USE_GETTEXTdinoex2012-06-191-2/+1 * - Fix configure [1]tota2012-06-191-2/+4 * - Update to 2.03sunpoet2012-06-182-5/+3 * - fix Unterminated quoted string on FreeBSD 9.xdinoex2012-06-183-9/+35 * - Mark BROKEN: does not compilepav2012-06-181-0/+2 * - Mark BROKEN: does not compilepav2012-06-181-0/+2 * - update to 1.5.1.5rm2012-06-183-32/+10 * - bugfix USE_GETTEXTdinoex2012-06-172-1/+2 * - make portlint happierdinoex2012-06-165-4/+38 * - remove OPTIONS_DEFAULTdinoex2012-06-161-1/+0 * - use OPTIONS_DEFINEdinoex2012-06-161-5/+6 * - use OPTIONS_DEFINEdinoex2012-06-161-6/+7 * - validate xmldinoex2012-06-151-3/+2 * - Register conflicts between signing-party/sig2dot/springgraphjohans2012-06-151-0/+2 * Switch to OptionsNgmartymac2012-06-151-1/+3 * - update to 0.8.10dinoex2012-06-156-113/+84 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-1530-45/+30 * - use OPTIONS_DEFINEdinoex2012-06-141-20/+21 * - Update to 8.0.3gahr2012-06-142-3/+3 * - Update to 3.8.0gahr2012-06-147-39/+69 * - Mark BROKEN: does not compilepav2012-06-143-0/+6 * - Mark BROKEN: does not compilepav2012-06-142-0/+4 * - Mark BROKEN: does not configurepav2012-06-141-0/+2 * fix the build when librsvg2 or ImageMagick is installedbf2012-06-131-14/+15 * also remove the -nox11 suffix from the djvulibre runtime dependencybf2012-06-131-1/+1 * update DjVuLibre to 3.5.25.3 and adjust dependent ports: the QT3 GUI that wasbf2012-06-13