aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorniels <niels@FreeBSD.org>2010-08-25 16:00:03 +0800
committerniels <niels@FreeBSD.org>2010-08-25 16:00:03 +0800
commit83e7e5ceba212983e4afc6b2868266302765b2bb (patch)
tree67ad567b3167929a2c3faaf7a141897b5ddf5b6c /net
parentb04b19754e665e4c6ad723ecb243aa124f23d75b (diff)
downloadfreebsd-ports-gnome-83e7e5ceba212983e4afc6b2868266302765b2bb.tar.gz
freebsd-ports-gnome-83e7e5ceba212983e4afc6b2868266302765b2bb.tar.zst
freebsd-ports-gnome-83e7e5ceba212983e4afc6b2868266302765b2bb.zip
- Security update to version 0.99.17
- This update also resolves functional problems of PR 148238 and 147970 PR: ports/149940 PR: ports/148238 PR: ports/147970 Approved by: itetcu (mentor, implicit), maintainer Submitted by: mike@sentex.net, maintainer Security: 167953a4-b01c-11df-9a98-0015587e2cc1 Security: http://www.openwall.com/lists/oss-security/2010/08/24/3
Diffstat (limited to 'net')
-rw-r--r--net/quagga/Makefile6
-rw-r--r--net/quagga/distinfo6
-rw-r--r--net/quagga/files/patch-configure10
-rw-r--r--net/quagga/files/patch-configure.ac57
4 files changed, 63 insertions, 16 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 27145ee15461..9db789fa9ccc 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= quagga
-PORTVERSION= 0.99.16
+PORTVERSION= 0.99.17
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
@@ -22,7 +22,7 @@ COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4, IS-IS route software
CONFLICTS= openbgpd-[0-9]* zebra-0*
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool:22 autoheader:262
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
@@ -46,7 +46,7 @@ OPTIONS= ISISD "Enable experimental ISIS daemon" off \
CFLAGS+= -I${LOCALBASE}/include
.if ${OSVERSION} >= 800000
-LDFLAGS+= -fstack-protector
+LDFLAGS+= -fstack-protector
.endif
CONFIGURE_ARGS+=--includedir=${PREFIX}/include --enable-exampledir=${PREFIX}/share/examples/quagga
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
diff --git a/net/quagga/distinfo b/net/quagga/distinfo
index abc371a53a9c..23560287d6ac 100644
--- a/net/quagga/distinfo
+++ b/net/quagga/distinfo
@@ -1,3 +1,3 @@
-MD5 (quagga-0.99.16.tar.gz) = 350fb150be526cdfc4d2b093cb4d69a7
-SHA256 (quagga-0.99.16.tar.gz) = 840e376bf42a3c5ee1069eedddb195749b1ebadeef6cacd9fee24ed6f44c35c5
-SIZE (quagga-0.99.16.tar.gz) = 2168417
+MD5 (quagga-0.99.17.tar.gz) = 37b9022adca04b03863d2d79787e643f
+SHA256 (quagga-0.99.17.tar.gz) = 1d77df121a334e9504b45e489ee7ce35bf478e27d33cd2793a23280b59d9efd4
+SIZE (quagga-0.99.17.tar.gz) = 2202151
diff --git a/net/quagga/files/patch-configure b/net/quagga/files/patch-configure
deleted file mode 100644
index 1f2a44f1f41c..000000000000
--- a/net/quagga/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig 2010-06-19 15:58:32.000000000 +0600
-+++ configure 2010-06-19 15:58:44.000000000 +0600
-@@ -25085,6 +25085,7 @@
- #if HAVE_NETINET_IP_ICMP_H
- # include <netinet/ip_icmp.h>
- #endif
-+#include <security/pam_types.h>
-
- "
- if test "x$ac_cv_header_security_openpam_h" = x""yes; then :
diff --git a/net/quagga/files/patch-configure.ac b/net/quagga/files/patch-configure.ac
new file mode 100644
index 000000000000..90103c026843
--- /dev/null
+++ b/net/quagga/files/patch-configure.ac
@@ -0,0 +1,57 @@
+--- configure.ac.orig 2010-08-19 11:36:29.000000000 +0200
++++ configure.ac 2010-08-25 09:06:04.000000000 +0200
+@@ -443,20 +443,6 @@
+ #endif /* TIME_WITH_SYS_TIME */
+ ])dnl
+
+-AC_CHECK_HEADERS([sys/un.h net/if.h netinet/in_systm.h netinet/in_var.h \
+- net/if_dl.h net/if_var.h net/netopt.h net/route.h \
+- inet/nd.h arpa/inet.h netinet/ip_icmp.h \
+- fcntl.h stddef.h sys/ioctl.h syslog.h wchar.h wctype.h \
+- sys/sysctl.h sys/sockio.h kvm.h sys/conf.h],
+- [], [], QUAGGA_INCLUDES)
+-
+-AC_CHECK_HEADERS([ucontext.h], [], [],
+-[#ifndef __USE_GNU
+-#define __USE_GNU
+-#endif /* __USE_GNU */
+-QUAGGA_INCLUDES
+-])
+-
+ m4_define([QUAGGA_INCLUDES],
+ QUAGGA_INCLUDES
+ [#if HAVE_NET_IF_H
+@@ -474,9 +460,6 @@
+ #if HAVE_NET_IF_DL_H
+ # include <net/if_dl.h>
+ #endif
+-#if HAVE_NET_IF_VAR_H
+-# include <net/if_var.h>
+-#endif
+ #if HAVE_NET_NETOPT_H
+ # include <net/netopt.h>
+ #endif
+@@ -493,8 +476,23 @@
+ #if HAVE_NETINET_IP_ICMP_H
+ # include <netinet/ip_icmp.h>
+ #endif
++#include <security/pam_types.h>
+ ])dnl
+
++AC_CHECK_HEADERS([sys/un.h net/if.h net/if_var.h net/if_dl.h \
++ netinet/in_systm.h netinet/in_var.h net/netopt.h net/route.h \
++ inet/nd.h arpa/inet.h netinet/ip_icmp.h \
++ fcntl.h stddef.h sys/ioctl.h syslog.h wchar.h wctype.h \
++ sys/sysctl.h sys/sockio.h kvm.h sys/conf.h],
++ [], [], QUAGGA_INCLUDES)
++
++AC_CHECK_HEADERS([ucontext.h], [], [],
++[#ifndef __USE_GNU
++#define __USE_GNU
++#endif /* __USE_GNU */
++QUAGGA_INCLUDES
++])
++
+ dnl V6 headers are checked below, after we check for v6
+
+ dnl Some systems (Solaris 2.x) require libnsl (Network Services Library)