aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2013-08-09 17:18:13 +0800
committerculot <culot@FreeBSD.org>2013-08-09 17:18:13 +0800
commit848b71f82dd8439db74b86e0e870589e6481075c (patch)
treecd2c70a067032474841c41b21f757e653e623a00 /net
parent592064dc990849c10a789136738d68306083b458 (diff)
downloadfreebsd-ports-gnome-848b71f82dd8439db74b86e0e870589e6481075c.tar.gz
freebsd-ports-gnome-848b71f82dd8439db74b86e0e870589e6481075c.tar.zst
freebsd-ports-gnome-848b71f82dd8439db74b86e0e870589e6481075c.zip
- Update to 1.13 [1]
- Trim Makefile's header [1] - Convert to new Uses/perl5.mk framework - Add LICENSE (MIT) Changes: http://search.cpan.org/dist/App-dropboxapi/Changes PR: ports/181111 [1] Submitted by: Andrew Childs <lorne@cons.org.nz> Approved by: Lung-Pin Chang <changlp@cs.nctu.edu.tw> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/dropbox-api-command/Makefile36
-rw-r--r--net/dropbox-api-command/distinfo4
2 files changed, 24 insertions, 16 deletions
diff --git a/net/dropbox-api-command/Makefile b/net/dropbox-api-command/Makefile
index a0785e2a335d..57a5c428cf97 100644
--- a/net/dropbox-api-command/Makefile
+++ b/net/dropbox-api-command/Makefile
@@ -1,39 +1,47 @@
-# New ports collection makefile for: dropbox-api-command
-# Date created: 2011-07-14
-# Whom: Lung-Pin Chang <changlp@cs.nctu.edu.tw>
-#
+# Created by: Lung-Pin Chang <changlp@cs.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= dropbox-api-command
-PORTVERSION= 1.05
+PORTVERSION= 1.13
PORTEPOCH= 1
CATEGORIES= net
MAINTAINER= changlp@cs.nctu.edu.tw
COMMENT= Dropbox API wrapper command
-RUN_DEPENDS= p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+LICENSE= MIT
+
+BUILD_DEPENDS= p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
p5-Encode-Locale>=0:${PORTSDIR}/converters/p5-Encode-Locale \
p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
- p5-WebService-Dropbox>=1.09:${PORTSDIR}/net/p5-WebService-Dropbox \
- p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
+ p5-WebService-Dropbox>=1.17:${PORTSDIR}/net/p5-WebService-Dropbox \
+ p5-Path-Class>=0.26:${PORTSDIR}/devel/p5-Path-Class
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GITHUB= yes
GH_ACCOUNT= s-aska
GH_TAGNAME= ${PORTVERSION}
-GH_COMMIT= cd3a707
+GH_COMMIT= 1c843ed
+
+USES= perl5
+USE_PERL5= configure
-NO_BUILD= yes
-USE_PERL5_RUN= yes
+# There is documentation contained in an otherwise empty library
+# (App::dropboxapi). In post-patch copy it over to the main
+# dropbox-api script so the perl build process makes a dropbox-api.1,
+# and override do-install to only copy the useful parts, i.e., not the
+# empty library.
+MAN1= dropbox-api.1
PLIST_FILES= bin/dropbox-api bin/upload-to-dropbox
post-patch:
${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/upload-to-dropbox
+ ${TAIL} +3 ${WRKSRC}/lib/App/dropboxapi.pm >> ${WRKSRC}/dropbox-api
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/dropbox-api ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/upload-to-dropbox ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/blib/man1/dropbox-api.1 ${PREFIX}/man/man1/
+ ${INSTALL_SCRIPT} ${WRKSRC}/blib/script/dropbox-api ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/upload-to-dropbox ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/net/dropbox-api-command/distinfo b/net/dropbox-api-command/distinfo
index 54a7a1bbf5fa..c854537bb152 100644
--- a/net/dropbox-api-command/distinfo
+++ b/net/dropbox-api-command/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dropbox-api-command-1.05.tar.gz) = a04c84f01dd77941ad46db162c4ed36caeace5f4601b5c9e932eb57335642fdc
-SIZE (dropbox-api-command-1.05.tar.gz) = 7524
+SHA256 (dropbox-api-command-1.13.tar.gz) = db42fa3d8a1788866d11f97e7422d221d606ea745c1398a5f6165f0364ef92a8
+SIZE (dropbox-api-command-1.13.tar.gz) = 11327