aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-06-05 17:40:21 +0800
committerfjoe <fjoe@FreeBSD.org>2010-06-05 17:40:21 +0800
commit86fc1bb65f50f364cc9f31b59ceaa726e2868659 (patch)
tree88aa1745714308a9cd4050002a4cd4c296ceeadf /net
parent2298df1a2711b77f9fe510160afe9554aab73e57 (diff)
downloadfreebsd-ports-gnome-86fc1bb65f50f364cc9f31b59ceaa726e2868659.tar.gz
freebsd-ports-gnome-86fc1bb65f50f364cc9f31b59ceaa726e2868659.tar.zst
freebsd-ports-gnome-86fc1bb65f50f364cc9f31b59ceaa726e2868659.zip
New ports:
- net/libfb - foneBRIDGE configuration library - net/fonulator - foneBRIDGE configuration utility
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/fonulator/Makefile47
-rw-r--r--net/fonulator/distinfo3
-rw-r--r--net/fonulator/pkg-descr3
-rw-r--r--net/libfb/Makefile34
-rw-r--r--net/libfb/distinfo3
-rw-r--r--net/libfb/pkg-descr3
-rw-r--r--net/libfb/pkg-plist7
8 files changed, 102 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e8184f932d40..c38f4c0882ba 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -143,6 +143,7 @@
SUBDIR += etunnel
SUBDIR += findmtu
SUBDIR += flowgrep
+ SUBDIR += fonulator
SUBDIR += forg
SUBDIR += fpc-pcap
SUBDIR += fping
@@ -308,6 +309,7 @@
SUBDIR += libdnet
SUBDIR += libevnet
SUBDIR += libexosip2
+ SUBDIR += libfb
SUBDIR += libfixbuf
SUBDIR += libgnetwork
SUBDIR += libgweather
diff --git a/net/fonulator/Makefile b/net/fonulator/Makefile
new file mode 100644
index 000000000000..a74879996b61
--- /dev/null
+++ b/net/fonulator/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: fonulator
+# Date created: 12 Jan 2010
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fonulator
+PORTVERSION= 2.0.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://support.red-fone.com/fonulator/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= A foneBRIDGE configuration utility
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV=\
+ CPPFLAGS="-I${LOCALBASE}/include ${LIBNET_CPPFLAGS}"\
+ LDFLAGS="${LIBNET_LIBS:N-l*}"
+CONFIGURE_ARGS= --disable-shared
+
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet\
+ ${LOCALBASE}/lib/libargtable2.a:${PORTSDIR}/devel/argtable\
+ ${LOCALBASE}/lib/libfb.a:${PORTSDIR}/net/libfb
+LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
+
+PLIST_FILES= bin/fonulator
+MAN1= fonulator.1
+
+post-patch:
+ @${REINPLACE_CMD}\
+ -e 's,/usr/lib/libargtable2.a,${LOCALBASE}/lib/libargtable2.a,'\
+ -e 's,/usr/lib/libnet.a,${LIBNET_LIBS:N-l*:S,-L,,}/libnet.a,'\
+ ${WRKSRC}/Makefile.in ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,/etc/redfone.conf,${LOCALBASE}/etc/redfone.conf,'\
+ ${WRKSRC}/fonulator.c ${WRKSRC}/fonulator.1
+
+.if 0
+# this does not work when LIBNET_CONFIG does not exist prior to building this port
+LIBNET_CPPFLAGS!= ${LIBNET_CONFIG} --cflags --defines
+LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
+.else
+LIBNET_CPPFLAGS= -I${LOCALBASE}/include/libnet11
+LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/fonulator/distinfo b/net/fonulator/distinfo
new file mode 100644
index 000000000000..1cd89dd22011
--- /dev/null
+++ b/net/fonulator/distinfo
@@ -0,0 +1,3 @@
+MD5 (fonulator-2.0.1.tar.gz) = c834ebbd77d3bb253c60c57b22623f74
+SHA256 (fonulator-2.0.1.tar.gz) = 4a550b2e4e413183f97585c2ef54ee752cd94bcc277c15faeceb46f1b2be3dfb
+SIZE (fonulator-2.0.1.tar.gz) = 661549
diff --git a/net/fonulator/pkg-descr b/net/fonulator/pkg-descr
new file mode 100644
index 000000000000..e98694b1cea4
--- /dev/null
+++ b/net/fonulator/pkg-descr
@@ -0,0 +1,3 @@
+A foneBRIDGE configuration utility.
+
+WWW: http://red-fone.com/
diff --git a/net/libfb/Makefile b/net/libfb/Makefile
new file mode 100644
index 000000000000..bc0548a1825e
--- /dev/null
+++ b/net/libfb/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libfb
+# Date created: 12 Jan 2010
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfb
+PORTVERSION= 2.0.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://support.red-fone.com/downloads/fonulator/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= A foneBRIDGE configuration library
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV=\
+ CPPFLAGS="${LIBNET_CPPFLAGS}"\
+ LDFLAGS="${LIBNET_LIBS:N-l*}"
+CONFIGURE_ARGS= --disable-shared
+
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
+
+.if 0
+# this does not work when LIBNET_CONFIG does not exist prior to building this port
+LIBNET_CPPFLAGS!= ${LIBNET_CONFIG} --cflags --defines
+LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
+.else
+LIBNET_CPPFLAGS= -I${LOCALBASE}/include/libnet11
+LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/libfb/distinfo b/net/libfb/distinfo
new file mode 100644
index 000000000000..e7d77cd72a68
--- /dev/null
+++ b/net/libfb/distinfo
@@ -0,0 +1,3 @@
+MD5 (libfb-2.0.0.tar.gz) = fa5b3afc6e5e0d90078f681654fae0f8
+SHA256 (libfb-2.0.0.tar.gz) = a31c05b74ee5b8896314629d00c95e22622ecdacc157ac2c83714b330c066af9
+SIZE (libfb-2.0.0.tar.gz) = 923533
diff --git a/net/libfb/pkg-descr b/net/libfb/pkg-descr
new file mode 100644
index 000000000000..939423708577
--- /dev/null
+++ b/net/libfb/pkg-descr
@@ -0,0 +1,3 @@
+A foneBRIDGE configuration library.
+
+WWW: http://red-fone.com/
diff --git a/net/libfb/pkg-plist b/net/libfb/pkg-plist
new file mode 100644
index 000000000000..e3ca3bb80ab3
--- /dev/null
+++ b/net/libfb/pkg-plist
@@ -0,0 +1,7 @@
+include/libfb/fb_config.h
+include/libfb/fb_context.h
+include/libfb/fb_lib.h
+include/libfb/sha1.h
+lib/libfb.a
+lib/libfb.la
+@dirrm include/libfb