aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /net
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'net')
-rw-r--r--net/coda6_server/Makefile1
-rw-r--r--net/freeswitch-core-devel/Makefile2
-rw-r--r--net/freeswitch-core/Makefile2
-rw-r--r--net/net6/Makefile2
-rw-r--r--net/netembryo/Makefile3
-rw-r--r--net/radvd/Makefile2
-rw-r--r--net/samba34/Makefile4
-rw-r--r--net/samba35/Makefile4
-rw-r--r--net/samba36/Makefile4
-rw-r--r--net/tapidbus/Makefile2
10 files changed, 10 insertions, 16 deletions
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index 3be810de8d83..a0385e627c3f 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= lwp.2:${PORTSDIR}/devel/lwp \
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_PKGCONFIG= yes
CONFIGURE_ARGS+= --enable-${CODA_SUITE}
diff --git a/net/freeswitch-core-devel/Makefile b/net/freeswitch-core-devel/Makefile
index d3751f8d2025..cc2cbe5b8fe0 100644
--- a/net/freeswitch-core-devel/Makefile
+++ b/net/freeswitch-core-devel/Makefile
@@ -34,7 +34,6 @@ EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}.tar.bz2
MAINTAINER= r.neese@gmail.com
COMMENT= FreeSwitch SoftSwitch Port
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff \
@@ -49,6 +48,7 @@ USE_AUTOTOOLS= autoconf:env automake:env libtool:env
USE_PERL5_BUILD=yes
USE_BISON= both
+USE_PKGCONFIG= yes
USE_GMAKE= yes
SUB_FILES= pkg-install
USE_RC_SUBR= freeswitch
diff --git a/net/freeswitch-core/Makefile b/net/freeswitch-core/Makefile
index 1373b71af681..65acf40c09c2 100644
--- a/net/freeswitch-core/Makefile
+++ b/net/freeswitch-core/Makefile
@@ -34,7 +34,6 @@ EXTRACT_ONLY= ${BASE_PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= r.neese@gmail.com
COMMENT= FreeSwitch SoftSwitch Port
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff \
@@ -48,6 +47,7 @@ USE_AUTOTOOLS= autoconf:env automake:env libtool:env
USE_PERL5_BUILD=yes
USE_BISON= both
+USE_PKGCONFIG= yes
USE_GMAKE= yes
SUB_FILES= pkg-install pkg-message
USE_RC_SUBR= freeswitch
diff --git a/net/net6/Makefile b/net/net6/Makefile
index bdac2d27b167..544cbce56c6e 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -15,7 +15,6 @@ COMMENT= Network access framework for IPv4/IPv6
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
gnutls.47:${PORTSDIR}/security/gnutls
@@ -23,6 +22,7 @@ USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 9f1fac89867f..46ad12ee9916 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -15,12 +15,11 @@ COMMENT= A network abstraction library used by for feng, libnemesi, felix
LICENSE= LGPL21
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
USE_GNOME= gnomehack
.include <bsd.port.mk>
diff --git a/net/radvd/Makefile b/net/radvd/Makefile
index fe4e5f8166a8..1bc27a796b64 100644
--- a/net/radvd/Makefile
+++ b/net/radvd/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://www.litech.org/radvd/dist/
MAINTAINER= dhn@FreeBSD.org
COMMENT= A Linux/BSD IPv6 router advertisement daemon
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= daemon.0:${PORTSDIR}/devel/libdaemon
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name=
USE_GMAKE= yes
+USE_PKGCONFIG= yes
USE_RC_SUBR= radvd
MAN5= radvd.conf.5
diff --git a/net/samba34/Makefile b/net/samba34/Makefile
index 4b3c3b34053f..161b31054985 100644
--- a/net/samba34/Makefile
+++ b/net/samba34/Makefile
@@ -72,9 +72,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
-PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-CONFIGURE_ENV+= PKG_CONFIG="${PKG_CONFIG}"
-BUILD_DEPENDS+= ${PKG_CONFIG}:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
# Let process generate meaningful backtrace on a core dump
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
# Always use external libtalloc
diff --git a/net/samba35/Makefile b/net/samba35/Makefile
index 31ceac51caef..1de11db2b2cf 100644
--- a/net/samba35/Makefile
+++ b/net/samba35/Makefile
@@ -80,9 +80,7 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
-PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-CONFIGURE_ENV+= PKG_CONFIG="${PKG_CONFIG}"
-BUILD_DEPENDS+= ${PKG_CONFIG}:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
# Let process generate meaningful backtrace on a core dump
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
# tdb
diff --git a/net/samba36/Makefile b/net/samba36/Makefile
index f44648578cca..46593eeaf2db 100644
--- a/net/samba36/Makefile
+++ b/net/samba36/Makefile
@@ -83,9 +83,7 @@ CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" \
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
-PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-CONFIGURE_ENV+= PKG_CONFIG="${PKG_CONFIG}"
-BUILD_DEPENDS+= ${PKG_CONFIG}:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
# Let process generate meaningful backtrace on a core dump
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
# tdb
diff --git a/net/tapidbus/Makefile b/net/tapidbus/Makefile
index e225d6aa32e0..9c13650c3b2e 100644
--- a/net/tapidbus/Makefile
+++ b/net/tapidbus/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= SF/tapioca-voip/OldFiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Abstraction layer for interprocess communication
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
@@ -22,6 +21,7 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}