aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2002-02-22 02:40:21 +0800
committerobrien <obrien@FreeBSD.org>2002-02-22 02:40:21 +0800
commit900700f27332b1fb90d056566457e3b9925f3a01 (patch)
tree5082ae8e99339cb146ad59de36addeaa099c92a2 /net
parent93b11deb7754ffc18c64bc3faef63ebf12cdfe31 (diff)
downloadfreebsd-ports-gnome-900700f27332b1fb90d056566457e3b9925f3a01.tar.gz
freebsd-ports-gnome-900700f27332b1fb90d056566457e3b9925f3a01.tar.zst
freebsd-ports-gnome-900700f27332b1fb90d056566457e3b9925f3a01.zip
Add vendor patch to correctly drop group privileges when changing uid.
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile2
-rw-r--r--net/rsync/files/patch-clientserver.c27
2 files changed, 28 insertions, 1 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 1d7b9cdd9943..4e069da83e1f 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rsync
PORTVERSION= 2.5.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://samba.anu.edu.au/pub/rsync/ \
ftp://sunsite.auc.dk/pub/unix/rsync/ \
diff --git a/net/rsync/files/patch-clientserver.c b/net/rsync/files/patch-clientserver.c
new file mode 100644
index 000000000000..9385abb3caf7
--- /dev/null
+++ b/net/rsync/files/patch-clientserver.c
@@ -0,0 +1,27 @@
+--- clientserver.c 7 Feb 2002 16:36:12 -0000 1.82
++++ clientserver.c 21 Feb 2002 00:45:48 -0000 1.86
+@@ -282,6 +285,24 @@
+ }
+
+ if (am_root) {
++ /* Get rid of any supplementary groups this process
++ * might have inheristed. */
++ if (setgroups(0, NULL)) {
++ rsyserr(FERROR, errno, "setgroups failed");
++ io_printf(fd, "@ERROR: setgroups failed\n");
++ return -1;
++ }
++
++ /* XXXX: You could argue that if the daemon is started
++ * by a non-root user and they explicitly specify a
++ * gid, then we should try to change to that gid --
++ * this could be possible if it's already in their
++ * supplementary groups. */
++
++ /* TODO: Perhaps we need to document that if rsyncd is
++ * started by somebody other than root it will inherit
++ * all their supplementary groups. */
++
+ if (setgid(gid)) {
+ rsyserr(FERROR, errno, "setgid %d failed", (int) gid);
+ io_printf(fd,"@ERROR: setgid failed\n");