aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-30 04:53:10 +0800
committermiwi <miwi@FreeBSD.org>2008-11-30 04:53:10 +0800
commit901472b31e216672bdd1b1d8502d88966f0c79b4 (patch)
tree2353ba9ffbf55df009867ecaa9b94313789eac1e /net
parent5f27c057c206928d0fb70874d55cbc138025ab34 (diff)
downloadfreebsd-ports-gnome-901472b31e216672bdd1b1d8502d88966f0c79b4.tar.gz
freebsd-ports-gnome-901472b31e216672bdd1b1d8502d88966f0c79b4.tar.zst
freebsd-ports-gnome-901472b31e216672bdd1b1d8502d88966f0c79b4.zip
pecl-oauth is a php interface to the oauth protocol.
Oauth is an authorization protocol built on top of HTTP which allows applications to securely access data without having to store usernames and passwords. WWW: http://pecl.php.net/package/oauth/ PR: ports/129167 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pecl-oauth/Makefile28
-rw-r--r--net/pecl-oauth/distinfo3
-rw-r--r--net/pecl-oauth/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8e27b14d7228..936cbd91e81e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -693,6 +693,7 @@
SUBDIR += pear-XML_RPC2
SUBDIR += pecl-cvsclient
SUBDIR += pecl-geoip
+ SUBDIR += pecl-oauth
SUBDIR += pecl-radius
SUBDIR += pecl-yaz
SUBDIR += pen
diff --git a/net/pecl-oauth/Makefile b/net/pecl-oauth/Makefile
new file mode 100644
index 000000000000..4a8bf56a33a4
--- /dev/null
+++ b/net/pecl-oauth/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pecl-oauth
+# Date created: 25 Nov 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oauth
+PORTVERSION= 0.99.1
+CATEGORIES= net pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Php Interface to the OAuth Protocol
+
+BUILD_DEPENDS= ${LOCALBASE}/include/curl/curl.h:${PORTSDIR}/ftp/curl
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/net/pecl-oauth/distinfo b/net/pecl-oauth/distinfo
new file mode 100644
index 000000000000..91f83975b4ff
--- /dev/null
+++ b/net/pecl-oauth/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/oauth-0.99.1.tgz) = 8b828ac3f202f537fabc62c6a72feda4
+SHA256 (PECL/oauth-0.99.1.tgz) = d09cd5d0cf397db5da3a49c6fb94275ddc234e8555c77710dcf9510536e32415
+SIZE (PECL/oauth-0.99.1.tgz) = 12517
diff --git a/net/pecl-oauth/pkg-descr b/net/pecl-oauth/pkg-descr
new file mode 100644
index 000000000000..9da4a1e33c5e
--- /dev/null
+++ b/net/pecl-oauth/pkg-descr
@@ -0,0 +1,6 @@
+pecl-oauth is a php interface to the oauth protocol.
+Oauth is an authorization protocol built on top of
+HTTP which allows applications to securely access
+data without having to store usernames and passwords.
+
+WWW: http://pecl.php.net/package/oauth/