aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2006-11-30 16:39:58 +0800
committerdelphij <delphij@FreeBSD.org>2006-11-30 16:39:58 +0800
commit9107a477188a12324a8d82e101887ba19fc6c13c (patch)
treedfd14ffb546206fc2e98377f1ad626d31eca0721 /net
parenta83589d422c5809442a82b6f7a04b7f8598b48d7 (diff)
downloadfreebsd-ports-gnome-9107a477188a12324a8d82e101887ba19fc6c13c.tar.gz
freebsd-ports-gnome-9107a477188a12324a8d82e101887ba19fc6c13c.tar.zst
freebsd-ports-gnome-9107a477188a12324a8d82e101887ba19fc6c13c.zip
o Respect PTHREAD_LIBS=ANY (like -lthr). [1]
o Use Berkeley DB 4.4, as suggested by OpenLDAP developers. Submitted by: nork [1]
Diffstat (limited to 'net')
-rw-r--r--net/openldap23-server/Makefile6
-rw-r--r--net/openldap24-server/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 18f1e829cdae..e6632674a8ab 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -39,7 +39,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 0
+PORTREVISION_SERVER= 1
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" on \
@@ -78,6 +78,8 @@ OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
OPENLDAP_PKGFILESUFX=
.endif
+CONFIGURE_SED= -e 's,-kthread,${PTHREAD_LIBS},g'
+
.include <bsd.port.pre.mk>
.if defined(CLIENT_ONLY)
@@ -269,7 +271,7 @@ PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB="@comment "
.else
-WITH_BDB_VER?= 43
+WITH_BDB_VER?= 44
USE_BDB= yes
.if ${WITH_BDB_VER} >= 42
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 74e6a0af4141..3cc16faef1f4 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -39,7 +39,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 0
+PORTREVISION_SERVER= 1
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" on \
@@ -85,6 +85,8 @@ OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
OPENLDAP_PKGFILESUFX=
.endif
+CONFIGURE_SED= -e 's,-kthread,${PTHREAD_LIBS},g'
+
.include <bsd.port.pre.mk>
.if defined(CLIENT_ONLY)
@@ -286,7 +288,7 @@ PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB="@comment "
.else
-WITH_BDB_VER?= 43
+WITH_BDB_VER?= 44
USE_BDB= yes
.if ${WITH_BDB_VER} >= 42