aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2008-02-29 08:46:40 +0800
committerleeym <leeym@FreeBSD.org>2008-02-29 08:46:40 +0800
commit968403267d30ae0e7a2988abdb81f3b482cbeddd (patch)
tree7e269da93dbaf57d1056023859e2543ef1300516 /net
parent44ba03a6f34abb7240e45b34a11f8d2823b0fad3 (diff)
downloadfreebsd-ports-gnome-968403267d30ae0e7a2988abdb81f3b482cbeddd.tar.gz
freebsd-ports-gnome-968403267d30ae0e7a2988abdb81f3b482cbeddd.tar.zst
freebsd-ports-gnome-968403267d30ae0e7a2988abdb81f3b482cbeddd.zip
- update to 20071102
- fix dependency
Diffstat (limited to 'net')
-rw-r--r--net/p5-S3/Makefile22
-rw-r--r--net/p5-S3/distinfo6
-rw-r--r--net/p5-S3/pkg-plist1
3 files changed, 17 insertions, 12 deletions
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index bfe8f09c479a..ab28b6c26664 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -6,21 +6,19 @@
#
PORTNAME= S3
-PORTVERSION= 20070518
+PORTVERSION= 20071102
CATEGORIES= net perl5
-MASTER_SITES= http://developer.amazonwebservices.com/connect/servlet/KbServlet/download/%SUBDIR%/
-MASTER_SITE_SUBDIR= 133-102-1292
+MASTER_SITES= http://s3.amazonaws.com/doc/s3-example-code/
PKGNAMEPREFIX= p5-
DISTNAME= s3-example-perl-library
MAINTAINER= perl@FreeBSD.org
COMMENT= A library in Perl for working with the Amazon S3 REST interface
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC\
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS= p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
USE_PERL5_RUN= yes
@@ -33,4 +31,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/S3.pm ${PREFIX}/${SITE_PERL_REL}
${INSTALL_SCRIPT} ${WRKSRC}/s3-*.pl ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-S3/distinfo b/net/p5-S3/distinfo
index 3ee48a1753bb..574e01d34773 100644
--- a/net/p5-S3/distinfo
+++ b/net/p5-S3/distinfo
@@ -1,3 +1,3 @@
-MD5 (s3-example-perl-library.zip) = fd130dac6ce43b9624ea24a82a2be51d
-SHA256 (s3-example-perl-library.zip) = 49d4e75e813241a35df8954bd61dadf57a762e5f6119fa32acdc291ca4b49a53
-SIZE (s3-example-perl-library.zip) = 17112
+MD5 (s3-example-perl-library.zip) = baa2456a2cddf526ac1cb173e4671dc0
+SHA256 (s3-example-perl-library.zip) = 180e906340f1c98a6ae411727bad0bf3308c34107f6f802e97e50c368239641f
+SIZE (s3-example-perl-library.zip) = 18750
diff --git a/net/p5-S3/pkg-plist b/net/p5-S3/pkg-plist
index 3291339d0131..696f791a2489 100644
--- a/net/p5-S3/pkg-plist
+++ b/net/p5-S3/pkg-plist
@@ -4,6 +4,7 @@
%%SITE_PERL%%/S3/GetResponse.pm
%%SITE_PERL%%/S3/ListAllMyBucketsResponse.pm
%%SITE_PERL%%/S3/ListBucketResponse.pm
+%%SITE_PERL%%/S3/LocationResponse.pm
%%SITE_PERL%%/S3/QueryStringAuthGenerator.pm
%%SITE_PERL%%/S3/Response.pm
%%SITE_PERL%%/S3/S3Object.pm