aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-31 11:04:32 +0800
committerclsung <clsung@FreeBSD.org>2006-07-31 11:04:32 +0800
commita8fe4af728f7a790c29a806618174c1652567ef7 (patch)
tree5a9f995e65c29663f46010e86224b90aee5103a2 /net
parentfd5c16b109d393ff6400966ea76b757b6c210014 (diff)
downloadfreebsd-ports-gnome-a8fe4af728f7a790c29a806618174c1652567ef7.tar.gz
freebsd-ports-gnome-a8fe4af728f7a790c29a806618174c1652567ef7.tar.zst
freebsd-ports-gnome-a8fe4af728f7a790c29a806618174c1652567ef7.zip
Add p5-POE-Component-Client-Telnet 0.06, a POE component that provides
non-blocking access to Net::Telnet. PR: ports/101072 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-POE-Component-Client-Telnet/Makefile33
-rw-r--r--net/p5-POE-Component-Client-Telnet/distinfo3
-rw-r--r--net/p5-POE-Component-Client-Telnet/pkg-descr7
-rw-r--r--net/p5-POE-Component-Client-Telnet/pkg-plist10
5 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2f5c43b5b296..853fdaecaecc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -488,6 +488,7 @@
SUBDIR += p5-POE-Component-Client-Ident
SUBDIR += p5-POE-Component-Client-Keepalive
SUBDIR += p5-POE-Component-Client-Ping
+ SUBDIR += p5-POE-Component-Client-Telnet
SUBDIR += p5-POE-Component-ControlPort
SUBDIR += p5-POE-Component-Jabber
SUBDIR += p5-POE-Component-Pcap
diff --git a/net/p5-POE-Component-Client-Telnet/Makefile b/net/p5-POE-Component-Client-Telnet/Makefile
new file mode 100644
index 000000000000..672e4c8ef398
--- /dev/null
+++ b/net/p5-POE-Component-Client-Telnet/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-POE-Component-Client-Telnet
+# Date created: 2006-07-31
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Telnet
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@Pluto.CDPA.nsysu.edu.tw
+COMMENT= A POE component that provides non-blocking access to Net::Telnet
+
+BUILD_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet \
+ ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::Telnet.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500602
+BUILD_DEPENDS+= p5-Test-Simple>=0.32:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-POE-Component-Client-Telnet/distinfo b/net/p5-POE-Component-Client-Telnet/distinfo
new file mode 100644
index 000000000000..0a8838c273bf
--- /dev/null
+++ b/net/p5-POE-Component-Client-Telnet/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Client-Telnet-0.06.tar.gz) = 90eca1ffae98b57eb4db9b5cbd828db1
+SHA256 (POE-Component-Client-Telnet-0.06.tar.gz) = 6b8b9b09f1da2bd9c7b28e36b662c29486c139867079aea301880647adecc832
+SIZE (POE-Component-Client-Telnet-0.06.tar.gz) = 6685
diff --git a/net/p5-POE-Component-Client-Telnet/pkg-descr b/net/p5-POE-Component-Client-Telnet/pkg-descr
new file mode 100644
index 000000000000..a0c0f4fbedd1
--- /dev/null
+++ b/net/p5-POE-Component-Client-Telnet/pkg-descr
@@ -0,0 +1,7 @@
+POE::Component::Client::Telnet is a POE component that provides
+a non-blocking wrapper around Net::Telnet, or any other module
+based on Net::Telnet.
+
+Consult the Net::Telnet documentation for more details.
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-Telnet/
diff --git a/net/p5-POE-Component-Client-Telnet/pkg-plist b/net/p5-POE-Component-Client-Telnet/pkg-plist
new file mode 100644
index 000000000000..72ef2621330d
--- /dev/null
+++ b/net/p5-POE-Component-Client-Telnet/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Telnet/.packlist
+%%SITE_PERL%%/POE/Component/Client/Telnet.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Telnet
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE