aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2010-05-30 06:20:30 +0800
committerwxs <wxs@FreeBSD.org>2010-05-30 06:20:30 +0800
commita9b9ce95ba115a2aae0fe73784df1d2621067c33 (patch)
treefa081d2be184ac85d25e28c46a12b371c307afb1 /net
parentddbf098920d81df34b8315fcb5382a0a5634130c (diff)
downloadfreebsd-ports-gnome-a9b9ce95ba115a2aae0fe73784df1d2621067c33.tar.gz
freebsd-ports-gnome-a9b9ce95ba115a2aae0fe73784df1d2621067c33.tar.zst
freebsd-ports-gnome-a9b9ce95ba115a2aae0fe73784df1d2621067c33.zip
net/isc-dhcp41-client:
- Set the default dhclient-script and dhclient.conf properly. PR: ports/146608 Submitted by: Craig Leres <leres@ee.lbl.gov>
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp41-server/Makefile3
-rw-r--r--net/isc-dhcp41-server/files/patch-client__Makefile.in18
2 files changed, 18 insertions, 3 deletions
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index d46824204c42..266eef3a5f2b 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= wxs@FreeBSD.org
COMMENT?= The ISC Dynamic Host Configuration Protocol server
PORTREVISION_SERVER= 1
-PORTREVISION_CLIENT= 0
+PORTREVISION_CLIENT= 1
PORTREVISION_RELAY= 0
SUBSYS?= server
@@ -51,6 +51,7 @@ GROUPS= dhcpd
MAN_COMPRESSED= no
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-D_PATH_DHCLIENT_SCRIPT='\"${PREFIX}/sbin/dhclient-script\"' -D_PATH_DHCLIENT_CONF='\"${PREFIX}/etc/dhclient.conf\"'"
SCRIPTS_ENV+= PKG_PREFIX=${PREFIX}
.if ${SUBSYS} == client
diff --git a/net/isc-dhcp41-server/files/patch-client__Makefile.in b/net/isc-dhcp41-server/files/patch-client__Makefile.in
index 9c9f72ebe548..cb02e370fe5d 100644
--- a/net/isc-dhcp41-server/files/patch-client__Makefile.in
+++ b/net/isc-dhcp41-server/files/patch-client__Makefile.in
@@ -1,5 +1,5 @@
---- ./client/Makefile.in.orig 2010-01-07 19:47:06.000000000 -0500
-+++ ./client/Makefile.in 2010-05-02 20:38:26.000000000 -0400
+--- client/Makefile.in.orig 2010-01-07 19:47:06.000000000 -0500
++++ client/Makefile.in 2010-05-29 17:24:48.814048529 -0400
@@ -351,8 +351,8 @@
@list='$(dist_sysconf_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
@@ -11,3 +11,17 @@
done
uninstall-dist_sysconfDATA:
+@@ -537,11 +537,11 @@
+
+
+ dhclient.o: dhclient.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=/sbin:/usr/sbin:$(sbindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhclient.c
+
+ dhc6.o: dhc6.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=/sbin:/usr/sbin:$(sbindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.