aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-12 17:46:09 +0800
committeradamw <adamw@FreeBSD.org>2003-06-12 17:46:09 +0800
commitaaf166713559a44a8e20404e1e6eb14e1758a66b (patch)
tree001522fb512c55afb05368bed1bedb1a54f687a4 /net
parentbdac09a776abef8765f436443280f4aa3ba8ca0f (diff)
downloadfreebsd-ports-gnome-aaf166713559a44a8e20404e1e6eb14e1758a66b.tar.gz
freebsd-ports-gnome-aaf166713559a44a8e20404e1e6eb14e1758a66b.tar.zst
freebsd-ports-gnome-aaf166713559a44a8e20404e1e6eb14e1758a66b.zip
Remove REINPLACE commands that were rolled into gnomehack.
Diffstat (limited to 'net')
-rw-r--r--net/gabber/Makefile4
-rw-r--r--net/gnet-glib2/Makefile3
-rw-r--r--net/gnet2/Makefile3
-rw-r--r--net/gnomeicu/Makefile4
-rw-r--r--net/gnomeicu/gnomeicu/Makefile4
-rw-r--r--net/gnomeicu2/Makefile4
-rw-r--r--net/netspeed_applet/Makefile4
7 files changed, 2 insertions, 24 deletions
diff --git a/net/gabber/Makefile b/net/gabber/Makefile
index b87859dc8129..1f78219a1f8e 100644
--- a/net/gabber/Makefile
+++ b/net/gabber/Makefile
@@ -39,10 +39,6 @@ MAN1= gabber.1
BROKEN= "Crashes or hangs on 5.x"
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
pre-build:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
diff --git a/net/gnet-glib2/Makefile b/net/gnet-glib2/Makefile
index 2ccdb23ae2eb..9c5e6137aacf 100644
--- a/net/gnet-glib2/Makefile
+++ b/net/gnet-glib2/Makefile
@@ -23,9 +23,6 @@ CONFIGURE_ARGS= --enable-glib2
MAN1= gnet-glib2-config.1
post-patch:
-# fix pthreads detection
- @${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
# remove "release" information from lib name
@${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
${WRKSRC}/src/Makefile.in
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
index 2ccdb23ae2eb..9c5e6137aacf 100644
--- a/net/gnet2/Makefile
+++ b/net/gnet2/Makefile
@@ -23,9 +23,6 @@ CONFIGURE_ARGS= --enable-glib2
MAN1= gnet-glib2-config.1
post-patch:
-# fix pthreads detection
- @${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
# remove "release" information from lib name
@${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
${WRKSRC}/src/Makefile.in
diff --git a/net/gnomeicu/Makefile b/net/gnomeicu/Makefile
index 9a6204ef53b4..de8333584590 100644
--- a/net/gnomeicu/Makefile
+++ b/net/gnomeicu/Makefile
@@ -44,8 +44,4 @@ CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/net/gnomeicu/gnomeicu/Makefile b/net/gnomeicu/gnomeicu/Makefile
index b7b8d81008c1..a84f5de3c166 100644
--- a/net/gnomeicu/gnomeicu/Makefile
+++ b/net/gnomeicu/gnomeicu/Makefile
@@ -46,9 +46,7 @@ CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|gnet|gnet-glib2|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|gnet|gnet-glib2|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|GNOME_PARAM_GNOME_DATADIR|GNOME_PARAM_APP_DATADIR|g' \
${WRKSRC}/src/gnomeicu.c
diff --git a/net/gnomeicu2/Makefile b/net/gnomeicu2/Makefile
index b7b8d81008c1..a84f5de3c166 100644
--- a/net/gnomeicu2/Makefile
+++ b/net/gnomeicu2/Makefile
@@ -46,9 +46,7 @@ CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|gnet|gnet-glib2|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|gnet|gnet-glib2|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|GNOME_PARAM_GNOME_DATADIR|GNOME_PARAM_APP_DATADIR|g' \
${WRKSRC}/src/gnomeicu.c
diff --git a/net/netspeed_applet/Makefile b/net/netspeed_applet/Makefile
index 9210c825aeae..ec535dc426a8 100644
--- a/net/netspeed_applet/Makefile
+++ b/net/netspeed_applet/Makefile
@@ -23,8 +23,4 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>