aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2014-06-11 02:28:06 +0800
committerume <ume@FreeBSD.org>2014-06-11 02:28:06 +0800
commitb09f46b5f2bf583a6842467941ba7aa8ed675aef (patch)
tree58648f8b563a680463e93b1d602cf971e99ee127 /net
parent96c8bd0db5d58a3390f407fa0fe51bd43d8d20bc (diff)
downloadfreebsd-ports-gnome-b09f46b5f2bf583a6842467941ba7aa8ed675aef.tar.gz
freebsd-ports-gnome-b09f46b5f2bf583a6842467941ba7aa8ed675aef.tar.zst
freebsd-ports-gnome-b09f46b5f2bf583a6842467941ba7aa8ed675aef.zip
- Stagefy.
- Add LICENSE.
Diffstat (limited to 'net')
-rw-r--r--net/jwhois/Makefile15
-rw-r--r--net/jwhois/pkg-plist14
2 files changed, 13 insertions, 16 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index b4f9957aff51..c4b062584e34 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -12,14 +12,14 @@ MASTER_SITE_SUBDIR= jwhois
MAINTAINER= ports@FreeBSD.org
COMMENT=An improved WHOIS client capable of selecting server to query
+LICENSE= GPLv3
+
GNU_CONFIGURE= yes
USES= gettext gmake
CPPFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
CONFIGURE_ARGS= --localstatedir=${PREFIX}/var/jwhois
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
@@ -33,8 +33,6 @@ PLIST_SUB= NLS="@comment "
INSTALL_TARGET= install-strip
-MANLANG= "" sv
-MAN1= jwhois.1
INFO= jwhois
.include <bsd.port.pre.mk>
@@ -46,12 +44,7 @@ JWHOIS_CONF_SRC=${WRKSRC}/example/jwhois.conf
.endif
post-install:
- ${MKDIR} ${PREFIX}/var/jwhois
- ${CHOWN} :nogroup ${PREFIX}/var/jwhois
- ${CHMOD} g+w ${PREFIX}/var/jwhois
- ${CHOWN} :nogroup ${PREFIX}/bin/jwhois
- ${CHMOD} g+s ${PREFIX}/bin/jwhois
- ${INSTALL_DATA} ${JWHOIS_CONF_SRC} ${PREFIX}/etc/jwhois.conf.sample
- if [ ! -f ${PREFIX}/etc/jwhois.conf ]; then ${INSTALL_DATA} ${PREFIX}/etc/jwhois.conf.sample ${PREFIX}/etc/jwhois.conf; fi
+ ${MKDIR} ${STAGEDIR}${PREFIX}/var/jwhois
+ ${INSTALL_DATA} ${JWHOIS_CONF_SRC} ${STAGEDIR}${PREFIX}/etc/jwhois.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/jwhois/pkg-plist b/net/jwhois/pkg-plist
index f7edc204179d..b2e5f12cc54a 100644
--- a/net/jwhois/pkg-plist
+++ b/net/jwhois/pkg-plist
@@ -1,7 +1,7 @@
bin/jwhois
-@unexec if cmp -s %D/etc/jwhois.conf %D/etc/jwhois.conf.sample; then rm -f %D/etc/jwhois.conf; fi
-etc/jwhois.conf.sample
-@exec if [ ! -f %B/jwhois.conf ]; then cp %B/%f %B/jwhois.conf; fi
+@sample etc/jwhois.conf.sample
+man/man1/jwhois.1.gz
+man/sv/man1/jwhois.1.gz
%%NLS%%share/locale/es/LC_MESSAGES/jwhois.mo
%%NLS%%share/locale/fr/LC_MESSAGES/jwhois.mo
%%NLS%%share/locale/hu/LC_MESSAGES/jwhois.mo
@@ -17,13 +17,17 @@ etc/jwhois.conf.sample
%%NLS%%share/locale/tr/LC_MESSAGES/jwhois.mo
%%NLS%%share/locale/vi/LC_MESSAGES/jwhois.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/jwhois.mo
+@exec mkdir -p %D/var 2>/dev/null || true
+@group nogroup
+@mode 775
@exec mkdir -p %D/var/jwhois 2>/dev/null || true
-@exec chown :nogroup %D/var/jwhois
-@exec chmod g+w %D/var/jwhois
@unexec rm -f %D/var/jwhois/jwhois.db 2>/dev/null || true
@dirrmtry var/jwhois
+@group wheel
+@mode 755
@dirrmtry var
@dirrmtry man/sv/man1
@dirrmtry man/sv
@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/rw 2>/dev/null || true
+@mode 444