aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2012-09-20 22:21:34 +0800
committertj <tj@FreeBSD.org>2012-09-20 22:21:34 +0800
commitb1f0acf9f0709b752a7d168399aa98a8acf2e901 (patch)
tree786e60cb1e52b77d54d02aa62c1f78bb41eb679f /net
parented8df9fe3a362b2602ebfeab93b6fa441433be35 (diff)
downloadfreebsd-ports-gnome-b1f0acf9f0709b752a7d168399aa98a8acf2e901.tar.gz
freebsd-ports-gnome-b1f0acf9f0709b752a7d168399aa98a8acf2e901.tar.zst
freebsd-ports-gnome-b1f0acf9f0709b752a7d168399aa98a8acf2e901.zip
This module provides an object oriented client interface to interact
with servers supporting STOMP (Streaming Text Orientated Messaging Protocol). It supports the major features of messaging brokers: SSL, asynchronous I/O, receipts and transactions. For details on the protocol see http://stomp.codehaus.org/Protocol. WWW: http://search.cpan.org/dist/Net-STOMP-Client/ Approved by: db (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-STOMP-Client/Makefile28
-rw-r--r--net/p5-Net-STOMP-Client/distinfo2
-rw-r--r--net/p5-Net-STOMP-Client/pkg-descr8
-rw-r--r--net/p5-Net-STOMP-Client/pkg-plist17
5 files changed, 56 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 82523a433c2b..c80fa4d6ee74 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -663,6 +663,7 @@
SUBDIR += p5-Net-SSH-Expect
SUBDIR += p5-Net-SSH-Perl
SUBDIR += p5-Net-SSH2
+ SUBDIR += p5-Net-STOMP-Client
SUBDIR += p5-Net-Server
SUBDIR += p5-Net-Server-Coro
SUBDIR += p5-Net-Server-SS-PreFork
diff --git a/net/p5-Net-STOMP-Client/Makefile b/net/p5-Net-STOMP-Client/Makefile
new file mode 100644
index 000000000000..1bd5def96024
--- /dev/null
+++ b/net/p5-Net-STOMP-Client/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= Net-STOMP-Client
+PORTVERSION= 1.7
+CATEGORIES= net-im perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Streaming Text Orientated Messaging Protocol Client
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::STOMP::Client.3 \
+ Net::STOMP::Client::Connection.3 \
+ Net::STOMP::Client::Debug.3 \
+ Net::STOMP::Client::Error.3 \
+ Net::STOMP::Client::Frame.3 \
+ Net::STOMP::Client::IO.3 \
+ Net::STOMP::Client::OO.3 \
+ Net::STOMP::Client::Peer.3 \
+ Net::STOMP::Client::Protocol.3 \
+ Net::STOMP::Client::Tutorial.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-STOMP-Client/distinfo b/net/p5-Net-STOMP-Client/distinfo
new file mode 100644
index 000000000000..b4a98d0ea2f8
--- /dev/null
+++ b/net/p5-Net-STOMP-Client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-STOMP-Client-1.7.tar.gz) = 1f7ec8ea5d67063028590b269dcde558f47faae78ae5ede0f842a2ba899e9d7c
+SIZE (Net-STOMP-Client-1.7.tar.gz) = 38502
diff --git a/net/p5-Net-STOMP-Client/pkg-descr b/net/p5-Net-STOMP-Client/pkg-descr
new file mode 100644
index 000000000000..a24bf376ea7d
--- /dev/null
+++ b/net/p5-Net-STOMP-Client/pkg-descr
@@ -0,0 +1,8 @@
+This module provides an object oriented client interface to interact
+with servers supporting STOMP (Streaming Text Orientated Messaging
+Protocol). It supports the major features of messaging brokers: SSL,
+asynchronous I/O, receipts and transactions.
+
+For details on the protocol see http://stomp.codehaus.org/Protocol.
+
+WWW: http://search.cpan.org/dist/Net-STOMP-Client/
diff --git a/net/p5-Net-STOMP-Client/pkg-plist b/net/p5-Net-STOMP-Client/pkg-plist
new file mode 100644
index 000000000000..e6665fdf0ab1
--- /dev/null
+++ b/net/p5-Net-STOMP-Client/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Net/STOMP/Client.pm
+%%SITE_PERL%%/Net/STOMP/Client/Connection.pm
+%%SITE_PERL%%/Net/STOMP/Client/Debug.pm
+%%SITE_PERL%%/Net/STOMP/Client/Error.pm
+%%SITE_PERL%%/Net/STOMP/Client/Frame.pm
+%%SITE_PERL%%/Net/STOMP/Client/IO.pm
+%%SITE_PERL%%/Net/STOMP/Client/OO.pm
+%%SITE_PERL%%/Net/STOMP/Client/Peer.pm
+%%SITE_PERL%%/Net/STOMP/Client/Protocol.pm
+%%SITE_PERL%%/Net/STOMP/Client/Tutorial.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STOMP/Client/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STOMP/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STOMP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/STOMP/Client
+@dirrmtry %%SITE_PERL%%/Net/STOMP
+@dirrmtry %%SITE_PERL%%/Net