aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2013-05-17 10:00:55 +0800
committerwxs <wxs@FreeBSD.org>2013-05-17 10:00:55 +0800
commitb562111bdd61c3840f626320737adda483c35cef (patch)
tree5d254da12f9cd301b68822a0501c3ae629f2fb90 /net
parent396b1c122e65ac24d403bf7c8a6af9af6dffa4f8 (diff)
downloadfreebsd-ports-gnome-b562111bdd61c3840f626320737adda483c35cef.tar.gz
freebsd-ports-gnome-b562111bdd61c3840f626320737adda483c35cef.tar.zst
freebsd-ports-gnome-b562111bdd61c3840f626320737adda483c35cef.zip
libnids-libnet11 is a slave port of libnids that specifically uses libnet11.
This is required because vortex needs libnids built with libnet11 while other ports (dsniff) needs libnids built with libnet10.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libnids-libnet11/Makefile17
-rw-r--r--net/libnids-libnet11/pkg-descr13
-rw-r--r--net/libnids/Makefile8
4 files changed, 38 insertions, 1 deletions
diff --git a/net/Makefile b/net/Makefile
index 91429f6c9f95..b6d26466b016 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -330,6 +330,7 @@
SUBDIR += libnetdude
SUBDIR += libnfs
SUBDIR += libnids
+ SUBDIR += libnids-libnet11
SUBDIR += libnss-mysql
SUBDIR += liboauth
SUBDIR += libopennet
diff --git a/net/libnids-libnet11/Makefile b/net/libnids-libnet11/Makefile
new file mode 100644
index 000000000000..30a92b7871d7
--- /dev/null
+++ b/net/libnids-libnet11/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -libnet11
+
+COMMENT= Network monitoring library with TCP/IP reassembly using libnet11
+
+MASTERDIR= ${.CURDIR}/../libnids
+
+DESCR= ${.CURDIR}/pkg-descr
+
+WITH_LIBNET11= yes
+
+CONFLICTS?= libnids-[0-9]*
+
+DISTINFO_FILE= ${MASTERDIR}/distinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/libnids-libnet11/pkg-descr b/net/libnids-libnet11/pkg-descr
new file mode 100644
index 000000000000..d82ad8ad56e0
--- /dev/null
+++ b/net/libnids-libnet11/pkg-descr
@@ -0,0 +1,13 @@
+Libnids is a library that provides the function of one of the NIDS
+(Network Intrusion Detection System) components, namely E-component. The
+libnids code watches all local network traffic, processes received
+datagrams a bit, and provides convenient information on them to analyzing
+modules. Libnids performs:
+
+a) assembly of TCP segments into TCP streams
+b) IP defragmentation
+c) TCP port scan detection
+
+This slave port builds with libnet11 by default.
+
+WWW: http://libnids.sf.net
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 59f9f1112165..6f360d6859d7 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -7,15 +7,21 @@ CATEGORIES= net security
MASTER_SITES= SF
MAINTAINER= wxs@FreeBSD.org
-COMMENT= Network monitoring library with TCP/IP reassembly
+COMMENT?= Network monitoring library with TCP/IP reassembly
LICENSE= GPLv2
+CONFLICTS?= libnids-libnet11-[0-9]*
+
OPTIONS_DEFINE= LIBNET10 LIBNET11 GLIB2
LIBNET10_DESC= Use libnet 1.0.x
LIBNET11_DESC= Use libnet 1.1.x
GLIB2_DESC= Use GLIB2 for multiprocessing support
+.if defined(WITH_LIBNET11)
+OPTIONS_DEFAULT= LIBNET11 GLIB2
+.else
OPTIONS_DEFAULT= LIBNET10 GLIB2
+.endif
WANT_GNOME= yes
USES= pkgconfig