aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2007-08-26 19:05:00 +0800
committeraz <az@FreeBSD.org>2007-08-26 19:05:00 +0800
commitb8e1f9abe4766f1feb1b0b0708baf51b79930ad3 (patch)
treed00cf0f84b510a37acc794083033257e3490b620 /net
parent4c1e9d44129c058a9f9688412d54666f1d1066cc (diff)
downloadfreebsd-ports-gnome-b8e1f9abe4766f1feb1b0b0708baf51b79930ad3.tar.gz
freebsd-ports-gnome-b8e1f9abe4766f1feb1b0b0708baf51b79930ad3.tar.zst
freebsd-ports-gnome-b8e1f9abe4766f1feb1b0b0708baf51b79930ad3.zip
- Implement new option -t <integer value in seconds>(*).
- bump PORTREVISION (*) Since program was drop connections every six hours, this option provide mechanism to override default constant. PR: ports/115420 Submitted by: SeaD <sead at mail.ru> Approved by: maintainer (timeout)
Diffstat (limited to 'net')
-rw-r--r--net/bounce/Makefile2
-rw-r--r--net/bounce/files/patch-0458
2 files changed, 59 insertions, 1 deletions
diff --git a/net/bounce/Makefile b/net/bounce/Makefile
index 9bac16f1afaa..45386ecf108a 100644
--- a/net/bounce/Makefile
+++ b/net/bounce/Makefile
@@ -8,7 +8,7 @@
PORTNAME= bounce
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net security
MASTER_SITES= http://www.iagora.com/~espel/ \
${MASTER_SITE_LOCAL}
diff --git a/net/bounce/files/patch-04 b/net/bounce/files/patch-04
new file mode 100644
index 000000000000..a2910794d148
--- /dev/null
+++ b/net/bounce/files/patch-04
@@ -0,0 +1,58 @@
+--- bounce.c.orig Sun Aug 26 14:24:58 2007
++++ bounce.c Sun Aug 26 14:34:57 2007
+@@ -31,6 +31,7 @@
+ #define DEFAULT_PORT 1523
+
+ char sbuf[16384], cbuf[16384];
++int t=0;
+
+ void sigchld() {
+ signal(SIGCHLD, sigchld);
+@@ -46,12 +47,15 @@
+
+ struct itimerval itime;
+
++ if (t)
++ {
+ itime.it_interval.tv_sec=0;
+ itime.it_interval.tv_usec=0;
+- itime.it_value.tv_sec=21600;
++ itime.it_value.tv_sec=t;
+ itime.it_value.tv_usec=0;
+ setitimer(ITIMER_REAL,&itime,NULL);
+ /* arbitrary connection time limit: 6 hours (in case the client hangs) */
++ }
+
+ chead=ctail=cbuf;
+ cpos=0;
+@@ -153,7 +157,7 @@
+
+ /* Process arguments */
+
+- while( (ch = getopt(argc, argv, "p:a:b:d")) != -1 ) {
++ while( (ch = getopt(argc, argv, "p:a:b:d:t:")) != -1 ) {
+ switch(ch) {
+ case 'b': b = 1;
+ case 'd': d = 1; break;
+@@ -172,6 +176,12 @@
+ exit(-1);
+ }
+ break;
++ case 't':
++ if ((t=atoi(optarg)) == 0) {
++ fprintf(stderr, "Bad timer value.\n");
++ exit(-1);
++ }
++ break;
+ }
+ }
+
+@@ -179,7 +189,7 @@
+ argv += optind;
+
+ if (argc!=2) {
+- fprintf(stderr,"Use: %s [-a localaddr | -b localaddr] [-p localport] [-d] machine port \n",myname);
++ fprintf(stderr,"Use: %s [-a localaddr | -b localaddr] [-d] [-p localport] [-t timer] machine port \n",myname);
+ exit(-1);
+ }
+ if ((remoteport=atoi(argv[1]))<=0) {