aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /net
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'net')
-rw-r--r--net/ssvnc/Makefile4
-rw-r--r--net/tightvnc/Makefile3
2 files changed, 4 insertions, 3 deletions
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
index 1f630dce97ea..d04dfc303a48 100644
--- a/net/ssvnc/Makefile
+++ b/net/ssvnc/Makefile
@@ -13,7 +13,6 @@ COMMENT= Enhanced TightVNC Viewer (SSVNC: SSL/SSH VNC viewer)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= stunnel:${PORTSDIR}/security/stunnel \
xterm:${PORTSDIR}/x11/xterm
@@ -21,6 +20,7 @@ RUN_DEPENDS= stunnel:${PORTSDIR}/security/stunnel \
OPTIONS_DEFINE= ULTRAFTP DOCS
ULTRAFTP_DESC= UltraVNC File Transfer support (Java required)
+USES= imake:env
USE_XORG= xi xmu xt xaw ice xpm xext sm
USE_TK_WRAPPER= yes
USE_PERL5_RUN= yes
@@ -55,7 +55,7 @@ post-patch:
.endif
do-configure:
- @cd ${WRKSRC} && ${GMAKE} config
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} config
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 69cf3d362939..4e06e1311140 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -22,10 +22,11 @@ CONFLICTS= tridiavnc-[0-9]* vnc-[0-9]*
WRKSRC= ${WRKDIR}/vnc_unixsrc
+USES= imake
+CFLAGS+= -Wno-return-type
USE_GCC= yes
USE_BZIP2= yes
USE_PERL5= yes
-USE_IMAKE= yes
USE_XORG= xaw
ALL_TARGET= World
NO_INSTALL_MANPAGES= yes