aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2011-07-10 11:24:46 +0800
committerdougb <dougb@FreeBSD.org>2011-07-10 11:24:46 +0800
commitba5a2a48ab901dd519edf720fc029a8b3666c9b7 (patch)
tree96f65b10e99226bad09b22367ed7995a899d326b /net
parent2463ea03e7c3f482c97f28ee5c650ee8ab3882f7 (diff)
downloadfreebsd-ports-gnome-ba5a2a48ab901dd519edf720fc029a8b3666c9b7.tar.gz
freebsd-ports-gnome-ba5a2a48ab901dd519edf720fc029a8b3666c9b7.tar.zst
freebsd-ports-gnome-ba5a2a48ab901dd519edf720fc029a8b3666c9b7.zip
Expand CONFLICTS to handle isc-dhcp42 and beyond
Prompted by: sunpoet
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp31-server/Makefile6
-rw-r--r--net/isc-dhcp41-server/Makefile6
2 files changed, 6 insertions, 6 deletions
diff --git a/net/isc-dhcp31-server/Makefile b/net/isc-dhcp31-server/Makefile
index 65279cc3d5fc..27be8bcfc35a 100644
--- a/net/isc-dhcp31-server/Makefile
+++ b/net/isc-dhcp31-server/Makefile
@@ -41,15 +41,15 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
# PORTREVISION handling
.if ${SUBSYS} == client
-CONFLICTS= isc-dhcp41-client*
+CONFLICTS= isc-dhcp4[1-9]-client*
DHCP_PORTREVISION= ${PORTREVISION_CLIENT}
.elif ${SUBSYS} == relay
-CONFLICTS= isc-dhcp41-relay*
+CONFLICTS= isc-dhcp4[1-9]-relay*
DHCP_PORTREVISION= ${PORTREVISION_RELAY}
.elif ${SUBSYS} == devel
DHCP_PORTREVISION= ${PORTREVISION_DEVEL}
.else
-CONFLICTS= isc-dhcp41-server*
+CONFLICTS= isc-dhcp4[1-9]-server*
DHCP_PORTREVISION= ${PORTREVISION_SERVER}
.endif
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index 412d20c5b212..a444d7150264 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -41,13 +41,13 @@ OPTIONS+= DHCP_PARANOIA "Enable support for chroot" on \
# PORTREVISION and CONFLICTS handling
.if ${SUBSYS} == client
-CONFLICTS= isc-dhcp3?-client*
+CONFLICTS= isc-dhcp3?-client* isc-dhcp4[2-9]-client*
DHCP_PORTREVISION= ${PORTREVISION_CLIENT}
.elif ${SUBSYS} == relay
-CONFLICTS= isc-dhcp3?-relay*
+CONFLICTS= isc-dhcp3?-relay* isc-dhcp4[2-9]-relay*
DHCP_PORTREVISION= ${PORTREVISION_RELAY}
.else
-CONFLICTS= isc-dhcp3?-server*
+CONFLICTS= isc-dhcp3?-server* isc-dhcp4[2-9]-server*
DHCP_PORTREVISION= ${PORTREVISION_SERVER}
.endif