aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-24 03:41:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-24 03:41:07 +0800
commitbc426f4d26b4580cac2910174fa5042c7707e2a6 (patch)
tree25b74e00d10a1e552190a6515a6656ca1d030a4a /net
parent0cfef012e489cd9c425eda86dac43d1d827841b5 (diff)
downloadfreebsd-ports-gnome-bc426f4d26b4580cac2910174fa5042c7707e2a6.tar.gz
freebsd-ports-gnome-bc426f4d26b4580cac2910174fa5042c7707e2a6.tar.zst
freebsd-ports-gnome-bc426f4d26b4580cac2910174fa5042c7707e2a6.zip
- Add p5-URI-Query 0.09
URI::Query provides simple URI query string manipulation, allowing you to create and manipulate URI query strings from GET and POST requests in web applications. This is primarily useful for creating links where you wish to preserve some subset of the parameters to the current request, and potentially add or replace others. Given a query string this is doable with regexes, of course, but making sure you get the anchoring and escaping right is tedious and error-prone - this module is simpler. WWW: http://search.cpan.org/dist/URI-Query/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-URI-Query/Makefile30
-rw-r--r--net/p5-URI-Query/distinfo2
-rw-r--r--net/p5-URI-Query/pkg-descr9
-rw-r--r--net/p5-URI-Query/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 051e18ee0643..aee5981f0a92 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -731,6 +731,7 @@
SUBDIR += p5-URI-FromHash
SUBDIR += p5-URI-Match
SUBDIR += p5-URI-OpenURL
+ SUBDIR += p5-URI-Query
SUBDIR += p5-URI-SmartURI
SUBDIR += p5-URI-Template
SUBDIR += p5-URI-Template-Restrict
diff --git a/net/p5-URI-Query/Makefile b/net/p5-URI-Query/Makefile
new file mode 100644
index 000000000000..2456c861f3df
--- /dev/null
+++ b/net/p5-URI-Query/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-URI-Query
+# Date created: 2011-09-23
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-Query
+PORTVERSION= 0.09
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= URI query string manipulation
+
+BUILD_DEPENDS= p5-URI>=1.31:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= p5-URI>=1.31:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= yes
+
+MAN3= URI::Query.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-URI-Query/distinfo b/net/p5-URI-Query/distinfo
new file mode 100644
index 000000000000..b965e91f8a17
--- /dev/null
+++ b/net/p5-URI-Query/distinfo
@@ -0,0 +1,2 @@
+SHA256 (URI-Query-0.09.tar.gz) = e0f5d24f86d83d5b55ad8ec061530f635f8f6943b46349dd4908f327c5a149c8
+SIZE (URI-Query-0.09.tar.gz) = 7845
diff --git a/net/p5-URI-Query/pkg-descr b/net/p5-URI-Query/pkg-descr
new file mode 100644
index 000000000000..f34d38bc89b5
--- /dev/null
+++ b/net/p5-URI-Query/pkg-descr
@@ -0,0 +1,9 @@
+URI::Query provides simple URI query string manipulation, allowing you to create
+and manipulate URI query strings from GET and POST requests in web applications.
+This is primarily useful for creating links where you wish to preserve some
+subset of the parameters to the current request, and potentially add or replace
+others. Given a query string this is doable with regexes, of course, but making
+sure you get the anchoring and escaping right is tedious and error-prone - this
+module is simpler.
+
+WWW: http://search.cpan.org/dist/URI-Query/
diff --git a/net/p5-URI-Query/pkg-plist b/net/p5-URI-Query/pkg-plist
new file mode 100644
index 000000000000..6602d6e92ec8
--- /dev/null
+++ b/net/p5-URI-Query/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/URI/Query.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Query/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Query
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI
+@dirrmtry %%SITE_PERL%%/URI