aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commitbcc2006e5a05ff46461202f4b3c0a4ac8d86476e (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /net
parent27befbedb683f9336783ae19591c9b2f5037500d (diff)
downloadfreebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.gz
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.zst
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile1
-rw-r--r--net/asterisk10/Makefile1
-rw-r--r--net/asterisk14/Makefile1
-rw-r--r--net/boinc-client/Makefile1
-rw-r--r--net/freeswitch-core-devel/Makefile1
-rw-r--r--net/freeswitch-core/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 312d368aec91..7fe7f44c3f98 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -29,6 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
+USE_GCC= any
USE_GMAKE= yes
USE_GNOME= libxml2
USE_BISON= build
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 7e6011a8deb9..5eacc94aad24 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -27,6 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
+USE_GCC= any
USE_GMAKE= yes
USE_GNOME= libxml2
USE_BISON= build
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 2dd5920e8dcd..c3a6c47c0d42 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -30,6 +30,7 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
+USE_GCC= any
USE_GMAKE= yes
USE_BISON= build
USE_RC_SUBR= asterisk
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index bb744f6a885e..82f0101d9441 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= pav
MAINTAINER= pav@FreeBSD.org
COMMENT= Berkeley Open Infrastructure for Network Computing client
+USE_GCC= any
USE_XZ= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net/freeswitch-core-devel/Makefile b/net/freeswitch-core-devel/Makefile
index 2d721fc99108..da5dd672df41 100644
--- a/net/freeswitch-core-devel/Makefile
+++ b/net/freeswitch-core-devel/Makefile
@@ -47,6 +47,7 @@ USE_AUTOTOOLS= autoconf:env automake:env libtool:env
USE_PERL5_BUILD=yes
USE_BISON= both
+USE_GCC= any
USE_PKGCONFIG= yes
USE_GMAKE= yes
SUB_FILES= pkg-install
diff --git a/net/freeswitch-core/Makefile b/net/freeswitch-core/Makefile
index 01475c47deaa..04e92597ca56 100644
--- a/net/freeswitch-core/Makefile
+++ b/net/freeswitch-core/Makefile
@@ -47,6 +47,7 @@ USE_AUTOTOOLS= autoconf:env automake:env libtool:env
USE_PERL5_BUILD=yes
USE_BISON= both
+USE_GCC= any
USE_PKGCONFIG= yes
USE_GMAKE= yes
SUB_FILES= pkg-install pkg-message