aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2012-04-24 04:49:14 +0800
committerpav <pav@FreeBSD.org>2012-04-24 04:49:14 +0800
commitbd337faae68deb4ec84b8c5e017b462c69c4e283 (patch)
tree1b200d644f8113cf9d03fcf736d3217ba30aa3b0 /net
parentb4c38a036fae84fe73865c980c3b4d358f562e96 (diff)
downloadfreebsd-ports-gnome-bd337faae68deb4ec84b8c5e017b462c69c4e283.tar.gz
freebsd-ports-gnome-bd337faae68deb4ec84b8c5e017b462c69c4e283.tar.zst
freebsd-ports-gnome-bd337faae68deb4ec84b8c5e017b462c69c4e283.zip
- Install some more headers
Submitted by: rene
Diffstat (limited to 'net')
-rw-r--r--net/boinc-client/Makefile6
-rw-r--r--net/boinc-client/files/patch-api__boinc_api.h11
-rw-r--r--net/boinc-client/pkg-plist4
3 files changed, 19 insertions, 2 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 83e82df2786f..398a291d89ac 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -7,7 +7,7 @@
PORTNAME= boinc-client
PORTVERSION= 7.0.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
@@ -152,9 +152,11 @@ post-install:
cd ${LOCALBASE}/share/pixmaps ; ${LN} -sf ${PREFIX}/share/boinc/boincmgr.${name}x${name}.png
. endfor
.endif
+ ${INSTALL_DATA} ${WRKSRC}/config.h ${PREFIX}/include/boinc
${INSTALL_DATA} ${WRKSRC}/lib/std_fixes.h ${PREFIX}/include/boinc
.if !defined(WITHOUT_X11)
-. for name in api/boinc_gl.h api/txf_util.h
+. for name in api/boinc_gl.h api/graphics_api.h api/graphics_data.h \
+ api/reduce.h api/txf_util.h
${INSTALL_DATA} ${WRKSRC}/${name} ${PREFIX}/include/boinc
. endfor
. if defined(WITHOUT_MANAGER)
diff --git a/net/boinc-client/files/patch-api__boinc_api.h b/net/boinc-client/files/patch-api__boinc_api.h
new file mode 100644
index 000000000000..2eadb977e8e1
--- /dev/null
+++ b/net/boinc-client/files/patch-api__boinc_api.h
@@ -0,0 +1,11 @@
+--- api/boinc_api.h.orig 2012-04-20 16:15:13.000000000 +0200
++++ api/boinc_api.h 2012-04-20 16:17:11.000000000 +0200
+@@ -29,6 +29,8 @@
+ extern "C" {
+ #endif
+
++#include <cstddef>
++
+ // parameters passed to the BOINC runtime system
+ //
+ typedef struct BOINC_OPTIONS {
diff --git a/net/boinc-client/pkg-plist b/net/boinc-client/pkg-plist
index 4e37b7a10a7d..2afe90e8a6a9 100644
--- a/net/boinc-client/pkg-plist
+++ b/net/boinc-client/pkg-plist
@@ -16,6 +16,7 @@ include/boinc/cc_config.h
include/boinc/cert_sig.h
include/boinc/cl_boinc.h
include/boinc/common_defs.h
+include/boinc/config.h
include/boinc/coproc.h
include/boinc/crypt.h
include/boinc/diagnostics.h
@@ -48,6 +49,9 @@ include/boinc/util.h
include/boinc/version.h
include/boinc/win_util.h
%%X11%%include/boinc/boinc_gl.h
+%%X11%%include/boinc/graphics_api.h
+%%X11%%include/boinc/graphics_data.h
+%%X11%%include/boinc/reduce.h
%%X11%%include/boinc/txf_util.h
lib/libboinc.a
lib/libboinc.la