aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2009-08-18 22:33:37 +0800
committerskv <skv@FreeBSD.org>2009-08-18 22:33:37 +0800
commitc785b459dd7d53a994117aeb98a2c3cbca786f6d (patch)
tree45d4a3bf9e17626b5ff7a505385f94c407a9f370 /net
parentcd42d256c687436c7c81850b813b97b7d581166b (diff)
downloadfreebsd-ports-gnome-c785b459dd7d53a994117aeb98a2c3cbca786f6d.tar.gz
freebsd-ports-gnome-c785b459dd7d53a994117aeb98a2c3cbca786f6d.tar.zst
freebsd-ports-gnome-c785b459dd7d53a994117aeb98a2c3cbca786f6d.zip
Unbreak build with defined WITHOUT_KERBEROS.
PR: ports/133344 Submitted by: Alex Bakhtin <bakhtin xx amt.ru> Approved by: maintainer timeout (> 4 months)
Diffstat (limited to 'net')
-rw-r--r--net/nss_ldap/Makefile4
-rw-r--r--net/nss_ldap/files/patch-ldap-nss.c8
2 files changed, 9 insertions, 3 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 21282770f878..17abf6310d29 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -23,7 +23,6 @@ USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:262 autoheader:262
USE_LDCONFIG= yes
USE_OPENLDAP= yes
-
PLIST_FILES= etc/nss_ldap.conf.sample \
lib/nss_ldap.so.1
@@ -33,8 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
--with-ldap-secret-file=${PREFIX}/etc/nss_ldap.secret \
--enable-rfc2307bis \
- --enable-paged-results \
- --enable-configurable-krb5-ccname-env
+ --enable-paged-results
MAN5= nss_ldap.5
diff --git a/net/nss_ldap/files/patch-ldap-nss.c b/net/nss_ldap/files/patch-ldap-nss.c
index 2622dc3b1726..297cc4d403f9 100644
--- a/net/nss_ldap/files/patch-ldap-nss.c
+++ b/net/nss_ldap/files/patch-ldap-nss.c
@@ -9,3 +9,11 @@
#include <sasl/sasl.h>
#elif defined(HAVE_SASL_H)
#include <sasl.h>
+@@ -84,7 +84,7 @@
+ #include <gssapi/gssapi.h>
+ #include <gssapi/gssapi_krb5.h>
+ #endif
+-#ifdef CONFIGURE_KRB5_CCNAME
++#if defined(CONFIGURE_KRB5_CCNAME) && defined(HAVE_KRB5_H)
+ #include <krb5.h>
+ #endif