aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-10-06 12:03:05 +0800
committerswills <swills@FreeBSD.org>2014-10-06 12:03:05 +0800
commitcd555a5b23726f7777a60ce2ed6aded59e339751 (patch)
tree247a7ea3303dca328b8bf2bd1fd0b4a02033aaee /net
parent12a0115a5ca02691bba7032b673e96b79f4ec696 (diff)
downloadfreebsd-ports-gnome-cd555a5b23726f7777a60ce2ed6aded59e339751.tar.gz
freebsd-ports-gnome-cd555a5b23726f7777a60ce2ed6aded59e339751.tar.zst
freebsd-ports-gnome-cd555a5b23726f7777a60ce2ed6aded59e339751.zip
net/rubygem-omniauth-openid: create port
OpenID strategy for OmniAuth. WWW: https://github.com/intridea/omniauth-openid
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-omniauth-openid/Makefile19
-rw-r--r--net/rubygem-omniauth-openid/distinfo2
-rw-r--r--net/rubygem-omniauth-openid/pkg-descr3
4 files changed, 25 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3dfc50b6e019..c02836c2f443 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1012,6 +1012,7 @@
SUBDIR += rubygem-omniauth-google-oauth2
SUBDIR += rubygem-omniauth-oauth
SUBDIR += rubygem-omniauth-oauth2
+ SUBDIR += rubygem-omniauth-openid
SUBDIR += rubygem-omniauth-twitter
SUBDIR += rubygem-open-uri-cached
SUBDIR += rubygem-openid
diff --git a/net/rubygem-omniauth-openid/Makefile b/net/rubygem-omniauth-openid/Makefile
new file mode 100644
index 000000000000..cda9565eb6b0
--- /dev/null
+++ b/net/rubygem-omniauth-openid/Makefile
@@ -0,0 +1,19 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= omniauth-openid
+PORTVERSION= 1.0.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= OpenID strategy for OmniAuth
+
+RUN_DEPENDS= rubygem-omniauth>=1.0:${PORTSDIR}/security/rubygem-omniauth \
+ rubygem-rack-openid>=1.3.1:${PORTSDIR}/www/rubygem-rack-openid
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-openid/distinfo b/net/rubygem-omniauth-openid/distinfo
new file mode 100644
index 000000000000..cba23a355313
--- /dev/null
+++ b/net/rubygem-omniauth-openid/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/omniauth-openid-1.0.1.gem) = 823bce35528072340b4a8a30ebd78e20d1a68178e222b88fe1dd977a88a457e2
+SIZE (rubygem/omniauth-openid-1.0.1.gem) = 10240
diff --git a/net/rubygem-omniauth-openid/pkg-descr b/net/rubygem-omniauth-openid/pkg-descr
new file mode 100644
index 000000000000..eaa7bf87c5fa
--- /dev/null
+++ b/net/rubygem-omniauth-openid/pkg-descr
@@ -0,0 +1,3 @@
+OpenID strategy for OmniAuth.
+
+WWW: https://github.com/intridea/omniauth-openid