aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-02 05:19:33 +0800
committermarino <marino@FreeBSD.org>2015-04-02 05:19:33 +0800
commitd047507cb70a249d3d2f99e6710da84fc3340a7b (patch)
treef0098ad8fe472d9eff5fc3288ea72366c05262f9 /net
parent25b9746ed9e2a7719768694c6b4450a785c02b85 (diff)
downloadfreebsd-ports-gnome-d047507cb70a249d3d2f99e6710da84fc3340a7b.tar.gz
freebsd-ports-gnome-d047507cb70a249d3d2f99e6710da84fc3340a7b.tar.zst
freebsd-ports-gnome-d047507cb70a249d3d2f99e6710da84fc3340a7b.zip
net/widentd: disable -Werror
On gcc, this warning is given: widentd.c: In function 'main': widentd.c:194:3: error: 'memset' used with constant zero length parameter; this could be due to transposed parameters [-Werror=memset-transposed-args] memset(buff, sizeof(buff), 0); ^ Removing -Werror is blanket-approved. This is another port that uses <bsd.prog.mk> instead of providing an independent makefile, so the -Werror is coming from the system build framework.
Diffstat (limited to 'net')
-rw-r--r--net/widentd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/widentd/Makefile b/net/widentd/Makefile
index 930f48cfd197..10718dd393d2 100644
--- a/net/widentd/Makefile
+++ b/net/widentd/Makefile
@@ -13,6 +13,7 @@ LICENSE= BSD3CLAUSE
USES= uidfix tar:xz
MAKE_ENV+= BINDIR="${PREFIX}/sbin" MANDIR="${PREFIX}/man/man"
+MAKE_ENV+= NO_WERROR="defined"
PLIST_FILES= sbin/widentd man/man8/widentd.8.gz
USE_RC_SUBR= widentd