aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-10 21:33:20 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-10 21:33:20 +0800
commitd5336cee7f2f084868fb92b5c4a1022fe5c2663f (patch)
treea35ed3aa4986405d719b4d08f57a8771a37bd590 /net
parent142582b6dc00590d7fa356d69d2a343b42e0ca19 (diff)
downloadfreebsd-ports-gnome-d5336cee7f2f084868fb92b5c4a1022fe5c2663f.tar.gz
freebsd-ports-gnome-d5336cee7f2f084868fb92b5c4a1022fe5c2663f.tar.zst
freebsd-ports-gnome-d5336cee7f2f084868fb92b5c4a1022fe5c2663f.zip
Add a new port of net/nanomsg, a ZeroMQ-like socket library in pure C.
Currently the port does not install manual pages, as they have to be generated. Probably prerequisites for manpages are not as massive as for HTML docs, but they are not decoupled correctly in the configure and Makefile.in files. While here, remove trailing whitespace in `net/Makefile'. PR: 199043
Diffstat (limited to 'net')
-rw-r--r--net/Makefile5
-rw-r--r--net/nanomsg/Makefile36
-rw-r--r--net/nanomsg/distinfo2
-rw-r--r--net/nanomsg/pkg-descr20
-rw-r--r--net/nanomsg/pkg-plist26
5 files changed, 87 insertions, 2 deletions
diff --git a/net/Makefile b/net/Makefile
index 38bc48155296..191935556691 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -392,6 +392,7 @@
SUBDIR += mtr
SUBDIR += mtr-nox11
SUBDIR += nakenchat
+ SUBDIR += nanomsg
SUBDIR += nast
SUBDIR += nbd-server
SUBDIR += nc
@@ -860,8 +861,8 @@
SUBDIR += php55-soap
SUBDIR += php55-sockets
SUBDIR += php55-xmlrpc
- SUBDIR += php56-ldap
- SUBDIR += php56-soap
+ SUBDIR += php56-ldap
+ SUBDIR += php56-soap
SUBDIR += php56-sockets
SUBDIR += php56-xmlrpc
SUBDIR += phpldapadmin
diff --git a/net/nanomsg/Makefile b/net/nanomsg/Makefile
new file mode 100644
index 000000000000..97dd9e1bc715
--- /dev/null
+++ b/net/nanomsg/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= nanomsg
+PORTVERSION= 0.5
+CATEGORIES= net
+MASTER_SITES= http://download.nanomsg.org/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-beta
+
+MAINTAINER= crest@bultmann.eu
+COMMENT= Socket library that provides several common communication patterns
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= libtool pathfix
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --disable-silent-rules
+.endif
+
+PORTDOCS= AUTHORS ChangeLog README
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,GREP "GNU strip",EGREP "GNU|elftoolchain",' \
+ ${WRKSRC}/configure
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/nanomsg/distinfo b/net/nanomsg/distinfo
new file mode 100644
index 000000000000..baa7368969b9
--- /dev/null
+++ b/net/nanomsg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nanomsg-0.5-beta.tar.gz) = 13bff7ae8f31957722ee62d50504ce1a0c590da908f8566f997e3e521abb089f
+SIZE (nanomsg-0.5-beta.tar.gz) = 623927
diff --git a/net/nanomsg/pkg-descr b/net/nanomsg/pkg-descr
new file mode 100644
index 000000000000..e9533dc10f47
--- /dev/null
+++ b/net/nanomsg/pkg-descr
@@ -0,0 +1,20 @@
+nanomsg is a socket library that provides several common communication
+patterns. It aims to make the networking layer fast, scalable, and easy
+to use. Implemented in C, it works on a wide range of operating systems
+with no further dependencies.
+
+The communication patterns, also called "scalability protocols", are basic
+blocks for building distributed systems. By combining them you can create
+a vast array of distributed applications. The following scalability
+protocols are currently available:
+
+ * PAIR -- simple one-to-one communication
+ * BUS -- simple many-to-many communication
+ * REQREP -- allows to build clusters of stateless services to process
+ user requests
+ * PUBSUB -- distributes messages to large sets of interested subscribers
+ * PIPELINE -- aggregates messages from multiple sources and load balances
+ them among many destinations
+ * SURVEY -- allows to query state of multiple applications in single go
+
+WWW: http://nanomsg.org/
diff --git a/net/nanomsg/pkg-plist b/net/nanomsg/pkg-plist
new file mode 100644
index 000000000000..752c61920865
--- /dev/null
+++ b/net/nanomsg/pkg-plist
@@ -0,0 +1,26 @@
+bin/nanocat
+bin/nn_bus
+bin/nn_pair
+bin/nn_pub
+bin/nn_pull
+bin/nn_push
+bin/nn_rep
+bin/nn_req
+bin/nn_respondent
+bin/nn_sub
+bin/nn_surveyor
+include/nanomsg/bus.h
+include/nanomsg/inproc.h
+include/nanomsg/ipc.h
+include/nanomsg/nn.h
+include/nanomsg/pair.h
+include/nanomsg/pipeline.h
+include/nanomsg/pubsub.h
+include/nanomsg/reqrep.h
+include/nanomsg/survey.h
+include/nanomsg/tcp.h
+lib/libnanomsg.a
+lib/libnanomsg.so
+lib/libnanomsg.so.0
+lib/libnanomsg.so.0.2.1
+libdata/pkgconfig/libnanomsg.pc