aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-07-03 03:04:18 +0800
committerrakuco <rakuco@FreeBSD.org>2013-07-03 03:04:18 +0800
commitd8aba0f944c06887cc7520b2e25efe037cf47b8b (patch)
tree2923053fc55dccac74b95b5ed97ba05ff2db25bb /net
parentc394643404ed2a30367814c35c919dd806e3f02d (diff)
downloadfreebsd-ports-gnome-d8aba0f944c06887cc7520b2e25efe037cf47b8b.tar.gz
freebsd-ports-gnome-d8aba0f944c06887cc7520b2e25efe037cf47b8b.tar.zst
freebsd-ports-gnome-d8aba0f944c06887cc7520b2e25efe037cf47b8b.zip
Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.
With commits from avilla@, makc@, rakuco@ and Schaich Alonso. The upstream announcement can be found in [1]. [1] http://www.kde.org/announcements/announce-4.10.4.php clang support should be more stable now, with clang being recognized by kdelibs4 and being passed the correct flags to build other ports. Additionally, all ports being committed have been verified to build with -CURRENT's clang 3.3 on an amd64 tinderbox (special thanks go to swills@ for providing it). Work on the newly-released 4.10.5 will begin shortly.
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork4/distinfo4
-rw-r--r--net/kdenetwork4/files/patch-kget__core__transferhistorystore.cpp25
-rw-r--r--net/kdenetwork4/files/patch-r135634843
3 files changed, 2 insertions, 70 deletions
diff --git a/net/kdenetwork4/distinfo b/net/kdenetwork4/distinfo
index ba05cbbbce06..008470f26b6c 100644
--- a/net/kdenetwork4/distinfo
+++ b/net/kdenetwork4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.3/kdenetwork-4.10.3.tar.xz) = 0f5e92d7920bc2d8a30985ca309b131384e3cb2f7b414962f394de36963be5f7
-SIZE (KDE/4.10.3/kdenetwork-4.10.3.tar.xz) = 9058180
+SHA256 (KDE/4.10.4/kdenetwork-4.10.4.tar.xz) = e681cd08ec512303b08fddb847f26b612c10dee51b6746b32be30c4bed71a9ba
+SIZE (KDE/4.10.4/kdenetwork-4.10.4.tar.xz) = 8911092
diff --git a/net/kdenetwork4/files/patch-kget__core__transferhistorystore.cpp b/net/kdenetwork4/files/patch-kget__core__transferhistorystore.cpp
deleted file mode 100644
index 9eaedbcb2bbf..000000000000
--- a/net/kdenetwork4/files/patch-kget__core__transferhistorystore.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
-------------------------------------------------------------------------
-r1355676 | rkcosta | 2013-05-20 16:16:41 +0300 (Mon, 20 May 2013) | 6 lines
-
-Fix most-vexing parse error introduced in r1345874.
-
-By the way, why is this revision only in branches/KDE/4.10 and not in trunk?
-
-CCMAIL: david.narvaez@computer.org
-
-
-Index: kget/core/transferhistorystore.cpp
-===================================================================
---- kget/core/transferhistorystore.cpp (revision 1355675)
-+++ kget/core/transferhistorystore.cpp (revision 1355676)
-@@ -554,7 +554,7 @@
- void NepomukStore::load()
- {
- Nepomuk::Query::QueryServiceClient * queryService = new Nepomuk::Query::QueryServiceClient(this);
-- Nepomuk::Query::ResourceTypeTerm historyTypeTerm(Nepomuk::Types::Class(Nepomuk::HistoryItem::resourceTypeUri()));
-+ Nepomuk::Query::ResourceTypeTerm historyTypeTerm((Nepomuk::Types::Class(Nepomuk::HistoryItem::resourceTypeUri())));
- Nepomuk::Query::Query historyQuery(historyTypeTerm);
-
- connect(queryService, SIGNAL(newEntries(const QList<Nepomuk::Query::Result>&)), this, SLOT(loadResult(const QList<Nepomuk::Query::Result>&)));
-
-------------------------------------------------------------------------
diff --git a/net/kdenetwork4/files/patch-r1356348 b/net/kdenetwork4/files/patch-r1356348
deleted file mode 100644
index 3f12ce4ef9de..000000000000
--- a/net/kdenetwork4/files/patch-r1356348
+++ /dev/null
@@ -1,43 +0,0 @@
-------------------------------------------------------------------------
-r1356348 | rkcosta | 2013-05-28 11:36:38 +0300 (Tue, 28 May 2013) | 11 lines
-
-Merge r1356347 from trunk.
-
-------------------------------------------------------------------------
-r1356347 | rkcosta | 2013-05-28 11:32:26 +0300 (Tue, 28 May 2013) | 4 lines
-
-Default arguments should be in the method's declaration.
-
-Not only is this correct C++, but it also fixes the build with clang 3.3.
-
-------------------------------------------------------------------------
-
-
-Index: kget/transfer-plugins/bittorrent/btsettingswidget.h
-===================================================================
---- kget/transfer-plugins/bittorrent/btsettingswidget.h (revision 1356347)
-+++ kget/transfer-plugins/bittorrent/btsettingswidget.h (revision 1356348)
-@@ -19,7 +19,7 @@
- {
- Q_OBJECT
- public:
-- BTSettingsWidget(QWidget * parent, const QVariantList &args);
-+ BTSettingsWidget(QWidget * parent = 0, const QVariantList &args = QVariantList());
-
- public slots:
- virtual void load();
-Index: kget/transfer-plugins/bittorrent/btsettingswidget.cpp
-===================================================================
---- kget/transfer-plugins/bittorrent/btsettingswidget.cpp (revision 1356347)
-+++ kget/transfer-plugins/bittorrent/btsettingswidget.cpp (revision 1356348)
-@@ -17,7 +17,7 @@
-
- KGET_EXPORT_PLUGIN_CONFIG(BTSettingsWidget)
-
--BTSettingsWidget::BTSettingsWidget(QWidget * parent = 0, const QVariantList &args = QVariantList())
-+BTSettingsWidget::BTSettingsWidget(QWidget * parent, const QVariantList &args)
- : KCModule(KGetFactory::componentData(), parent, args)
- {
- setupUi(this);
-
-------------------------------------------------------------------------