aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-04-24 19:50:59 +0800
committermiwi <miwi@FreeBSD.org>2010-04-24 19:50:59 +0800
commitde5e6d2d4506d9b6c694244db2643c5c4f0711c2 (patch)
treeecd64f15ffcd6fc3c439f25b0d5c4ef0d20ee8eb /net
parent4c44e027e1a5cf0dd2811e59268d9c112bb19721 (diff)
downloadfreebsd-ports-gnome-de5e6d2d4506d9b6c694244db2643c5c4f0711c2.tar.gz
freebsd-ports-gnome-de5e6d2d4506d9b6c694244db2643c5c4f0711c2.tar.zst
freebsd-ports-gnome-de5e6d2d4506d9b6c694244db2643c5c4f0711c2.zip
Bunny is an AMQP (Advanced Message Queuing Protocol) client, written in Ruby,
that is intended to allow you to interact with AMQP-compliant message brokers/servers such as RabbitMQ in a synchronous fashion. It is based on a great deal of useful code from amqp by Aman Gupta and Carrot by Amos Elliston. You can use Bunny to : * Create and delete exchanges * Create and delete queues * Publish and consume messages Bunny is known to work with RabbitMQ versions 1.5.4 and above with version 0-8 of the AMQP specification. WWW: http://github.com/celldee/bunny PR: ports/145841 Submitted by: renchap at cocoa-x.com
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-bunny/Makefile23
-rw-r--r--net/rubygem-bunny/distinfo3
-rw-r--r--net/rubygem-bunny/pkg-descr16
4 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2c39c16fcfe4..b5801643a252 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -895,6 +895,7 @@
SUBDIR += ruby-spread
SUBDIR += ruby-tcpsocketpipe
SUBDIR += ruby-tserver
+ SUBDIR += rubygem-bunny
SUBDIR += rubygem-geoip
SUBDIR += rubygem-macaddr
SUBDIR += rubygem-net-netrc
diff --git a/net/rubygem-bunny/Makefile b/net/rubygem-bunny/Makefile
new file mode 100644
index 000000000000..958f4ef08190
--- /dev/null
+++ b/net/rubygem-bunny/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: rubygem-bunny
+# Date created: 19 Mar 2010
+# Whom: renchap@cocoa-x.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bunny
+PORTVERSION= 0.6.0
+CATEGORIES= net
+MASTER_SITES= http://gemcutter.org/gems/
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= Another synchronous Ruby AMQP client
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+# we care about not passing -A to allow HTTP redirect
+FETCH_ARGS= -pRr
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-bunny/distinfo b/net/rubygem-bunny/distinfo
new file mode 100644
index 000000000000..145cedb99fdc
--- /dev/null
+++ b/net/rubygem-bunny/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/bunny-0.6.0.gem) = 1697fe4ec6f17826b823ae86adc92098
+SHA256 (rubygem/bunny-0.6.0.gem) = fb8142488e96124f1b880979d1006366f254323f555add01a028ef70db306038
+SIZE (rubygem/bunny-0.6.0.gem) = 32256
diff --git a/net/rubygem-bunny/pkg-descr b/net/rubygem-bunny/pkg-descr
new file mode 100644
index 000000000000..299e1594296f
--- /dev/null
+++ b/net/rubygem-bunny/pkg-descr
@@ -0,0 +1,16 @@
+Bunny is an AMQP (Advanced Message Queuing Protocol) client, written in Ruby,
+that is intended to allow you to interact with AMQP-compliant message
+brokers/servers such as RabbitMQ in a synchronous fashion.
+
+It is based on a great deal of useful code from amqp by Aman Gupta and Carrot
+by Amos Elliston.
+
+You can use Bunny to :
+* Create and delete exchanges
+* Create and delete queues
+* Publish and consume messages
+
+Bunny is known to work with RabbitMQ versions 1.5.4 and above with version 0-8
+of the AMQP specification.
+
+WWW: http://github.com/celldee/bunny