aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2013-01-19 18:09:14 +0800
committeroliver <oliver@FreeBSD.org>2013-01-19 18:09:14 +0800
commite2b212f1a3d086f98a53f996e482ed6e01e41912 (patch)
tree958fe0c330c65b1fda2b92cf639c1cff96ad13cc /net
parent0e513a77bc2cc7a57f31e22a55084facdeb00607 (diff)
downloadfreebsd-ports-gnome-e2b212f1a3d086f98a53f996e482ed6e01e41912.tar.gz
freebsd-ports-gnome-e2b212f1a3d086f98a53f996e482ed6e01e41912.tar.zst
freebsd-ports-gnome-e2b212f1a3d086f98a53f996e482ed6e01e41912.zip
update of the worldfordge suite
devel/eris: 1.3.21 devel/mercator: 0.3.2 devel/varconf: 1.0.0 math/wfmath: 1.0.1 net/cyphesis: 0.6.0 net/skstream: 0.3.9 games/ember: 0.7.0
Diffstat (limited to 'net')
-rw-r--r--net/cyphesis/Makefile44
-rw-r--r--net/cyphesis/distinfo4
-rw-r--r--net/cyphesis/files/patch-common-system_net.cpp59
-rw-r--r--net/cyphesis/pkg-plist55
-rw-r--r--net/skstream/Makefile15
-rw-r--r--net/skstream/distinfo4
-rw-r--r--net/skstream/pkg-plist31
7 files changed, 160 insertions, 52 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index 9d162ca4fc41..5ac8cd01f5f6 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -1,14 +1,9 @@
-
-# New ports collection makefile for: cyphesis
-# Date created: 02 Oct 2005
-# Whom: Oliver Lehmann <oliver@FreeBSD.org>
-#
+# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cyphesis
-PORTVERSION= 0.5.26
-PORTREVISION= 2
+PORTVERSION= 0.6.0
+#PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
@@ -16,11 +11,12 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= A server for WorldForge games
LIB_DEPENDS= Atlas-0.6.1:${PORTSDIR}/devel/atlas-devel \
- varconf-1.0.7:${PORTSDIR}/devel/varconf \
- wfmath-0.3.5:${PORTSDIR}/math/wfmath \
- mercator-0.3.1:${PORTSDIR}/devel/mercator \
- skstream-0.3.6:${PORTSDIR}/net/skstream \
- gcrypt.18:${PORTSDIR}/security/libgcrypt
+ varconf-1.0.8:${PORTSDIR}/devel/varconf \
+ wfmath-1.0.1:${PORTSDIR}/math/wfmath \
+ mercator-0.3.3:${PORTSDIR}/devel/mercator \
+ skstream-0.3.7:${PORTSDIR}/net/skstream \
+ gcrypt.18:${PORTSDIR}/security/libgcrypt \
+ boost_regex:${PORTSDIR}/devel/boost-libs
CONFIGURE_ARGS= --with-python=${LOCALBASE}
@@ -31,34 +27,38 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PGSQL= yes
USE_PYTHON= 2.5-2.6
+USE_GCC= 4.7+
CFLAGS+= -I${LOCALBASE}/include
MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
cyconvertrules.1 cydumprules.1 cyloadrules.1 cypasswd.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' ${WRKSRC}/data/Makefile.in
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' \
+ ${WRKSRC}/data/minimal/Makefile.in \
+ ${WRKSRC}/data/mars/Makefile.in \
+ ${WRKSRC}/data/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lpython|${PTHREAD_LIBS} &|' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
- ${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g'
+ ${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g ; \
+ s|confbackupdir = .*|confbackupdir = ${DOCSDIR}/conf|g'
@${REINPLACE_CMD} -e 's|/bash|/sh|' ${WRKSRC}/scripts/extract_revision.sh
@${REINPLACE_CMD} -e '1s|python|${LOCALBASE}/bin/${PYTHON_VERSION}|' ${WRKSRC}/scripts/gen_buildid.py
@${REINPLACE_CMD} -e 's/#ifdef __APPLE__/#if defined(__APPLE__) || defined(__FreeBSD__)/g; \
s/#ifndef __APPLE__/#if !defined(__APPLE__) \&\& !defined(__FreeBSD__)/g' \
${WRKSRC}/common/system.cpp \
- ${WRKSRC}/common/AtlasStreamClient.cpp \
${WRKSRC}/server/CommUnixListener.cpp
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/conf
-.for docfile in README COPYING AUTHORS THANKS NEWS ChangeLog TODO
+.for docfile in README COPYING AUTHORS THANKS NEWS ChangeLog TODO FIXME
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.for docfile in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
@@ -66,4 +66,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/cyphesis/distinfo b/net/cyphesis/distinfo
index 75bc11f4c982..ddc5ec7d4267 100644
--- a/net/cyphesis/distinfo
+++ b/net/cyphesis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cyphesis-0.5.26.tar.bz2) = eff10beeafeea72a045a60caf1793270ee5406864ab22d086dc5fc902ad9b394
-SIZE (cyphesis-0.5.26.tar.bz2) = 755060
+SHA256 (cyphesis-0.6.0.tar.bz2) = b6988e6dbdf7b601bf6d9fc7456fa7ad376f96ad350b3da3d9c4714fa43a52ad
+SIZE (cyphesis-0.6.0.tar.bz2) = 840777
diff --git a/net/cyphesis/files/patch-common-system_net.cpp b/net/cyphesis/files/patch-common-system_net.cpp
new file mode 100644
index 000000000000..576e0cf3b99b
--- /dev/null
+++ b/net/cyphesis/files/patch-common-system_net.cpp
@@ -0,0 +1,59 @@
+--- common/system_net.cpp.orig 2012-12-18 19:51:32.000000000 +0100
++++ common/system_net.cpp 2012-12-19 08:49:52.000000000 +0100
+@@ -28,6 +28,7 @@
+ #endif // _WIN32
+
+ #include <cassert>
++#include <cstdio>
+
+ extern "C" {
+ #ifdef HAVE_SYS_UTSNAME_H
+@@ -80,6 +81,14 @@
+ #ifdef HAVE_SYS_UN_H
+ #ifndef __APPLE__
+ #ifndef SO_PEERCRED
++ size_t creds_size;
++
++#if defined (SCM_CREDENTIALS)
++ creds_size = sizeof(struct ucred);
++#elif defined (SCM_CREDS)
++ creds_size = sizeof(struct cmsgcred);
++#endif
++
+ // Prove to the server that we are real.
+
+ unsigned char buf[1];
+@@ -97,12 +106,13 @@
+ auth_message.msg_iovlen = 1;
+ auth_message.msg_name = 0;
+ auth_message.msg_namelen = 0;
+- auth_message.msg_controllen = CMSG_SPACE(sizeof(struct ucred));
++ auth_message.msg_controllen = CMSG_SPACE(creds_size);
+ unsigned char * mcb = new unsigned char[auth_message.msg_controllen];
+ auth_message.msg_control = mcb;
+ auth_message.msg_flags = 0;
+
+ struct cmsghdr * control = CMSG_FIRSTHDR(&auth_message);
++#if defined (SCM_CREDENTIALS)
+ control->cmsg_len = CMSG_LEN(sizeof(struct ucred));
+ control->cmsg_level = SOL_SOCKET;
+ control->cmsg_type = SCM_CREDENTIALS;
+@@ -110,8 +120,17 @@
+ creds->pid = ::getpid();
+ creds->uid = ::getuid();
+ creds->gid = ::getgid();
++#elif defined (SCM_CREDS)
++ control->cmsg_len = CMSG_LEN(sizeof(struct cmsgcred));
++ control->cmsg_level = SOL_SOCKET;
++ control->cmsg_type = SCM_CREDS;
++ struct cmsgcred * creds = (struct cmsgcred *)CMSG_DATA(control);
++ creds->cmcred_pid = ::getpid();
++ creds->cmcred_uid = ::getuid();
++ creds->cmcred_gid = ::getgid();
++#endif
+
+- int serr = sendmsg(m_fd, &auth_message, 0);
++ int serr = sendmsg(fd, &auth_message, 0);
+
+ delete [] mcb;
+
diff --git a/net/cyphesis/pkg-plist b/net/cyphesis/pkg-plist
index efb3bd315096..6e3464d6b771 100644
--- a/net/cyphesis/pkg-plist
+++ b/net/cyphesis/pkg-plist
@@ -10,6 +10,10 @@ bin/cypasswd
bin/cyphesis
bin/cypython
etc/cyphesis/cyphesis.vconf
+etc/cyphesis/mars.d/basic.xml
+etc/cyphesis/mars.d/characters.xml
+etc/cyphesis/mars.d/environment.xml
+etc/cyphesis/mars.d/terrain.xml
etc/cyphesis/mason.d/animals.xml
etc/cyphesis/mason.d/basic.xml
etc/cyphesis/mason.d/buildings.xml
@@ -25,6 +29,10 @@ etc/cyphesis/mason.d/tasks.xml
etc/cyphesis/mason.d/terrain.xml
etc/cyphesis/mason.d/tools.xml
etc/cyphesis/mason.d/weapons.xml
+etc/cyphesis/minimal.d/basic.xml
+etc/cyphesis/minimal.d/characters.xml
+etc/cyphesis/minimal.d/environment.xml
+etc/cyphesis/minimal.d/terrain.xml
%%DATADIR%%/rulesets/basic/mind/Goal.py
%%DATADIR%%/rulesets/basic/mind/Knowledge.py
%%DATADIR%%/rulesets/basic/mind/Memory.py
@@ -56,12 +64,18 @@ etc/cyphesis/mason.d/weapons.xml
%%DATADIR%%/rulesets/basic/mind/panlingua/ontology.py
%%DATADIR%%/rulesets/basic/mind/panlingua/panlingua.py
%%DATADIR%%/rulesets/basic/mind/panlingua/syntax.py
+%%DATADIR%%/rulesets/mars/define_mars.py
+%%DATADIR%%/rulesets/mars/world/__init__.py
+%%DATADIR%%/rulesets/mars/world/objects/Weather.py
+%%DATADIR%%/rulesets/mars/world/objects/__init__.py
+%%DATADIR%%/rulesets/mars/world/statistics/Statistics.py
+%%DATADIR%%/rulesets/mars/world/statistics/__init__.py
%%DATADIR%%/rulesets/mason/benchmarks.py
%%DATADIR%%/rulesets/mason/define_world.py
%%DATADIR%%/rulesets/mason/define_world_aglanor.py
%%DATADIR%%/rulesets/mason/regression.py
-%%DATADIR%%/rulesets/mason/tests.py
%%DATADIR%%/rulesets/mason/terrain.py
+%%DATADIR%%/rulesets/mason/tests.py
%%DATADIR%%/rulesets/mason/world/__init__.py
%%DATADIR%%/rulesets/mason/world/objects/Pile.py
%%DATADIR%%/rulesets/mason/world/objects/Weather.py
@@ -104,27 +118,51 @@ etc/cyphesis/mason.d/weapons.xml
%%DATADIR%%/rulesets/mason/world/objects/undead/__init__.py
%%DATADIR%%/rulesets/mason/world/statistics/Statistics.py
%%DATADIR%%/rulesets/mason/world/statistics/__init__.py
+%%DATADIR%%/rulesets/mason/world/tasks/Baking.py
%%DATADIR%%/rulesets/mason/world/tasks/Bisect.py
+%%DATADIR%%/rulesets/mason/world/tasks/BuildBloomery.py
%%DATADIR%%/rulesets/mason/world/tasks/Combat.py
%%DATADIR%%/rulesets/mason/world/tasks/Cultivate.py
%%DATADIR%%/rulesets/mason/world/tasks/Delve.py
+%%DATADIR%%/rulesets/mason/world/tasks/Destroying.py
%%DATADIR%%/rulesets/mason/world/tasks/Dig.py
+%%DATADIR%%/rulesets/mason/world/tasks/Dragging.py
+%%DATADIR%%/rulesets/mason/world/tasks/Drying.py
+%%DATADIR%%/rulesets/mason/world/tasks/Earthbarrier.py
+%%DATADIR%%/rulesets/mason/world/tasks/Earthwall.py
%%DATADIR%%/rulesets/mason/world/tasks/Fishing.py
+%%DATADIR%%/rulesets/mason/world/tasks/Furnishings.py
+%%DATADIR%%/rulesets/mason/world/tasks/Gateconstruction.py
%%DATADIR%%/rulesets/mason/world/tasks/Heaping.py
+%%DATADIR%%/rulesets/mason/world/tasks/IronSmelting.py
%%DATADIR%%/rulesets/mason/world/tasks/Logging.py
+%%DATADIR%%/rulesets/mason/world/tasks/Pioneering.py
+%%DATADIR%%/rulesets/mason/world/tasks/Pioneeringconstruction.py
+%%DATADIR%%/rulesets/mason/world/tasks/Pulling.py
%%DATADIR%%/rulesets/mason/world/tasks/Raise.py
%%DATADIR%%/rulesets/mason/world/tasks/Ram.py
%%DATADIR%%/rulesets/mason/world/tasks/Reap.py
+%%DATADIR%%/rulesets/mason/world/tasks/Repairing.py
%%DATADIR%%/rulesets/mason/world/tasks/Sharpen.py
%%DATADIR%%/rulesets/mason/world/tasks/Sift.py
%%DATADIR%%/rulesets/mason/world/tasks/Slaughter.py
%%DATADIR%%/rulesets/mason/world/tasks/Slice.py
+%%DATADIR%%/rulesets/mason/world/tasks/Spell.py
%%DATADIR%%/rulesets/mason/world/tasks/Trailblaze.py
+%%DATADIR%%/rulesets/mason/world/tasks/Trenching.py
+%%DATADIR%%/rulesets/mason/world/tasks/Twirling.py
+%%DATADIR%%/rulesets/mason/world/tasks/Woodenwall.py
%%DATADIR%%/rulesets/mason/world/tasks/__init__.py
-%%DATADIR%%/scripts/cyphesis/__init__.py
+%%DATADIR%%/rulesets/minimal/define_minimal.py
+%%DATADIR%%/rulesets/minimal/world/__init__.py
+%%DATADIR%%/rulesets/minimal/world/objects/Weather.py
+%%DATADIR%%/rulesets/minimal/world/objects/__init__.py
+%%DATADIR%%/rulesets/minimal/world/statistics/Statistics.py
+%%DATADIR%%/rulesets/minimal/world/statistics/__init__.py
%%DATADIR%%/scripts/cyphesis/Thing.py
-%%DATADIR%%/scripts/cyphesis/probability.py
+%%DATADIR%%/scripts/cyphesis/__init__.py
%%DATADIR%%/scripts/cyphesis/editor.py
+%%DATADIR%%/scripts/cyphesis/probability.py
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -132,12 +170,15 @@ etc/cyphesis/mason.d/weapons.xml
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/FIXME
%%PORTDOCS%%%%DOCSDIR%%/conf/acorn.xml
%%PORTDOCS%%%%DOCSDIR%%/conf/basic.xml
%%PORTDOCS%%%%DOCSDIR%%/conf/cyphesis.vconf
%%PORTDOCS%%%%DOCSDIR%%/conf/mason.xml
%%PORTDOCS%%%%DOCSDIR%%/conf/werewolf.xml
+@dirrm etc/cyphesis/mars.d
@dirrm etc/cyphesis/mason.d
+@dirrm etc/cyphesis/minimal.d
@dirrm etc/cyphesis
@dirrm %%DATADIR%%/rulesets/basic/mind/goals/animal
@dirrm %%DATADIR%%/rulesets/basic/mind/goals/common
@@ -147,6 +188,10 @@ etc/cyphesis/mason.d/weapons.xml
@dirrm %%DATADIR%%/rulesets/basic/mind/panlingua
@dirrm %%DATADIR%%/rulesets/basic/mind
@dirrm %%DATADIR%%/rulesets/basic
+@dirrm %%DATADIR%%/rulesets/mars/world/statistics
+@dirrm %%DATADIR%%/rulesets/mars/world/objects
+@dirrm %%DATADIR%%/rulesets/mars/world
+@dirrm %%DATADIR%%/rulesets/mars
@dirrm %%DATADIR%%/rulesets/mason/world/objects/animals
@dirrm %%DATADIR%%/rulesets/mason/world/objects/buildings
@dirrm %%DATADIR%%/rulesets/mason/world/objects/clothing
@@ -161,6 +206,10 @@ etc/cyphesis/mason.d/weapons.xml
@dirrm %%DATADIR%%/rulesets/mason/world/tasks
@dirrm %%DATADIR%%/rulesets/mason/world
@dirrm %%DATADIR%%/rulesets/mason
+@dirrm %%DATADIR%%/rulesets/minimal/world/statistics
+@dirrm %%DATADIR%%/rulesets/minimal/world/objects
+@dirrm %%DATADIR%%/rulesets/minimal/world
+@dirrm %%DATADIR%%/rulesets/minimal
@dirrm %%DATADIR%%/rulesets
@dirrm %%DATADIR%%/scripts/cyphesis
@dirrm %%DATADIR%%/scripts
diff --git a/net/skstream/Makefile b/net/skstream/Makefile
index 295dff73cb4b..975f1ac74f46 100644
--- a/net/skstream/Makefile
+++ b/net/skstream/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: skstream
-# Date created: 3 February 2005
-# Whom: Janni
-#
+# Created by: Janni
# $FreeBSD$
-#
PORTNAME= skstream
-PORTVERSION= 0.3.8
+PORTVERSION= 0.3.9
CATEGORIES= net
MASTER_SITES= SF/worldforge/${PORTNAME}%20%28network%20lib%29/${PORTVERSION}
@@ -14,15 +10,18 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= An iostream based C++ socket library
USE_GMAKE= yes
-USE_GNOME= pkgconfig gnomehack
+USE_GNOME= gnomehack
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's| install-docdataDATA | |g' ${WRKSRC}/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docfile in README COPYING AUTHORS NEWS README.FreeSockets
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
diff --git a/net/skstream/distinfo b/net/skstream/distinfo
index 64ad6bd5048a..b8043c84840b 100644
--- a/net/skstream/distinfo
+++ b/net/skstream/distinfo
@@ -1,2 +1,2 @@
-SHA256 (skstream-0.3.8.tar.gz) = a0ceb95b6a239a5a3b82afece3f2832d3eaf1f9254d2d6d9011ca0c139103390
-SIZE (skstream-0.3.8.tar.gz) = 387412
+SHA256 (skstream-0.3.9.tar.gz) = e02096ea045d3d572d378e0bb10a80bfcfaf2c5c8829ec2cf7ae0d8a4164e8d4
+SIZE (skstream-0.3.9.tar.gz) = 413719
diff --git a/net/skstream/pkg-plist b/net/skstream/pkg-plist
index 44c053fc9525..2d588b538169 100644
--- a/net/skstream/pkg-plist
+++ b/net/skstream/pkg-plist
@@ -1,12 +1,10 @@
-lib/libskstream-0.3.la
-lib/libskstream-0.3.so
-lib/libskstream-0.3.so.6
-libdata/pkgconfig/skstream-0.3.pc
-libdata/pkgconfig/skstream-unix-0.3.pc
-lib/skstream-0.3/include/skstream/skstreamconfig.h
-@dirrm lib/skstream-0.3/include/skstream
-@dirrm lib/skstream-0.3/include
-@dirrm lib/skstream-0.3
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeSockets
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+include/skstream-0.3/skstream/skaddress.h
include/skstream-0.3/skstream/sksocket.h
include/skstream-0.3/skstream/skstream.h
include/skstream-0.3/skstream/skstream_unix.h
@@ -14,11 +12,14 @@ include/skstream-0.3/skstream/skserver.h
include/skstream-0.3/skstream/skserver_unix.h
include/skstream-0.3/skstream/skpoll.h
include/skstream-0.3/skstream/sasproto.h
+lib/libskstream-0.3.la
+lib/libskstream-0.3.so
+lib/libskstream-0.3.so.7
+libdata/pkgconfig/skstream-0.3.pc
+libdata/pkgconfig/skstream-unix-0.3.pc
+lib/skstream-0.3/include/skstream/skstreamconfig.h
@dirrm include/skstream-0.3/skstream
@dirrm include/skstream-0.3
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README.FreeSockets
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/skstream-0.3/include/skstream
+@dirrm lib/skstream-0.3/include
+@dirrm lib/skstream-0.3