aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2018-01-16 05:10:53 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:24:40 +0800
commite8503db4a7d719d9dc756b6caa8b1780ffe37179 (patch)
tree173736c5f43e6c978ad9666961eff1e0dc290986 /net
parent12a6eb7a23a09c6ff4c04429b63e679be870284e (diff)
downloadfreebsd-ports-gnome-e8503db4a7d719d9dc756b6caa8b1780ffe37179.tar.gz
freebsd-ports-gnome-e8503db4a7d719d9dc756b6caa8b1780ffe37179.tar.zst
freebsd-ports-gnome-e8503db4a7d719d9dc756b6caa8b1780ffe37179.zip
net/haproxy-devel: Fix linking SSL libs
- Pass lib and include paths to make - Optionsify PR: 225149 Approved by: demon (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/haproxy-devel/Makefile42
1 files changed, 15 insertions, 27 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index fd9559254ed3..fc88da42f990 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -31,31 +31,25 @@ SPCRE_DESC= Link statically
DEVICEATLAS_DESC= DeviceAtlas Device Detection support
OPTIONS_DEFAULT= SPCRE OPENSSL
-.include <bsd.port.options.mk>
+DPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
+DPCRE_MAKE_ARGS= USE_PCRE=1 USE_PCRE_JIT=1
+SPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
+SPCRE_MAKE_ARGS= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
+DEVICEATLAS_LIB_DEPENDS= libda.so:net/deviceatlas-enterprise-c
+DEVICEATLAS_MAKE_ARGS= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
+OPENSSL_USES= ssl
+OPENSSL_MAKE_ARGS= USE_OPENSSL=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
+LUA_USES= lua:53
+LUA_MAKE_ARGS= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}
-.if ${PORT_OPTIONS:MDPCRE}
-LIB_DEPENDS+= libpcre.so:devel/pcre
-MAKE_ARGS+= USE_PCRE=1 USE_PCRE_JIT=1
-.endif
-
-.if ${PORT_OPTIONS:MSPCRE}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcre.a:devel/pcre
-MAKE_ARGS+= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
-.endif
-
-.if ${PORT_OPTIONS:MDEVICEATLAS}
-LIB_DEPENDS+= libda.so:net/deviceatlas-enterprise-c
-MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
-.endif
+.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MOPENSSL}
-USES+= ssl
-MAKE_ARGS+= USE_OPENSSL=1
+.if ${ARCH} == "amd64" || ${ARCH} == "i386"
+MAKE_ARGS+= USE_REGPARM=1
.endif
-.if ${PORT_OPTIONS:MLUA}
-USES+= lua:53
-MAKE_ARGS+= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}
+.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
.endif
post-build:
@@ -70,10 +64,4 @@ do-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" || ${ARCH} == "i386"
-MAKE_ARGS+= USE_REGPARM=1
-.endif
-
.include <bsd.port.post.mk>