aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-09-06 06:05:35 +0800
committermandree <mandree@FreeBSD.org>2014-09-06 06:05:35 +0800
commiteb02227fad7d7a4d62e244a4cb76650f2de6b109 (patch)
tree693f4e756a55f86f220673d88c7093af9a61346f /net
parentd88ff08e48d1188413b2d2cd803badb4aa997dc5 (diff)
downloadfreebsd-ports-gnome-eb02227fad7d7a4d62e244a4cb76650f2de6b109.tar.gz
freebsd-ports-gnome-eb02227fad7d7a4d62e244a4cb76650f2de6b109.tar.zst
freebsd-ports-gnome-eb02227fad7d7a4d62e244a4cb76650f2de6b109.zip
Fix build on 8.x, by leveraging USE_BINUTILS=yes there (before 900033).
The older binutils are picky and error out when trying to strip .a files, the newer binutils just skip over things and print warnings. [1] Fix build with WITH_SSP[_PORTS]=yes, by not running together LDFLAGS expansions; this drops one hunk from files/patch-configure.in. Modernize USE_PYTHON and @unexec rmdir. PR: 192047 [1] Submitted by: feld@ [1], Janos Dohanics [1, to ports@]
Diffstat (limited to 'net')
-rw-r--r--net/ntop/Makefile16
-rw-r--r--net/ntop/files/patch-configure.in9
-rw-r--r--net/ntop/pkg-plist2
3 files changed, 14 insertions, 13 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 42cc23749bd8..1b99410d6783 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -22,10 +22,9 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
DBDIR?= /var/db
-USES= gmake libtool
+USES= gmake libtool python
USE_AUTOTOOLS= automake autoconf libtoolize
USE_GNOME= libxml2
-USE_PYTHON= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -79,6 +78,17 @@ CONFIGURE_ARGS+= --enable-jumbo-frames
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
.endif
+.include <bsd.port.pre.mk>
+
+# Quick and dirty hackaround - older binutils barf when asked to strip
+# an .a file, newer complain about missing sections and succeed.
+# The real fix would be for ntop to not try stripping .a files,
+# but upstream seems to have gone ahead with ntopng so this may not
+# ever be fixed.
+.if ${OSVERSION} < 900033
+USE_BINUTILS= yes
+.endif
+
pre-configure:
@cd ${WRKSRC} && ${SETENV} ${SCRIPTS_ENV} ${SH} autogen.sh --noconfig
@@ -88,4 +98,4 @@ pre-install:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ntop/plugins/*.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/ntop/files/patch-configure.in b/net/ntop/files/patch-configure.in
index 35aff5563304..780a4b50083c 100644
--- a/net/ntop/files/patch-configure.in
+++ b/net/ntop/files/patch-configure.in
@@ -1,14 +1,5 @@
--- configure.in.orig 2012-08-13 04:35:26.000000000 -0300
+++ configure.in 2013-01-09 13:11:12.000000000 -0200
-@@ -472,7 +472,7 @@
- dnl> Add /usr/local/ /opt/local
- CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
- CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
--LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
-+LDFLAGS="${LDFLAGS}-L/usr/local/lib -L/opt/local/lib"
-
- PWD=`pwd`
-
@@ -560,7 +560,7 @@
test -d ${TMP_ROOT} &&
test -r ${TMP_ROOT}/libpcap.a; then
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index e69f74879c47..15907b2054b4 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -509,4 +509,4 @@ man/man8/ntop.8.gz
@dirrm %%DATADIR%%
@exec mkdir -p %%DBDIR%%/ntop
@exec chown -R nobody:nobody %%DBDIR%%/ntop
-@unexec rmdir %%DBDIR%%/ntop 2>/dev/null || true
+@dirrmtry %%DBDIR%%/ntop