aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-03 01:04:19 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-03 01:04:19 +0800
commitebc8cd553242ce7eb22ceea5f93d8b7228e93c56 (patch)
tree21c32b17ad27262d21def2d94e36419907e27ad5 /net
parent863cab746f5dd32124a2af5217b1ed235f0171e4 (diff)
downloadfreebsd-ports-gnome-ebc8cd553242ce7eb22ceea5f93d8b7228e93c56.tar.gz
freebsd-ports-gnome-ebc8cd553242ce7eb22ceea5f93d8b7228e93c56.tar.zst
freebsd-ports-gnome-ebc8cd553242ce7eb22ceea5f93d8b7228e93c56.zip
- Allow concurrent installation (USE_PYTHON=concurrent)
- Add missing OPTIONS_DEFINE - Remove EXAMPLESDIR - Convert to new options target helper - Bump PORTREVISION for package change
Diffstat (limited to 'net')
-rw-r--r--net/py-GeoIP/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/py-GeoIP/Makefile b/net/py-GeoIP/Makefile
index 16339b6fb943..d1f31725771f 100644
--- a/net/py-GeoIP/Makefile
+++ b/net/py-GeoIP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= net python geography
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,11 +15,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+OPTIONS_DEFINE= EXAMPLES
+
CPPFLAGS+= -I${LOCALBASE}/include
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
USES= python shebangfix
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
PORTEXAMPLES= *
SHEBANG_FILES= examples/*.py
@@ -28,6 +30,8 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/GeoIP.so
+
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/examples/ && ${INSTALL_DATA} *.py ${STAGEDIR}${EXAMPLESDIR}/