aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortheraven <theraven@FreeBSD.org>2015-09-19 18:33:34 +0800
committertheraven <theraven@FreeBSD.org>2015-09-19 18:33:34 +0800
commitf410eb77efeec7636a0a08f7330d4821a1bcd4d0 (patch)
treeda5a3eeed8b9041e9805decaee1098282defef37 /net
parent1659ce0cba407df928696251d75c6308bec3077b (diff)
downloadfreebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.tar.gz
freebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.tar.zst
freebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.zip
Make all GNUstep ports install into the System domain so that the Local domain is available for stuff built from source.
Some ports were already installing in the System domain, for these just remove the Makefile lines explicitly specifying the install domain. The rest are installed in the Local domain, remove any overrides, update their pkg-plists and any explicit paths in the Makefiles and then bump port revision. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D2977
Diffstat (limited to 'net')
-rw-r--r--net/remotedesk/Makefile4
-rw-r--r--net/remotedesk/pkg-plist22
-rw-r--r--net/zillion/Makefile10
-rw-r--r--net/zillion/pkg-plist12
4 files changed, 24 insertions, 24 deletions
diff --git a/net/remotedesk/Makefile b/net/remotedesk/Makefile
index 0fab090400ab..2fb326349376 100644
--- a/net/remotedesk/Makefile
+++ b/net/remotedesk/Makefile
@@ -2,7 +2,7 @@
PORTNAME= remotedesk
PORTVERSION= 0.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net gnustep
MASTER_SITES= SAVANNAH/gap
DISTNAME= RemoteDesk-${PORTVERSION}
@@ -22,6 +22,6 @@ post-patch:
${WRKSRC}/GNUmakefile
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/RemoteDesk.app/RemoteDesk
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/RemoteDesk.app/RemoteDesk
.include <bsd.port.mk>
diff --git a/net/remotedesk/pkg-plist b/net/remotedesk/pkg-plist
index 5652b90bbbaf..1bba5b509c96 100644
--- a/net/remotedesk/pkg-plist
+++ b/net/remotedesk/pkg-plist
@@ -1,11 +1,11 @@
-GNUstep/Local/Applications/RemoteDesk.app/RemoteDesk
-GNUstep/Local/Applications/RemoteDesk.app/Resources/Info-gnustep.plist
-GNUstep/Local/Applications/RemoteDesk.app/Resources/LICENSE
-GNUstep/Local/Applications/RemoteDesk.app/Resources/README
-GNUstep/Local/Applications/RemoteDesk.app/Resources/RemoteDesk.desktop
-GNUstep/Local/Applications/RemoteDesk.app/Resources/RemoteDesk.gorm/data.classes
-GNUstep/Local/Applications/RemoteDesk.app/Resources/RemoteDesk.gorm/data.info
-GNUstep/Local/Applications/RemoteDesk.app/Resources/RemoteDesk.gorm/objects.gorm
-GNUstep/Local/Applications/RemoteDesk.app/Resources/remotedesk.tiff
-GNUstep/Local/Applications/RemoteDesk.app/stamp.make
-GNUstep/Local/Tools/RemoteDesk
+GNUstep/System/Applications/RemoteDesk.app/RemoteDesk
+GNUstep/System/Applications/RemoteDesk.app/Resources/Info-gnustep.plist
+GNUstep/System/Applications/RemoteDesk.app/Resources/LICENSE
+GNUstep/System/Applications/RemoteDesk.app/Resources/README
+GNUstep/System/Applications/RemoteDesk.app/Resources/RemoteDesk.desktop
+GNUstep/System/Applications/RemoteDesk.app/Resources/RemoteDesk.gorm/data.classes
+GNUstep/System/Applications/RemoteDesk.app/Resources/RemoteDesk.gorm/data.info
+GNUstep/System/Applications/RemoteDesk.app/Resources/RemoteDesk.gorm/objects.gorm
+GNUstep/System/Applications/RemoteDesk.app/Resources/remotedesk.tiff
+GNUstep/System/Applications/RemoteDesk.app/stamp.make
+GNUstep/System/Tools/RemoteDesk
diff --git a/net/zillion/Makefile b/net/zillion/Makefile
index 42985abb9e68..3d203ad0a061 100644
--- a/net/zillion/Makefile
+++ b/net/zillion/Makefile
@@ -2,7 +2,7 @@
PORTNAME= zillion
PORTVERSION= 0.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net gnustep
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-0_1
@@ -21,9 +21,9 @@ post-patch:
${REINPLACE_CMD} -e 's|^CC=|# CC=|' ${WRKSRC}/GNUmakefile
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/simpleZillionJob.bundle/simpleZillionJob
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Tools/zillion
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Tools/zillionClient
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Tools/zillionLoader
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/simpleZillionJob.bundle/simpleZillionJob
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Tools/zillion
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Tools/zillionClient
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Tools/zillionLoader
.include <bsd.port.mk>
diff --git a/net/zillion/pkg-plist b/net/zillion/pkg-plist
index 2f97481588e4..b5fd339c0b74 100644
--- a/net/zillion/pkg-plist
+++ b/net/zillion/pkg-plist
@@ -1,6 +1,6 @@
-GNUstep/Local/Library/Bundles/simpleZillionJob.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/simpleZillionJob.bundle/simpleZillionJob
-GNUstep/Local/Library/Bundles/simpleZillionJob.bundle/stamp.make
-GNUstep/Local/Tools/zillion
-GNUstep/Local/Tools/zillionClient
-GNUstep/Local/Tools/zillionLoader
+GNUstep/System/Library/Bundles/simpleZillionJob.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/simpleZillionJob.bundle/simpleZillionJob
+GNUstep/System/Library/Bundles/simpleZillionJob.bundle/stamp.make
+GNUstep/System/Tools/zillion
+GNUstep/System/Tools/zillionClient
+GNUstep/System/Tools/zillionLoader