aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2010-05-05 20:29:16 +0800
committertobez <tobez@FreeBSD.org>2010-05-05 20:29:16 +0800
commitf497d5742dea8cb9f8b9cdbf294c7a49d967fd02 (patch)
treee260119993cf39f3eabdb782e30dfa937963360a /net
parentd25b946e575e7565a163d90066f7c12ce441d6ba (diff)
downloadfreebsd-ports-gnome-f497d5742dea8cb9f8b9cdbf294c7a49d967fd02.tar.gz
freebsd-ports-gnome-f497d5742dea8cb9f8b9cdbf294c7a49d967fd02.tar.zst
freebsd-ports-gnome-f497d5742dea8cb9f8b9cdbf294c7a49d967fd02.zip
Add net/p5-Net-Appliance-Phrasebook 1.8, a Perl module that
implements a network appliance command-line phrasebook.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Appliance-Phrasebook/Makefile31
-rw-r--r--net/p5-Net-Appliance-Phrasebook/distinfo3
-rw-r--r--net/p5-Net-Appliance-Phrasebook/pkg-descr12
-rw-r--r--net/p5-Net-Appliance-Phrasebook/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6cf930f6f250..fd76a677a437 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -514,6 +514,7 @@
SUBDIR += p5-Net-Amazon-Signature
SUBDIR += p5-Net-Amazon-Thumbnail
SUBDIR += p5-Net-Analysis
+ SUBDIR += p5-Net-Appliance-Phrasebook
SUBDIR += p5-Net-BGP
SUBDIR += p5-Net-Blogger
SUBDIR += p5-Net-CIDR-Lite
diff --git a/net/p5-Net-Appliance-Phrasebook/Makefile b/net/p5-Net-Appliance-Phrasebook/Makefile
new file mode 100644
index 000000000000..6e7315dc019a
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: net/p5-Net-Appliance-Phrasebook
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Appliance-Phrasebook
+PORTVERSION= 1.8
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Network appliance command-line phrasebook
+
+BUILD_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/Data/Phrasebook.pm:${PORTSDIR}/textproc/p5-Data-Phrasebook \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Data/Phrasebook/Loader/YAML.pm:${PORTSDIR}/textproc/p5-Data-Phrasebook-Loader-YAML \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Appliance::Phrasebook.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Appliance-Phrasebook/distinfo b/net/p5-Net-Appliance-Phrasebook/distinfo
new file mode 100644
index 000000000000..71edb9756323
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Appliance-Phrasebook-1.8.tar.gz) = 96f16381de24e1058eef0138c20c96df
+SHA256 (Net-Appliance-Phrasebook-1.8.tar.gz) = 2419cfc891ff4a12ee7faa7b7ce2c26c1c5d7aef8ac4d26dbd811b2829406be6
+SIZE (Net-Appliance-Phrasebook-1.8.tar.gz) = 19555
diff --git a/net/p5-Net-Appliance-Phrasebook/pkg-descr b/net/p5-Net-Appliance-Phrasebook/pkg-descr
new file mode 100644
index 000000000000..2fa1334d74d6
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/pkg-descr
@@ -0,0 +1,12 @@
+If you use Perl to manage interactive sessions with with the
+command-line interfaces of networked appliances, then you might find
+this module useful.
+
+Net::Appliance::Phrasebook is a simple module that contains a number of
+dictionaries for the command-line interfaces of some popular network
+appliances.
+
+It also supports the use of custom phrasebooks, and of hiearchies of
+dictionaries within phrasebooks.
+
+WWW: http://search.cpan.org/dist/Net-Appliance-Phrasebook/
diff --git a/net/p5-Net-Appliance-Phrasebook/pkg-plist b/net/p5-Net-Appliance-Phrasebook/pkg-plist
new file mode 100644
index 000000000000..337546b3610b
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/Appliance/Phrasebook.pm
+%%SITE_PERL%%/Net/Appliance/Phrasebook/nas-pb.yml
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance/Phrasebook/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance/Phrasebook
+@dirrmtry %%SITE_PERL%%/Net/Appliance/Phrasebook
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Appliance
+@dirrmtry %%SITE_PERL%%/Net