aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2014-04-20 03:07:41 +0800
committermarcus <marcus@FreeBSD.org>2014-04-20 03:07:41 +0800
commitfd855f5766d241faf8b8abb4cb150f3b812b2a2e (patch)
treee8a8b2803aa503a5da7c575137bdf96c4084198e /net
parent21c8bc36de8188d1bf8c590b90cc4874480828c3 (diff)
downloadfreebsd-ports-gnome-fd855f5766d241faf8b8abb4cb150f3b812b2a2e.tar.gz
freebsd-ports-gnome-fd855f5766d241faf8b8abb4cb150f3b812b2a2e.tar.zst
freebsd-ports-gnome-fd855f5766d241faf8b8abb4cb150f3b812b2a2e.zip
* Convert to STAGE
* Only enable AppleTalk support on versions of FreeBSD that support it [1] PR: 187726
Diffstat (limited to 'net')
-rw-r--r--net/netatalk/Makefile35
-rw-r--r--net/netatalk/pkg-plist46
2 files changed, 56 insertions, 25 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 08c42dd97267..754a52c40283 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -27,8 +27,8 @@ CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-bdb=${LOCALBASE}
OPTIONS_DEFINE= APPLETALK SRVLOC PAM TIMELORD KRB5 ZEROCONF LDAP SENDFILE
-OPTIONS_DEFAULT= APPLETALK
-APPLETALK_DESC= AppleTalk protocol support
+OPTIONS_DEFAULT=APPLETALK
+APPLETALK_DESC= AppleTalk protocol support (where supported)
SRVLOC_DESC= Service Location Protocol support
TIMELORD_DESC= Timelord network time service
KRB5_DESC= Kerberos V UAM
@@ -38,18 +38,9 @@ SENDFILE_DESC= sendfile support
FILES= AppleVolumes.default AppleVolumes.system afpd.conf netatalk.conf
LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
binheader nadheader
-MAN1= ad.1 afpldaptest.1 afppasswd.1 apple_dump.1 asip-status.pl.1 \
- dbd.1 hqx2bin.1 macbinary.1 macusers.1 megatron.1 \
- netatalk-config.1 single2bin.1 unbin.1 unhex.1 uniconv.1 \
- unsingle.1
-MAN5= AppleVolumes.5 AppleVolumes.default.5 \
- AppleVolumes.system.5 afp_ldap.conf.5 afp_signature.conf.5 \
- afp_voluuid.conf.5 afpd.conf.5 netatalk.conf.5
-MAN8= afpd.8 cnid_dbd.8 cnid_metad.8 timelord.8
CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-1* yudit-[0-9]*
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKRB5}
@@ -59,15 +50,9 @@ PLIST_SUB+= NETATALKKRB5=""
PLIST_SUB+= NETATALKKRB5="@comment "
.endif
-.if ${PORT_OPTIONS:MAPPLETALK}
+.if ${OSVERSION} < 1100013 && ${PORT_OPTIONS:MAPPLETALK}
CONFIGURE_ARGS+= --enable-ddp
PLIST_SUB+= APPLETALK=""
-MAN1+= aecho.1 getzones.1 nbp.1 nbplkup.1 nbprgstr.1 \
- nbpunrgstr.1 pap.1 papstatus.1 psorder.1
-MAN3+= atalk_aton.3 nbp_name.3
-MAN4+= atalk.4
-MAN5+= atalkd.conf.5 papd.conf.5
-MAN8+= atalkd.8 papd.8 papstatus.8 psf.8
FILES+= atalkd.conf papd.conf
.else
PLIST_SUB+= APPLETALK="@comment "
@@ -128,17 +113,17 @@ post-patch:
${WRKSRC}/configure
post-install:
- @${RM} -f ${PREFIX}/bin/nu ${PREFIX}/bin/lp2pap.sh \
- ${PREFIX}/bin/test_parse_mtab \
- ${PREFIX}/bin/afpd-mtab.pl
+ @${RM} -f ${STAGEDIR}${PREFIX}/bin/nu ${STAGEDIR}${PREFIX}/bin/lp2pap.sh \
+ ${STAGEDIR}${PREFIX}/bin/test_parse_mtab \
+ ${STAGEDIR}${PREFIX}/bin/afpd-mtab.pl
${INSTALL_SCRIPT} ${WRKSRC}/contrib/macusers/macusers \
- ${PREFIX}/bin/macusers
+ ${STAGEDIR}${PREFIX}/bin/macusers
.for i in ${FILES}
- [ -f ${PREFIX}/etc/${i} ] || \
- ${INSTALL_DATA} -c ${PREFIX}/etc/${i}.dist ${PREFIX}/etc/${i}
+ [ -f ${STAGEDIR}${PREFIX}/etc/${i} ] || \
+ ${INSTALL_DATA} -c ${STAGEDIR}${PREFIX}/etc/${i}.dist ${STAGEDIR}${PREFIX}/etc/${i}
.endfor
.for i in ${LINKS}
- ( cd ${PREFIX}/bin && ${LN} -sf megatron ${i} )
+ ( cd ${STAGEDIR}${PREFIX}/bin && ${LN} -sf megatron ${i} )
.endfor
@${CAT} ${PKGMESSAGE}
diff --git a/net/netatalk/pkg-plist b/net/netatalk/pkg-plist
index 9559f5c4de22..80a06610120d 100644
--- a/net/netatalk/pkg-plist
+++ b/net/netatalk/pkg-plist
@@ -152,6 +152,52 @@ lib/libatalk.la
%%APPLETALK%%libexec/tfwmpaprev
%%APPLETALK%%libexec/tfwpap
%%APPLETALK%%libexec/tfwpaprev
+man/man1/ad.1.gz
+%%APPLETALK%%man/man1/aecho.1.gz
+man/man1/afpldaptest.1.gz
+man/man1/afppasswd.1.gz
+man/man1/apple_dump.1.gz
+man/man1/asip-status.pl.1.gz
+man/man1/dbd.1.gz
+%%APPLETALK%%man/man1/getzones.1.gz
+man/man1/hqx2bin.1.gz
+man/man1/macbinary.1.gz
+man/man1/macusers.1.gz
+man/man1/megatron.1.gz
+%%APPLETALK%%man/man1/nbp.1.gz
+%%APPLETALK%%man/man1/nbplkup.1.gz
+%%APPLETALK%%man/man1/nbprgstr.1.gz
+%%APPLETALK%%man/man1/nbpunrgstr.1.gz
+man/man1/netatalk-config.1.gz
+%%APPLETALK%%man/man1/pap.1.gz
+%%APPLETALK%%man/man1/papstatus.1.gz
+%%APPLETALK%%man/man1/psorder.1.gz
+man/man1/single2bin.1.gz
+man/man1/unbin.1.gz
+man/man1/unhex.1.gz
+man/man1/uniconv.1.gz
+man/man1/unsingle.1.gz
+%%APPLETALK%%man/man3/atalk_aton.3.gz
+%%APPLETALK%%man/man3/nbp_name.3.gz
+%%APPLETALK%%man/man4/atalk.4.gz
+man/man5/AppleVolumes.5.gz
+man/man5/AppleVolumes.default.5.gz
+man/man5/AppleVolumes.system.5.gz
+man/man5/afp_ldap.conf.5.gz
+man/man5/afp_signature.conf.5.gz
+man/man5/afp_voluuid.conf.5.gz
+man/man5/afpd.conf.5.gz
+%%APPLETALK%%man/man5/atalkd.conf.5.gz
+man/man5/netatalk.conf.5.gz
+%%APPLETALK%%man/man5/papd.conf.5.gz
+man/man8/afpd.8.gz
+%%APPLETALK%%man/man8/atalkd.8.gz
+man/man8/cnid_dbd.8.gz
+man/man8/cnid_metad.8.gz
+%%APPLETALK%%man/man8/papd.8.gz
+%%APPLETALK%%man/man8/papstatus.8.gz
+%%APPLETALK%%man/man8/psf.8.gz
+man/man8/timelord.8.gz
sbin/afpd
%%APPLETALK%%sbin/atalkd
sbin/cnid_dbd