aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormux <mux@FreeBSD.org>2006-01-28 09:46:32 +0800
committermux <mux@FreeBSD.org>2006-01-28 09:46:32 +0800
commit0123246cd2e7a04c8b995477ccf1e4664e93fb16 (patch)
tree7b1d222f78f361a1cde8b64a14aa403678fce225 /net
parentda1ac1fb90dfee3bfdc68bdf5cbeefdc3c3f5de5 (diff)
downloadfreebsd-ports-gnome-0123246cd2e7a04c8b995477ccf1e4664e93fb16.tar.gz
freebsd-ports-gnome-0123246cd2e7a04c8b995477ccf1e4664e93fb16.tar.zst
freebsd-ports-gnome-0123246cd2e7a04c8b995477ccf1e4664e93fb16.zip
Add a port for csup, the rewrite of CVSup in C.
While it still has some rough edges, it has reached a state where it's pretty much usable and this port will get me a wider audience for testing. Reviewed by: ahze
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/csup/Makefile22
-rw-r--r--net/csup/distinfo3
-rw-r--r--net/csup/pkg-descr11
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ab5e82439b57..63b4b1616ea8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -80,6 +80,7 @@
SUBDIR += cphone
SUBDIR += crescendo
SUBDIR += cryptcat
+ SUBDIR += csup
SUBDIR += ct
SUBDIR += ctorrent
SUBDIR += ctrace
diff --git a/net/csup/Makefile b/net/csup/Makefile
new file mode 100644
index 000000000000..9a133a64fc0b
--- /dev/null
+++ b/net/csup/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# New ports collection makefile for: csup
+# Date created: 27 January 2006
+# Whom: Maxime Henrion <mux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csup
+PORTVERSION= 20060127
+CATEGORIES= devel net
+MASTER_SITES= http://www.mu.org/~mux/
+DISTNAME= ${PORTNAME}-snap-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mux@FreeBSD.org
+COMMENT= A rewrite of the CVSup file updating client in C
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/csup
+
+.include <bsd.port.mk>
diff --git a/net/csup/distinfo b/net/csup/distinfo
new file mode 100644
index 000000000000..943144c7d31e
--- /dev/null
+++ b/net/csup/distinfo
@@ -0,0 +1,3 @@
+MD5 (csup-snap-20060127.tgz) = 2646387b0f3124c750d0e16ae1de08d7
+SHA256 (csup-snap-20060127.tgz) = 213ad9db0e4aa45c8d092149f1d4f821e73034386a4ea671f1fd1555d6d98f61
+SIZE (csup-snap-20060127.tgz) = 52222
diff --git a/net/csup/pkg-descr b/net/csup/pkg-descr
new file mode 100644
index 000000000000..bee5bda2a46c
--- /dev/null
+++ b/net/csup/pkg-descr
@@ -0,0 +1,11 @@
+Csup is a rewrite of CVSup in C.
+
+CVSup(R) is a software for distributing and updating collections of files
+accross a network. It can efficiently and accurately mirror all types of files,
+including sources, binaries, hard links, symbolic links, and even device nodes.
+In addition to being a great general-purpose mirroring tool, CVSup includes
+special features and optimizations specifically tailored to CVS repositories.
+It is being used as the preferred way to update sources within the FreeBSD,
+NetBSD and OpenBSD projects and more.
+
+WWW: http://mu.org/~mux/csup.html