aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 11:00:46 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 11:00:46 +0800
commit037277c495c4a69f56029e71eecf6838910561c8 (patch)
tree728a3619568ce38b9188fc0b8717a16a880d52d3 /net
parent944f55c3adc149ff34c18999a68dd201bd55600a (diff)
downloadfreebsd-ports-gnome-037277c495c4a69f56029e71eecf6838910561c8.tar.gz
freebsd-ports-gnome-037277c495c4a69f56029e71eecf6838910561c8.tar.zst
freebsd-ports-gnome-037277c495c4a69f56029e71eecf6838910561c8.zip
Add DOCS option for ports with PORTDOCS in plist.
Diffstat (limited to 'net')
-rw-r--r--net/aslookup/Makefile2
-rw-r--r--net/bmon/Makefile2
-rw-r--r--net/haproxy-devel/Makefile2
-rw-r--r--net/haproxy/Makefile2
-rw-r--r--net/ipsvd/Makefile4
-rw-r--r--net/libnids/Makefile2
-rw-r--r--net/lualdap/Makefile2
-rw-r--r--net/ntp-devel/Makefile.inc4
-rw-r--r--net/ntp/Makefile.inc4
-rw-r--r--net/openradius/Makefile2
-rw-r--r--net/ruby-dict/Makefile2
-rw-r--r--net/ruby-icmp/Makefile2
-rw-r--r--net/ruby-ldap/Makefile2
-rw-r--r--net/ruby-net-geoip/Makefile2
-rw-r--r--net/ruby-tserver/Makefile2
-rw-r--r--net/sniffit/Makefile2
-rw-r--r--net/ssltunnel-client/Makefile2
-rw-r--r--net/ssltunnel-server/Makefile2
-rw-r--r--net/tac_plus4/Makefile2
-rw-r--r--net/tcpsg/Makefile2
-rw-r--r--net/tigervnc/Makefile2
21 files changed, 38 insertions, 10 deletions
diff --git a/net/aslookup/Makefile b/net/aslookup/Makefile
index 53a33e5a0e84..88142d5869f9 100644
--- a/net/aslookup/Makefile
+++ b/net/aslookup/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}-alpha${PORTVERSION}
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Tool that searches the sequence of AS numbers
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -E -e "s|CFLAGS.*=|CFLAGS +=|" \
-e "s|CC.*=|CC ?=|" ${WRKSRC}/Makefile
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
index 3db12a15fd0f..cfaba67e1335 100644
--- a/net/bmon/Makefile
+++ b/net/bmon/Makefile
@@ -24,4 +24,6 @@ USE_AUTOTOOLS= libtoolize autoheader automake aclocal
AUTOMAKE_ARGS+= --add-missing
GNU_CONFIGURE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index 0f5ecfdbd45e..328c245c6eb5 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= haproxy-[1234567890]\*
USE_RC_SUBR= haproxy
SUB_FILES= pkg-message
-OPTIONS_DEFINE= PCRE OPENSSL
+OPTIONS_DEFINE= PCRE OPENSSL DOCS
OPTIONS_SINGLE= PCRE
OPTIONS_SINGLE_PCRE= DPCRE SPCRE
DPCRE_DESC= Link dynamically
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index cb4903b5b404..74439bd4e1c4 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -18,7 +18,7 @@ USES= gmake
USE_RC_SUBR= haproxy
SUB_FILES= pkg-message
-OPTIONS_DEFINE= OPENSSL
+OPTIONS_DEFINE= OPENSSL DOCS
OPTIONS_RADIO= PCRE
OPTIONS_RADIO_PCRE= DPCRE SPCRE
DPCRE_DESC= Link dynamically
diff --git a/net/ipsvd/Makefile b/net/ipsvd/Makefile
index a7624c397b3d..d37a03805d96 100644
--- a/net/ipsvd/Makefile
+++ b/net/ipsvd/Makefile
@@ -14,6 +14,8 @@ ALL_TARGET= default
DOCS= package/CHANGES package/COPYING package/README doc/*.html
+OPTIONS_DEFINE= DOCS
+
do-configure:
@${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
@${ECHO_CMD} "${CC} ${LDFLAGS}" > ${WRKSRC}/src/conf-ld
@@ -30,6 +32,6 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/*.${n} ${STAGEDIR}${MANPREFIX}/man/man${n}
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 65a454a1d419..e8ee0399d5c4 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
CONFLICTS?= libnids-libnet11-[0-9]*
-OPTIONS_DEFINE= GLIB2
+OPTIONS_DEFINE= GLIB2 DOCS
OPTIONS_DEFAULT=GLIB2
GLIB2_DESC= Use GLIB2 for multiprocessing support
OPTIONS_SUB= yes
diff --git a/net/lualdap/Makefile b/net/lualdap/Makefile
index 21effcf5d61f..4e2def439e39 100644
--- a/net/lualdap/Makefile
+++ b/net/lualdap/Makefile
@@ -24,6 +24,8 @@ MAKE_ARGS+= LUA_LIBDIR="${LUA_LIBDIR}" \
ALL_TARGET=
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/lualdap.so.${PORTVERSION} ${STAGEDIR}${LUA_MODLIBDIR}/${PORTNAME}.so
diff --git a/net/ntp-devel/Makefile.inc b/net/ntp-devel/Makefile.inc
index 12e15ed728f1..7f81d679efe2 100644
--- a/net/ntp-devel/Makefile.inc
+++ b/net/ntp-devel/Makefile.inc
@@ -52,7 +52,9 @@ OPTIONS_DEFINE= NTPSNMPD \
TRIMTAIP \
TRIMTSIP \
WHARTON \
- VARITEXT
+ VARITEXT \
+ DOCS \
+ EXAMPLES
OPTIONS_DEFAULT= SSL \
NTP_SIGND \
diff --git a/net/ntp/Makefile.inc b/net/ntp/Makefile.inc
index fd80df0690ba..6a9ee96b355b 100644
--- a/net/ntp/Makefile.inc
+++ b/net/ntp/Makefile.inc
@@ -50,7 +50,9 @@ OPTIONS_DEFINE= NTPSNMPD \
TRIMTAIP \
TRIMTSIP \
WHARTON \
- VARITEXT
+ VARITEXT \
+ DOCS \
+ EXAMPLES
OPTIONS_DEFAULT= SSL \
NTP_SIGND \
diff --git a/net/openradius/Makefile b/net/openradius/Makefile
index 3ebc52f69e02..6a8ccb0b387d 100644
--- a/net/openradius/Makefile
+++ b/net/openradius/Makefile
@@ -27,7 +27,7 @@ USES= gmake
USE_RC_SUBR= openradius
SUB_LIST= LOGFILE="${LOGFILE}"
-OPTIONS_DEFINE= LDAP
+OPTIONS_DEFINE= LDAP DOCS EXAMPLES
.include <bsd.port.options.mk>
diff --git a/net/ruby-dict/Makefile b/net/ruby-dict/Makefile
index 09193c880fca..a5a011cd1c3d 100644
--- a/net/ruby-dict/Makefile
+++ b/net/ruby-dict/Makefile
@@ -20,6 +20,8 @@ RUBY_SHEBANG_FILES= ${WRKSRC}/rdict
DOCS= Changelog README doc/dict.html doc/rdict.html
+OPTIONS_DEFINE= DOCS
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/rdict ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
diff --git a/net/ruby-icmp/Makefile b/net/ruby-icmp/Makefile
index 89f126f1f9ed..77a1ac17edb9 100644
--- a/net/ruby-icmp/Makefile
+++ b/net/ruby-icmp/Makefile
@@ -19,6 +19,8 @@ INSTALL_TARGET= site-install
EXAMPLES= sample/*
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
diff --git a/net/ruby-ldap/Makefile b/net/ruby-ldap/Makefile
index b2a6a87df0b5..66f701438746 100644
--- a/net/ruby-ldap/Makefile
+++ b/net/ruby-ldap/Makefile
@@ -14,6 +14,8 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to LDAP API based on RFC1823
+OPTIONS_DEFINE= DOCS
+
WITH_LDAP_BACKEND?= openldap2
.if ${WITH_LDAP_BACKEND} == ldapsdk
diff --git a/net/ruby-net-geoip/Makefile b/net/ruby-net-geoip/Makefile
index 457233bde49b..453e97440155 100644
--- a/net/ruby-net-geoip/Makefile
+++ b/net/ruby-net-geoip/Makefile
@@ -21,6 +21,8 @@ INSTALL_TARGET= site-install
DOCS= README
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
diff --git a/net/ruby-tserver/Makefile b/net/ruby-tserver/Makefile
index 3584dc03a324..44f04bdbc3fe 100644
--- a/net/ruby-tserver/Makefile
+++ b/net/ruby-tserver/Makefile
@@ -17,6 +17,8 @@ RUBY_SHEBANG_FILES= ${WRKSRC}/sample/*
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/tserver.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/net/sniffit/Makefile b/net/sniffit/Makefile
index a655e577d712..84c9ea624461 100644
--- a/net/sniffit/Makefile
+++ b/net/sniffit/Makefile
@@ -19,6 +19,8 @@ COMMENT= Packet sniffer program. For educational use
GNU_CONFIGURE= yes
ALL_TARGET=
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sniffit ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/sniffit.5 ${STAGEDIR}${MANPREFIX}/man/man5
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
index 4946b129ce87..cfafca3ef1d0 100644
--- a/net/ssltunnel-client/Makefile
+++ b/net/ssltunnel-client/Makefile
@@ -13,7 +13,7 @@ COMMENT= PPP over SSL virtual private networking (client part)
LICENSE= BSD3CLAUSE
-OPTIONS_DEFINE= GUI
+OPTIONS_DEFINE= GUI DOCS
GUI_DESC= GTK 1.2 graphical interface
CONFIGURE_ARGS= --disable-server --with-iconv=${ICONV_PREFIX}
diff --git a/net/ssltunnel-server/Makefile b/net/ssltunnel-server/Makefile
index e63e8706d26e..b1b2ed198a18 100644
--- a/net/ssltunnel-server/Makefile
+++ b/net/ssltunnel-server/Makefile
@@ -14,7 +14,7 @@ COMMENT= PPP over SSL virtual private networking (server part)
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS_DEFINE= TCPWRAPPERS
+OPTIONS_DEFINE= TCPWRAPPERS DOCS
TCPWRAPPERS_DESC= libwrap support
USE_RC_SUBR= ${PORTNAME}
diff --git a/net/tac_plus4/Makefile b/net/tac_plus4/Makefile
index dc5dfc093954..ac501ce3e98f 100644
--- a/net/tac_plus4/Makefile
+++ b/net/tac_plus4/Makefile
@@ -24,6 +24,8 @@ GROUPS= tacacs
CONFLICTS= ru-tac+ia-[0-9]* tac_plus-libradius-[0-9]*
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= DOCS
+
# check expiration dates against 'expire' field of master.passwd file
.if defined(TAC_EXPIRE_MASTER_PASSWD)
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-bb
diff --git a/net/tcpsg/Makefile b/net/tcpsg/Makefile
index 58c7c42bd77f..cc9ec189c79c 100644
--- a/net/tcpsg/Makefile
+++ b/net/tcpsg/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= mich@FreeBSD.org
COMMENT= Simple TCP port forwarder
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/tcpsg.c
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index 13cdd6f51efe..45495c0f96d4 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -40,7 +40,7 @@ USE_XORG+= bigreqsproto compositeproto damageproto fixesproto fontsproto glproto
CFLAGS+= -fPIC
-OPTIONS_DEFINE= GNUTLS NLS PAM VIEWER HPJPG
+OPTIONS_DEFINE= GNUTLS NLS PAM VIEWER HPJPG DOCS
OPTIONS_DEFAULT= GNUTLS NLS PAM VIEWER
VIEWER_DESC= Build vncviewer
HPJPG_DESC= Build with High-Performance JPEG support