aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2012-06-28 13:24:36 +0800
committerfjoe <fjoe@FreeBSD.org>2012-06-28 13:24:36 +0800
commit0379a7d2f246b90102a2ca21fb30edcf5a1c4a0f (patch)
tree2bdc59cf431acbbd8f536f09d3ec62d86ee79111 /net
parent58b8b823e6f311f0b5f2b24e65d1f0205bc91c50 (diff)
downloadfreebsd-ports-gnome-0379a7d2f246b90102a2ca21fb30edcf5a1c4a0f.tar.gz
freebsd-ports-gnome-0379a7d2f246b90102a2ca21fb30edcf5a1c4a0f.tar.zst
freebsd-ports-gnome-0379a7d2f246b90102a2ca21fb30edcf5a1c4a0f.zip
- Add support for MFC/R2 signaling using openr2 library.
- Bump PORTREVISION. Approved by: MAINTAINER
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile8
-rw-r--r--net/asterisk10/Makefile8
2 files changed, 10 insertions, 6 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 8ad793e43e4d..d13842241ec1 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.8.13.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -110,13 +111,14 @@ LIB_DEPENDS+= pt_r.1:${PORTSDIR}/devel/pwlib \
.if !defined(WITH_DAHDI)
PLIST_SUB+= WITH_DAHDI="@comment "
-CONFIGURE_ARGS+= --without-dahdi
+CONFIGURE_ARGS+= --without-dahdi --without-openr2
.else
PLIST_SUB+= WITH_DAHDI=""
-CONFIGURE_ARGS+= --with-dahdi
+CONFIGURE_ARGS+= --with-dahdi --with-openr2
BUILD_DEPENDS+= libpri>=1.4.10:${PORTSDIR}/misc/libpri \
${LOCALBASE}/include/dahdi/user.h:${PORTSDIR}/misc/dahdi
-LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri
+LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri\
+ openr2.4:${PORTSDIR}/misc/openr2
.endif
#
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 13b9bfb7ee00..88c3263a43cb 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 10.5.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -106,13 +107,14 @@ LIB_DEPENDS+= pt_r.1:${PORTSDIR}/devel/pwlib \
.if !defined(WITH_DAHDI)
PLIST_SUB+= WITH_DAHDI="@comment "
-CONFIGURE_ARGS+= --without-dahdi
+CONFIGURE_ARGS+= --without-dahdi --without-openr2
.else
PLIST_SUB+= WITH_DAHDI=""
-CONFIGURE_ARGS+= --with-dahdi
+CONFIGURE_ARGS+= --with-dahdi --with-openr2
BUILD_DEPENDS+= libpri>=1.4.10:${PORTSDIR}/misc/libpri \
${LOCALBASE}/include/dahdi/user.h:${PORTSDIR}/misc/dahdi
-LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri
+LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri\
+ openr2.4:${PORTSDIR}/misc/openr2
.endif
#