aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-05-09 10:46:09 +0800
committerwxs <wxs@FreeBSD.org>2009-05-09 10:46:09 +0800
commit07d4c25b16b552129bf5f6dde0fe4edb872316de (patch)
tree00d0bb737f33ec1602abd202e6f19289790644d9 /net
parent95a87c1acbb175b4660cd16d73a7b98fd8b33b2d (diff)
downloadfreebsd-ports-gnome-07d4c25b16b552129bf5f6dde0fe4edb872316de.tar.gz
freebsd-ports-gnome-07d4c25b16b552129bf5f6dde0fe4edb872316de.tar.zst
freebsd-ports-gnome-07d4c25b16b552129bf5f6dde0fe4edb872316de.zip
- Mark my ports as MAKE_JOBS_SAFE (with the exception of nethack34-gnome which
is MAKE_JOBS_UNSAFE).
Diffstat (limited to 'net')
-rw-r--r--net/bittwist/Makefile1
-rw-r--r--net/daemonlogger/Makefile1
-rw-r--r--net/honeyd/Makefile1
-rw-r--r--net/httpry/Makefile1
-rw-r--r--net/libpcap/Makefile1
-rw-r--r--net/net6/Makefile1
-rw-r--r--net/ntop/Makefile1
-rw-r--r--net/pktanon/Makefile1
-rw-r--r--net/silc-client/Makefile1
-rw-r--r--net/silc-server/Makefile1
-rw-r--r--net/sobby/Makefile1
-rw-r--r--net/tcpdump/Makefile1
-rw-r--r--net/tftpgrab/Makefile1
13 files changed, 13 insertions, 0 deletions
diff --git a/net/bittwist/Makefile b/net/bittwist/Makefile
index e7c805745f68..e2d4ab093136 100644
--- a/net/bittwist/Makefile
+++ b/net/bittwist/Makefile
@@ -16,6 +16,7 @@ COMMENT= Libpcap-based Ethernet packet generator, with PCAP editor
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}"
+MAKE_JOBS_SAFE= yes
MAN1= bittwist.1 bittwistb.1 bittwiste.1
PLIST_FILES= bin/bittwist bin/bittwistb bin/bittwiste
diff --git a/net/daemonlogger/Makefile b/net/daemonlogger/Makefile
index deb916e2cbe7..46a262d328a0 100644
--- a/net/daemonlogger/Makefile
+++ b/net/daemonlogger/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
USE_RC_SUBR= daemonlogger.sh
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/daemonlogger
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index 5ff1760a1cf6..997185498bca 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -23,6 +23,7 @@ USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
--with-libevent=${LOCALBASE}
+MAKE_JOBS_SAFE= yes
.if defined(WITH_PYTHON)
USE_PYTHON= 2.4
diff --git a/net/httpry/Makefile b/net/httpry/Makefile
index 32f50c310c15..745bfe066aab 100644
--- a/net/httpry/Makefile
+++ b/net/httpry/Makefile
@@ -16,6 +16,7 @@ COMMENT= Packet sniffer designed for displaying and logging HTTP traffic
MAN1= httpry.1
USE_RC_SUBR= httpry
+MAKE_JOBS_SAFE= yes
OPTIONS= EXTRASCRIPTS "Install additional scripts" Off
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index 55595ee0952f..dbc4e62fd473 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -16,6 +16,7 @@ COMMENT= Ubiquitous network traffic capture library
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= build
diff --git a/net/net6/Makefile b/net/net6/Makefile
index d51f42754b6b..c11ef6c634fc 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
+MAKE_JOBS_SAFE= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index eb01c00a2fa6..6d1a21991294 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
DBDIR?= /var/db
+MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:15 automake:19 autoconf:262
USE_GNOME= libxml2
USE_GMAKE= yes
diff --git a/net/pktanon/Makefile b/net/pktanon/Makefile
index 098030fa8744..61446032d148 100644
--- a/net/pktanon/Makefile
+++ b/net/pktanon/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost \
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+MAKE_JOBS_SAFE= yes
post-install:
${MKDIR} ${DATADIR}/profiles
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 1b165c69d1de..3753c1f377ee 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -30,6 +30,7 @@ COMMENT= Secure Internet Live Conferencing (SILC) network client
CONFLICTS= silc-toolkit-1.1.* silc-irssi-plugin-1.1.*
+MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib12
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index 943c76920018..b637d3285d73 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -30,6 +30,7 @@ COMMENT= Secure Internet Live Conferencing (SILC) network server
LIB_DEPENDS= silc-1.1:${PORTSDIR}/devel/silc-toolkit
+MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message pkg-deinstall
USE_RC_SUBR= silcd
USE_BZIP2= yes
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index 3db2f9d448ad..665e697fe443 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -25,6 +25,7 @@ MANCOMPRESSED= no
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/sobby
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index f995d31b465d..f45f40a8ff2e 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= pcap.3:${PORTSDIR}/net/libpcap \
GNU_CONFIGURE= yes
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
# Compilation Options
#
diff --git a/net/tftpgrab/Makefile b/net/tftpgrab/Makefile
index 6e1038918aa1..f8092a1d30b6 100644
--- a/net/tftpgrab/Makefile
+++ b/net/tftpgrab/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= wxs@FreeBSD.org
COMMENT= TFTP stream extractor
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/tftpgrab