aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2013-07-09 05:31:53 +0800
committerlippe <lippe@FreeBSD.org>2013-07-09 05:31:53 +0800
commit09502239c31cecd88903ec41faf9a1b7cd3844f0 (patch)
tree2aa530c58adf54b91bd2b276c1a2de7722f15ae3 /net
parent413de41cc8501095ea7862329ffebe8ba88af7db (diff)
downloadfreebsd-ports-gnome-09502239c31cecd88903ec41faf9a1b7cd3844f0.tar.gz
freebsd-ports-gnome-09502239c31cecd88903ec41faf9a1b7cd3844f0.tar.zst
freebsd-ports-gnome-09502239c31cecd88903ec41faf9a1b7cd3844f0.zip
Csync is a lightweight utility to synchronize files between two directories on
a system or between multiple systems. It synchronizes bidirectionally and allows the user to keep two copies of files and directories in sync. csync uses widely adopted protocols, such as smb or sftp, so that there is no need for a server component. It is a user-level program which means you do not to be a superuser or administrator. WWW: http://owncloud.org/sync-clients/ PR: ports/178946, ports/177900 Submitted by: arrowdodger <6yearold@gmail.com> Reviewed by: lippe@
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/owncloud-csync/Makefile36
-rw-r--r--net/owncloud-csync/distinfo2
-rw-r--r--net/owncloud-csync/files/patch-enodata27
-rw-r--r--net/owncloud-csync/files/patch-src-std-CMakeLists.txt10
-rw-r--r--net/owncloud-csync/files/patch-src-std-c_string.c11
-rw-r--r--net/owncloud-csync/pkg-descr9
-rw-r--r--net/owncloud-csync/pkg-plist50
8 files changed, 146 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 52e832384921..4210a771b965 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -498,6 +498,7 @@
SUBDIR += osrtspproxy
SUBDIR += ossp-sa
SUBDIR += ostinato
+ SUBDIR += owncloud-csync
SUBDIR += p5-AddressBook
SUBDIR += p5-Amazon-SQS-Simple
SUBDIR += p5-AnyEvent-MPRPC
diff --git a/net/owncloud-csync/Makefile b/net/owncloud-csync/Makefile
new file mode 100644
index 000000000000..b5053bb60baa
--- /dev/null
+++ b/net/owncloud-csync/Makefile
@@ -0,0 +1,36 @@
+# Created by: arrowdodger <6yearold@gmail.com>
+# $FreeBSD$
+
+PORTNAME= owncloud-csync
+PORTVERSION= 0.70.7
+CATEGORIES= net kde
+MASTER_SITES= http://download.owncloud.com/download/
+DISTNAME= ocsync-${PORTVERSION}
+
+MAINTAINER= 6yearold@gmail.com
+COMMENT= A csync fork for Owncloud
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv \
+ iniparser:${PORTSDIR}/devel/iniparser \
+ smbclient:${PORTSDIR}/net/samba-libsmbclient \
+ ssh:${PORTSDIR}/security/libssh \
+ neon:${PORTSDIR}/www/neon29
+
+USES= cmake:outsource
+USE_BZIP2= yes
+USE_PKGCONFIG= build
+USE_SQLITE= yes
+CMAKE_ARGS+= -DWITH_LOG4C=NO \
+ -DMAN_INSTALL_DIR=${MANPREFIX}/man
+
+MAN1= ocsync.1
+
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+DOCSDIR= /usr/local/share/doc/ocsync
+ETCDIR= /usr/local/etc/ocsync
+
+.include <bsd.port.mk>
diff --git a/net/owncloud-csync/distinfo b/net/owncloud-csync/distinfo
new file mode 100644
index 000000000000..41abf1faee39
--- /dev/null
+++ b/net/owncloud-csync/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ocsync-0.70.7.tar.bz2) = 571c7a822a8e30966c3a7e61a5218b49e8d52e70e8a8ec80d16db786d60bb324
+SIZE (ocsync-0.70.7.tar.bz2) = 2108498
diff --git a/net/owncloud-csync/files/patch-enodata b/net/owncloud-csync/files/patch-enodata
new file mode 100644
index 000000000000..a5199296c603
--- /dev/null
+++ b/net/owncloud-csync/files/patch-enodata
@@ -0,0 +1,27 @@
+From 199d6a1b07f8ce5d8009518b61b57768061d65b5 Mon Sep 17 00:00:00 2001
+From: arrowdodger <6yearold@gmail.com>
+Date: Tue, 19 Feb 2013 11:37:10 +0400
+Subject: [PATCH] Fix build for FreeBSD.
+
+---
+ src/std/c_private.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git src/std/c_private.h src/std/c_private.h
+index 2b1c6a3..bacd179 100644
+--- src/std/c_private.h
++++ src/std/c_private.h
+@@ -32,6 +32,10 @@
+ #endif
+
+
++#ifdef __FreeBSD__
++#define ENODATA 0
++#endif
++
+ #ifdef _WIN32
+ #define EDQUOT 0
+ #define ENODATA 0
+--
+1.8.1.3
+
diff --git a/net/owncloud-csync/files/patch-src-std-CMakeLists.txt b/net/owncloud-csync/files/patch-src-std-CMakeLists.txt
new file mode 100644
index 000000000000..ceeefbe63a51
--- /dev/null
+++ b/net/owncloud-csync/files/patch-src-std-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/std/_CMakeLists.txt 2013-02-20 20:39:16.000000000 +0400
++++ src/std/CMakeLists.txt 2013-03-16 14:16:52.896920438 +0400
+@@ -31,6 +31,7 @@
+ include_directories(
+ ${CSTDLIB_PUBLIC_INCLUDE_DIRS}
+ ${CSTDLIB_PRIVATE_INCLUDE_DIRS}
++ ${ICONV_INCLUDE_DIR}
+ )
+
+ add_library(${CSTDLIB_LIBRARY} STATIC ${cstdlib_SRCS})
diff --git a/net/owncloud-csync/files/patch-src-std-c_string.c b/net/owncloud-csync/files/patch-src-std-c_string.c
new file mode 100644
index 000000000000..42f115a20e50
--- /dev/null
+++ b/net/owncloud-csync/files/patch-src-std-c_string.c
@@ -0,0 +1,11 @@
+--- src/std/_c_string.c 2013-02-20 20:39:16.000000000 +0400
++++ src/std/c_string.c 2013-03-16 14:19:04.313916478 +0400
+@@ -83,7 +83,7 @@
+
+ static char *c_iconv(const char* str, enum iconv_direction dir)
+ {
+- char *in = (char*)str;
++ const char *in = (char*)str;
+ size_t size;
+ size_t outsize;
+ char *out;
diff --git a/net/owncloud-csync/pkg-descr b/net/owncloud-csync/pkg-descr
new file mode 100644
index 000000000000..5237b8f6c7cb
--- /dev/null
+++ b/net/owncloud-csync/pkg-descr
@@ -0,0 +1,9 @@
+Csync is a lightweight utility to synchronize files between two directories on
+a system or between multiple systems.
+
+It synchronizes bidirectionally and allows the user to keep two copies of files
+and directories in sync. csync uses widely adopted protocols, such as smb or
+sftp, so that there is no need for a server component. It is a user-level
+program which means you do not to be a superuser or administrator.
+
+WWW: http://owncloud.org/sync-clients/
diff --git a/net/owncloud-csync/pkg-plist b/net/owncloud-csync/pkg-plist
new file mode 100644
index 000000000000..c34d38e2dd2f
--- /dev/null
+++ b/net/owncloud-csync/pkg-plist
@@ -0,0 +1,50 @@
+bin/ocsync
+%%ETCDIR%%/ocsync.conf
+%%ETCDIR%%/ocsync_exclude.conf
+%%DOCSDIR%%/userguide/csync.html
+%%DOCSDIR%%/userguide/images/icons/README
+%%DOCSDIR%%/userguide/images/icons/callouts/1.png
+%%DOCSDIR%%/userguide/images/icons/callouts/10.png
+%%DOCSDIR%%/userguide/images/icons/callouts/11.png
+%%DOCSDIR%%/userguide/images/icons/callouts/12.png
+%%DOCSDIR%%/userguide/images/icons/callouts/13.png
+%%DOCSDIR%%/userguide/images/icons/callouts/14.png
+%%DOCSDIR%%/userguide/images/icons/callouts/15.png
+%%DOCSDIR%%/userguide/images/icons/callouts/2.png
+%%DOCSDIR%%/userguide/images/icons/callouts/3.png
+%%DOCSDIR%%/userguide/images/icons/callouts/4.png
+%%DOCSDIR%%/userguide/images/icons/callouts/5.png
+%%DOCSDIR%%/userguide/images/icons/callouts/6.png
+%%DOCSDIR%%/userguide/images/icons/callouts/7.png
+%%DOCSDIR%%/userguide/images/icons/callouts/8.png
+%%DOCSDIR%%/userguide/images/icons/callouts/9.png
+%%DOCSDIR%%/userguide/images/icons/caution.png
+%%DOCSDIR%%/userguide/images/icons/example.png
+%%DOCSDIR%%/userguide/images/icons/home.png
+%%DOCSDIR%%/userguide/images/icons/important.png
+%%DOCSDIR%%/userguide/images/icons/next.png
+%%DOCSDIR%%/userguide/images/icons/note.png
+%%DOCSDIR%%/userguide/images/icons/prev.png
+%%DOCSDIR%%/userguide/images/icons/tip.png
+%%DOCSDIR%%/userguide/images/icons/up.png
+%%DOCSDIR%%/userguide/images/icons/warning.png
+include/ocsync/csync.h
+include/ocsync/csync_vio.h
+include/ocsync/csync_vio_file_stat.h
+include/ocsync/csync_vio_handle.h
+include/ocsync/csync_vio_method.h
+include/ocsync/csync_vio_module.h
+lib/libocsync.so
+lib/libocsync.so.0
+lib/libocsync.so.0.2.0
+lib/ocsync-0/ocsync_owncloud.so
+lib/ocsync-0/ocsync_sftp.so
+lib/ocsync-0/ocsync_smb.so
+@dirrm lib/ocsync-0
+@dirrm include/ocsync
+@dirrmtry %%ETCDIR%%
+@dirrm %%DOCSDIR%%/userguide/images/icons/callouts
+@dirrm %%DOCSDIR%%/userguide/images/icons
+@dirrm %%DOCSDIR%%/userguide/images
+@dirrm %%DOCSDIR%%/userguide
+@dirrmtry %%DOCSDIR%%