aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-12-20 03:13:53 +0800
committerdemon <demon@FreeBSD.org>2001-12-20 03:13:53 +0800
commit0e75f7f1146597694c46622493ad5356ca04e24c (patch)
tree2ca49cfeb0b9c0a88399d6d55dffd52958ecd004 /net
parentf4de2abf8f0320786f6e9047119a08b4ed0a7fb8 (diff)
downloadfreebsd-ports-gnome-0e75f7f1146597694c46622493ad5356ca04e24c.tar.gz
freebsd-ports-gnome-0e75f7f1146597694c46622493ad5356ca04e24c.tar.zst
freebsd-ports-gnome-0e75f7f1146597694c46622493ad5356ca04e24c.zip
Define the -DSHAREDTMP option, since this allows one to simulate
clusters of pvm machines with jail(8). Basically, do this: ifconfig lo0 10.0.0.1 netmask 255.255.255.255 alias ifconfig lo0 10.0.0.2 netmask 255.255.255.255 alias ifconfig lo0 10.0.0.3 netmask 255.255.255.255 alias ... echo "10.0.0.1 ten-1" >> /etc/hosts echo "10.0.0.2 ten-2" >> /etc/hosts echo "10.0.0.3 ten-3" >> /etc/hosts ... jail / ten-1 10.0.0.1 /usr/libexec/inetd jail / ten-1 10.0.0.2 /usr/libexec/inetd jail / ten-1 10.0.0.3 /usr/libexec/inetd Tada! now you have three PVM enabled computers on your laptop :-) Submitted by: phk
Diffstat (limited to 'net')
-rw-r--r--net/pvm/Makefile1
-rw-r--r--net/pvm/files/patch-FREEBSD.def10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/pvm/Makefile b/net/pvm/Makefile
index fb81e886df70..63265f1f4cc0 100644
--- a/net/pvm/Makefile
+++ b/net/pvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pvm
PORTVERSION= 3.4.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.netlib.org/pvm3/ \
ftp://ftp.chg.ru/pub/prog/parallel/pvm/pvm3/
diff --git a/net/pvm/files/patch-FREEBSD.def b/net/pvm/files/patch-FREEBSD.def
new file mode 100644
index 000000000000..c140a5c4f2c5
--- /dev/null
+++ b/net/pvm/files/patch-FREEBSD.def
@@ -0,0 +1,10 @@
+--- conf/FREEBSD.def.orig Wed Dec 19 11:09:23 2001
++++ conf/FREEBSD.def Wed Dec 19 11:09:39 2001
+@@ -1,6 +1,6 @@
+ ARCHCFLAGS = -DSOCKADHASLEN -DNOREXEC -DRSHCOMMAND=\"/usr/bin/rsh\" \
+ -DHASSTDLIB -DNEEDMENDIAN -DHASERRORVARS \
+- -DFAKEXDRFLOAT -DSYSERRISCONST
++ -DFAKEXDRFLOAT -DSYSERRISCONST -DSHAREDTMP
+ ARCHDLIB =
+ ARCHDOBJ =
+ ARCHLIB = -lrpcsvc