aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-09-10 17:36:24 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-09-10 17:36:24 +0800
commit15b38b5514004d273025ede91480130f16564622 (patch)
treee74a0b6b88cc0ec1f3d7c7dbce6c947024faa650 /net
parent6e51e65aee60aa77c9f401b27854e079feba10cd (diff)
downloadfreebsd-ports-gnome-15b38b5514004d273025ede91480130f16564622.tar.gz
freebsd-ports-gnome-15b38b5514004d273025ede91480130f16564622.tar.zst
freebsd-ports-gnome-15b38b5514004d273025ede91480130f16564622.zip
Allow specifying config path in rc.conf
PR: 191601 Submitted by: daniel@blodan.se
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile2
-rw-r--r--net/rsync/files/rsyncd.in7
2 files changed, 6 insertions, 3 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 5a111d851229..c8271a8fe6c0 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rsync
PORTVERSION= 3.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://rsync.samba.org/ftp/%SUBDIR%/ \
ftp://ftp.samba.org/pub/%SUBDIR%/ \
diff --git a/net/rsync/files/rsyncd.in b/net/rsync/files/rsyncd.in
index 62540557eb34..d4ea0fe5b420 100644
--- a/net/rsync/files/rsyncd.in
+++ b/net/rsync/files/rsyncd.in
@@ -22,14 +22,17 @@ name="%%NAME%%"
rcvar=%%NAME%%_enable
command="%%PREFIX%%/bin/rsync"
-command_args="--daemon"
start_precmd="%%NAME%%_precmd"
pidfile="/var/run/$name.pid"
-required_files="%%ETCDIR%%/$name.conf"
# read configuration and set defaults
load_rc_config "$name"
: ${%%NAME%%_enable="NO"}
+: ${%%NAME%%_configfile:=%%ETCDIR%%/$name.conf}
+
+required_files="${%%NAME%%_configfile}"
+
+command_args="--daemon --config ${%%NAME%%_configfile}"
%%NAME%%_precmd()
{