aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2015-11-05 03:50:34 +0800
committergarga <garga@FreeBSD.org>2015-11-05 03:50:34 +0800
commit2218a80748559bc0ac380bb81904484a9c65ad7e (patch)
tree25d213695fb8caf6e5ba07150e6b47c8c7a4fda3 /net
parente21cb4109a5678e4625417b4505ccb2c31561bbb (diff)
downloadfreebsd-ports-gnome-2218a80748559bc0ac380bb81904484a9c65ad7e.tar.gz
freebsd-ports-gnome-2218a80748559bc0ac380bb81904484a9c65ad7e.tar.zst
freebsd-ports-gnome-2218a80748559bc0ac380bb81904484a9c65ad7e.zip
- Enable USE_CPU_AFFINITY, otherwise cpu-map parameter is going to fail
- Pet portlint - Bump PORTREVISION PR: 204280 Submitted by: garga Approved by: demon (maintainer) Obtained from: pfSense Sponsored by: Rubicon Communications (Netgate)
Diffstat (limited to 'net')
-rw-r--r--net/haproxy/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index e6df8797f3d9..ae1b80dd2c01 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= haproxy
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://www.haproxy.org/download/1.6/src/
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
@@ -20,7 +21,7 @@ USE_RC_SUBR= haproxy
DEVICEATLAS_VERSION= 2.1
DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
-DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
+DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
@@ -33,7 +34,7 @@ OPTIONS_DEFAULT= SPCRE OPENSSL
.include <bsd.port.options.mk>
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 CC="${CC}" CFLAGS="${CFLAGS}"
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS}"
.if ${PORT_OPTIONS:MDPCRE}
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
@@ -47,14 +48,14 @@ MAKE_ARGS+= USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.if ${PORT_OPTIONS:MDEVICEATLAS}
.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.zip)
-IGNORE?= You must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
+IGNORE?= you must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
.else
RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
DISTFILES+= ${DEVICEATLAS_DISTFILE}.zip
MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
.endif
.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
-IGNORE?= Enable PCRE support to use DeviceAtlas
+IGNORE?= enable PCRE support to use DeviceAtlas
.endif
.endif