aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-07-15 20:56:17 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-07-15 20:56:17 +0800
commit241e42f9a7121576a1ce5cb97d17d65d630bd3a9 (patch)
tree84ff5484233a4e8f468c22c956e546d2240d2004 /net
parent38e7166c2f1c7e14f0f5bc715452e30e040b3eeb (diff)
downloadfreebsd-ports-gnome-241e42f9a7121576a1ce5cb97d17d65d630bd3a9.tar.gz
freebsd-ports-gnome-241e42f9a7121576a1ce5cb97d17d65d630bd3a9.tar.zst
freebsd-ports-gnome-241e42f9a7121576a1ce5cb97d17d65d630bd3a9.zip
Make sure the binaries are linked against the port OpenSSL libraries when
and only when WITH_OPENSSL_PORT is defined. PR: 180395 (based on) Submitted by: "r4721@tormail.org" <r4721@tormail.org>
Diffstat (limited to 'net')
-rw-r--r--net/socat/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index b787ecd55320..eb55cb23c577 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -3,6 +3,7 @@
PORTNAME= socat
PORTVERSION= 1.7.2.2
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.dest-unreach.org/socat/download/ \
CRITICAL
@@ -28,6 +29,11 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
+.if defined(WITH_OPENSSL_PORT)
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif
+
.if(${OSVERSION} >= 1000024)
CCISCLANG!= ${CC} --version | ${HEAD} -1 | ${GREP} 'clang'
.endif