aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-29 15:49:31 +0800
committermiwi <miwi@FreeBSD.org>2008-09-29 15:49:31 +0800
commit2443bee549470406218d91fec49ed02162336fd2 (patch)
tree0e751eff464c361f9846991555bd88d626becea4 /net
parent7c4a74b9dac30e3fc4bf6e2839f7f9713f25158e (diff)
downloadfreebsd-ports-gnome-2443bee549470406218d91fec49ed02162336fd2.tar.gz
freebsd-ports-gnome-2443bee549470406218d91fec49ed02162336fd2.tar.zst
freebsd-ports-gnome-2443bee549470406218d91fec49ed02162336fd2.zip
Subclassable and hostless URIs
WWW: http://search.cpan.org/dist/URI-SmartURI/ PR: ports/127658 Submitted by: Oleg Mamontov <oleg at mamontov.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-URI-SmartURI/Makefile28
-rw-r--r--net/p5-URI-SmartURI/distinfo3
-rw-r--r--net/p5-URI-SmartURI/pkg-descr3
-rw-r--r--net/p5-URI-SmartURI/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 373c12e15f16..a74a01c15d6c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -625,6 +625,7 @@
SUBDIR += p5-URI
SUBDIR += p5-URI-FromHash
SUBDIR += p5-URI-OpenURL
+ SUBDIR += p5-URI-SmartURI
SUBDIR += p5-URI-Template
SUBDIR += p5-Validate-Net
SUBDIR += p5-What
diff --git a/net/p5-URI-SmartURI/Makefile b/net/p5-URI-SmartURI/Makefile
new file mode 100644
index 000000000000..02ce03afb71f
--- /dev/null
+++ b/net/p5-URI-SmartURI/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-URI-SmartURI
+# Date created: 2008-07-09
+# Whom: Oleg Mamontov <oleg@mamontov.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-SmartURI
+PORTVERSION= 0.025
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= oleg@mamontov.net
+COMMENT= Subclassable and hostless URIs
+
+RUN_DEPENDS= p5-Class-C3-Componentised>=0:${PORTSDIR}/devel/p5-Class-C3-Componentised \
+ p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MRO-Compat>=0.09:${PORTSDIR}/devel/p5-MRO-Compat \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= URI::SmartURI.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI-SmartURI/distinfo b/net/p5-URI-SmartURI/distinfo
new file mode 100644
index 000000000000..08c38dc8325a
--- /dev/null
+++ b/net/p5-URI-SmartURI/distinfo
@@ -0,0 +1,3 @@
+MD5 (URI-SmartURI-0.025.tar.gz) = aaec4a7aa427d60d892461a9721bd470
+SHA256 (URI-SmartURI-0.025.tar.gz) = aa783c680ebc680aaed6b193c2767ce2571c30809c6d4e9382acf16d4cda523d
+SIZE (URI-SmartURI-0.025.tar.gz) = 53202
diff --git a/net/p5-URI-SmartURI/pkg-descr b/net/p5-URI-SmartURI/pkg-descr
new file mode 100644
index 000000000000..7bda0271e166
--- /dev/null
+++ b/net/p5-URI-SmartURI/pkg-descr
@@ -0,0 +1,3 @@
+Subclassable and hostless URIs
+
+WWW: http://search.cpan.org/dist/URI-SmartURI/
diff --git a/net/p5-URI-SmartURI/pkg-plist b/net/p5-URI-SmartURI/pkg-plist
new file mode 100644
index 000000000000..57f223f4cba1
--- /dev/null
+++ b/net/p5-URI-SmartURI/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/URI/SmartURI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/SmartURI/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/SmartURI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI
+@dirrmtry %%SITE_PERL%%/URI