aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-25 18:57:00 +0800
committerkrion <krion@FreeBSD.org>2004-01-25 18:57:00 +0800
commit25c756027f15aec4ae318740a12283e47260fd39 (patch)
tree3705cb868ba4cd7f9e004306dae5b32686f783a8 /net
parent53593d32ca3d6fbabb961d9da1892748eab6a20e (diff)
downloadfreebsd-ports-gnome-25c756027f15aec4ae318740a12283e47260fd39.tar.gz
freebsd-ports-gnome-25c756027f15aec4ae318740a12283e47260fd39.tar.zst
freebsd-ports-gnome-25c756027f15aec4ae318740a12283e47260fd39.zip
Forgate (Forge Gateway) is a tool that allows you to capture
traffic from a third party in a switched environment at the expense of a slight increase in latency to that third party host. Utilizing ARP cache poisoning, packet capture, and packet reconstruction techniques, it works with nearly all TCP, ICMP, and UDP IPv4 traffic flows.
Diffstat (limited to 'net')
-rw-r--r--net/4g8/Makefile26
-rw-r--r--net/4g8/distinfo1
-rw-r--r--net/4g8/pkg-descr8
-rw-r--r--net/Makefile1
-rw-r--r--net/forgate/Makefile26
-rw-r--r--net/forgate/distinfo1
-rw-r--r--net/forgate/pkg-descr8
7 files changed, 71 insertions, 0 deletions
diff --git a/net/4g8/Makefile b/net/4g8/Makefile
new file mode 100644
index 000000000000..9bf0edc3ce9d
--- /dev/null
+++ b/net/4g8/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: forgate
+# Date created: 25.01.2004
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= forgate
+PORTVERSION= 0.9
+CATEGORIES= net
+MASTER_SITES= http://forgate.sourceforge.net/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Forgate is a tool that allows you to capture traffic
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= sbin/forgate
+
+.include <bsd.port.mk>
diff --git a/net/4g8/distinfo b/net/4g8/distinfo
new file mode 100644
index 000000000000..3640963ce557
--- /dev/null
+++ b/net/4g8/distinfo
@@ -0,0 +1 @@
+MD5 (forgate-0.9.tgz) = b5455f0c83547769bd486877362f9553
diff --git a/net/4g8/pkg-descr b/net/4g8/pkg-descr
new file mode 100644
index 000000000000..dcccdc438b60
--- /dev/null
+++ b/net/4g8/pkg-descr
@@ -0,0 +1,8 @@
+Forgate (Forge Gateway) is a tool that allows you to capture
+traffic from a third party in a switched environment at the
+expense of a slight increase in latency to that third party
+host. Utilizing ARP cache poisoning, packet capture, and packet
+reconstruction techniques, it works with nearly all TCP, ICMP,
+and UDP IPv4 traffic flows.
+
+WWW: http://forgate.sf.net
diff --git a/net/Makefile b/net/Makefile
index ac4a94da11a4..d0fd00773bc2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -142,6 +142,7 @@
SUBDIR += flow-tools
SUBDIR += flowscan
SUBDIR += forg
+ SUBDIR += forgate
SUBDIR += fpc-inet
SUBDIR += fping
SUBDIR += fprobe
diff --git a/net/forgate/Makefile b/net/forgate/Makefile
new file mode 100644
index 000000000000..9bf0edc3ce9d
--- /dev/null
+++ b/net/forgate/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: forgate
+# Date created: 25.01.2004
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= forgate
+PORTVERSION= 0.9
+CATEGORIES= net
+MASTER_SITES= http://forgate.sourceforge.net/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Forgate is a tool that allows you to capture traffic
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= sbin/forgate
+
+.include <bsd.port.mk>
diff --git a/net/forgate/distinfo b/net/forgate/distinfo
new file mode 100644
index 000000000000..3640963ce557
--- /dev/null
+++ b/net/forgate/distinfo
@@ -0,0 +1 @@
+MD5 (forgate-0.9.tgz) = b5455f0c83547769bd486877362f9553
diff --git a/net/forgate/pkg-descr b/net/forgate/pkg-descr
new file mode 100644
index 000000000000..dcccdc438b60
--- /dev/null
+++ b/net/forgate/pkg-descr
@@ -0,0 +1,8 @@
+Forgate (Forge Gateway) is a tool that allows you to capture
+traffic from a third party in a switched environment at the
+expense of a slight increase in latency to that third party
+host. Utilizing ARP cache poisoning, packet capture, and packet
+reconstruction techniques, it works with nearly all TCP, ICMP,
+and UDP IPv4 traffic flows.
+
+WWW: http://forgate.sf.net