aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2003-12-09 06:44:21 +0800
committerbms <bms@FreeBSD.org>2003-12-09 06:44:21 +0800
commit3c558f694160186c15dd59170cb9270e38386a42 (patch)
treeeccbbded8816dd76ce97b0ede3ae2ddc5bd497fa /net
parent8c4a467d776b503877e89d1986d20b2701d3c717 (diff)
downloadfreebsd-ports-gnome-3c558f694160186c15dd59170cb9270e38386a42.tar.gz
freebsd-ports-gnome-3c558f694160186c15dd59170cb9270e38386a42.tar.zst
freebsd-ports-gnome-3c558f694160186c15dd59170cb9270e38386a42.zip
New port: NoCatAuth-Server, the authentication server component of the
NoCat wireless captive portal authentication system.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/NoCatAuth-Server/Makefile42
-rw-r--r--net/NoCatAuth-Server/distinfo1
-rw-r--r--net/NoCatAuth-Server/files/patch-Makefile33
-rw-r--r--net/NoCatAuth-Server/files/patch-bin::detect-fw.sh11
-rw-r--r--net/NoCatAuth-Server/pkg-descr6
-rw-r--r--net/NoCatAuth-Server/pkg-install48
-rw-r--r--net/NoCatAuth-Server/pkg-plist66
8 files changed, 208 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0e3020141533..307e7b4091eb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -9,6 +9,7 @@
SUBDIR += GeoIP
SUBDIR += NeTraMet
SUBDIR += NoCatAuth-Gateway
+ SUBDIR += NoCatAuth-Server
SUBDIR += NoCatSplash
SUBDIR += SSLtelnet
SUBDIR += adasockets
diff --git a/net/NoCatAuth-Server/Makefile b/net/NoCatAuth-Server/Makefile
new file mode 100644
index 000000000000..c8b81b23b181
--- /dev/null
+++ b/net/NoCatAuth-Server/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: NoCatAuth
+# Date created: 19 November 2003
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Server
+PORTVERSION= 0.82
+CATEGORIES= net
+MASTER_SITES= http://nocat.net/download/NoCatAuth/
+PKGNAMEPREFIX= NoCatAuth-
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Open 802.11 Authentication Server
+
+RUN_DEPENDS= \
+ ${LOCALBASE}/bin/gpg:${PORTSDIR}/security/gnupg
+
+CONFLICTS= NoCatAuth-Gateway-*
+
+NO_BUILD= yes
+INSTALL_TARGET= authserv
+
+USE_PERL5_RUN= yes
+USE_GMAKE= yes
+USE_SUBMAKE= yes
+
+WRAP_USER?= nocat
+NOCATDIR?= nocat
+
+MAKE_ARGS+= DESTDIR=${PREFIX}/ PREFIX=${NOCATDIR}
+MAKE_ARGS+= WRAP_USER=${WRAP_USER}
+MAKE_ARGS+= -w
+
+pre-install:
+ @( ${FIND} ${WRKDIR} -type f -name '*.orig' -exec ${RM} '{}' ';' )
+ @${SETENV} NOCAT_DIR="${PREFIX}/${NOCATDIR}" WRAP=${WRAP_USER} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+.include <bsd.port.mk>
diff --git a/net/NoCatAuth-Server/distinfo b/net/NoCatAuth-Server/distinfo
new file mode 100644
index 000000000000..0d1bef43d14e
--- /dev/null
+++ b/net/NoCatAuth-Server/distinfo
@@ -0,0 +1 @@
+MD5 (NoCatAuth-0.82.tar.gz) = eaaa25b834c7f0bcfbe3270bc7b7f274
diff --git a/net/NoCatAuth-Server/files/patch-Makefile b/net/NoCatAuth-Server/files/patch-Makefile
new file mode 100644
index 000000000000..b97b15bfbe91
--- /dev/null
+++ b/net/NoCatAuth-Server/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig Sat May 17 15:35:14 2003
++++ Makefile Wed Nov 19 15:51:41 2003
+@@ -1,6 +1,6 @@
+ ### Install somewhere else if you've a mind (or aren't root).
+
+-PREFIX = /usr/local/nocat
++PREFIX ?= /usr/local/nocat
+
+ ### DESTDIR allows packagers to temporarily install somewhere else.
+
+@@ -35,7 +35,7 @@
+
+ check_fw:
+ @echo -n "Checking for firewall compatibility: "
+- @bin/detect-fw.sh bin || ( echo "Can't seem to find supported firewall software. Check your path?" && exit 255 )
++ @bin/detect-fw.sh ${FIREWALL} bin || ( echo "Can't seem to find supported firewall software. Check your path?" && exit 255 )
+
+ check_gpg:
+ @echo "Looking for gpg..."
+@@ -62,10 +62,10 @@
+ $(INSTALL) $(INST_GW) $(TARGET)
+
+ wrapper: check_fw
+- FW_BIN=`bin/detect-fw.sh | cut -d' ' -f1`; \
+- ln -sf fw-wrap bin/`basename $$FW_BIN`; \
++ FW_BIN=`bin/detect-fw.sh ${FIREWALL} bin | cut -d' ' -f1`; \
++ ln -sf fw-wrap bin/`basename ${FW_BIN}`; \
+ gcc -o bin/fw-wrap -Wall -DALLOWED_UID=\"$(WRAP_USER)\" \
+- -DFW_BINARY=\"$$FW_BIN\" \
++ -DFW_BINARY=\"${FW_BINARY}\" \
+ etc/fw-wrap.c
+ chmod u+s bin/fw-wrap
+
diff --git a/net/NoCatAuth-Server/files/patch-bin::detect-fw.sh b/net/NoCatAuth-Server/files/patch-bin::detect-fw.sh
new file mode 100644
index 000000000000..c8bc8dcf89b1
--- /dev/null
+++ b/net/NoCatAuth-Server/files/patch-bin::detect-fw.sh
@@ -0,0 +1,11 @@
+--- bin/detect-fw.sh.orig Fri Aug 9 07:28:43 2002
++++ bin/detect-fw.sh Wed Nov 19 15:51:16 2003
+@@ -3,7 +3,7 @@
+ export PATH=$PATH:/sbin:/usr/sbin:/usr/local/sbin
+
+ # Have we been explicitly told which firewall scripts to install?
+-if [ -n "$1" -a -n "$2" -a -d "$2/$1" ]; then
++if [ -n "$1" -a -n "$2" ]; then
+ FIREWALL=$1
+ shift
+
diff --git a/net/NoCatAuth-Server/pkg-descr b/net/NoCatAuth-Server/pkg-descr
new file mode 100644
index 000000000000..7ee6a47bb0de
--- /dev/null
+++ b/net/NoCatAuth-Server/pkg-descr
@@ -0,0 +1,6 @@
+This is the authorization server component of the NoCat system. Please note
+that the gpg target is not currently used or installed, and the message
+regarding 'make pgpkeys' should be disregarded for the time being.
+
+Bruce
+bms@FreeBSD.org
diff --git a/net/NoCatAuth-Server/pkg-install b/net/NoCatAuth-Server/pkg-install
new file mode 100644
index 000000000000..73769bdea007
--- /dev/null
+++ b/net/NoCatAuth-Server/pkg-install
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin
+
+if [ -z "${ENABLE_USER}" ]; then
+ ENABLE_USER=nocat
+fi
+
+if [ -z "${ENABLE_GROUP}" ]; then
+ ENABLE_GROUP=nocat
+fi
+
+case $2 in
+ PRE-INSTALL)
+ UID=181
+ GID=${UID}
+ if pw group show "${ENABLE_GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${ENABLE_GROUP}\", so I will use it."
+ else
+ if pw groupadd ${ENABLE_GROUP} -g ${GID}; then
+ echo "Added group \"${ENABLE_GROUP}\."
+ else
+ echo "Adding group \"${ENABLE_GROUP}\" failed."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${ENABLE_USER}" 2>/dev/null; then
+ echo "You already have a user \"${ENABLE_USER}\", so I will use it."
+ if pw usermod ${ENABLE_USER} -d ${NOCAT_DIR}
+ then
+ echo "Changed home directory of \"${ENABLE_USER}\" to \"${SYSCONF_DIR}\""
+ else
+ "${SYSCONF_DIR}\" failed..."
+ exit 1
+ fi
+ else
+ if pw useradd ${ENABLE_USER} -u ${UID} -g ${ENABLE_GROUP} -h \
+ -d ${SYSCONF_DIR} -s /sbin/nologin -c "NoCat Daemon"
+ then
+ echo "Added user \"${ENABLE_USER}\"."
+ else
+ echo "Adding user \"${ENABLE_USER}\" failed..."
+ exit 1
+ fi
+ fi
+ ;;
+esac
diff --git a/net/NoCatAuth-Server/pkg-plist b/net/NoCatAuth-Server/pkg-plist
new file mode 100644
index 000000000000..9126ad38c8b2
--- /dev/null
+++ b/net/NoCatAuth-Server/pkg-plist
@@ -0,0 +1,66 @@
+nocat/pgp/trustedkeys.gpg
+@dirrm nocat/pgp
+nocat/nocat.conf
+nocat/lib/NoCat/User.pm
+nocat/lib/NoCat/Source/Samba.pm
+nocat/lib/NoCat/Source/RADIUS.pm
+nocat/lib/NoCat/Source/Passwd.pm
+nocat/lib/NoCat/Source/PAM.pm
+nocat/lib/NoCat/Source/NIS.pm
+nocat/lib/NoCat/Source/LDAP.pm
+nocat/lib/NoCat/Source/IMAP.pm
+nocat/lib/NoCat/Source/DBI.pm
+nocat/lib/NoCat/Source.pm
+@dirrm nocat/lib/NoCat/Source
+nocat/lib/NoCat/Peer.pm
+nocat/lib/NoCat/Message.pm
+nocat/lib/NoCat/Group.pm
+nocat/lib/NoCat/Gateway/Passive.pm
+nocat/lib/NoCat/Gateway/Open.pm
+nocat/lib/NoCat/Gateway/Captive.pm
+nocat/lib/NoCat/Gateway.pm
+@dirrm nocat/lib/NoCat/Gateway
+nocat/lib/NoCat/Firewall.pm
+nocat/lib/NoCat/AuthService.pm
+nocat/lib/NoCat.pm
+@dirrm nocat/lib/NoCat
+@dirrm nocat/lib
+nocat/httpd.conf
+nocat/htdocs/update.html
+nocat/htdocs/status.html
+nocat/htdocs/splash.html
+nocat/htdocs/renew_pasv.html
+nocat/htdocs/renew.html
+nocat/htdocs/register_ok.html
+nocat/htdocs/register.html
+nocat/htdocs/logout.html
+nocat/htdocs/login_ok.html
+nocat/htdocs/login.html
+nocat/htdocs/login-no-skip.html
+nocat/htdocs/images/update.gif
+nocat/htdocs/images/skip.gif
+nocat/htdocs/images/reset.gif
+nocat/htdocs/images/register.gif
+nocat/htdocs/images/logout.gif
+nocat/htdocs/images/login.gif
+nocat/htdocs/images/continue.gif
+nocat/htdocs/images/auth_logo.gif
+@dirrm nocat/htdocs/images
+nocat/htdocs/fatal.html
+nocat/htdocs/expired.html
+@dirrm nocat/htdocs
+nocat/etc/passwd
+nocat/etc/groupadm
+nocat/etc/group
+@dirrm nocat/etc
+nocat/cgi-bin/update
+nocat/cgi-bin/register
+nocat/cgi-bin/login
+nocat/cgi-bin/admlogin
+@dirrm nocat/cgi-bin
+nocat/bin/vtun.sh
+nocat/bin/gateway
+nocat/bin/detect-fw.sh
+nocat/bin/admintool
+@dirrm nocat/bin
+@dirrm nocat